x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Ever since 4.8, everything seems to slow down when playing.

I have already posted something like this in the forum, I think?

But I still don't understand it, sorry.

I've never had any problem with 4.7.6. But 4,8.X and 4.9.X and the preview of 4.10 are just not running well. I have no idea why. It only slows down then I play it the level. I can somewhat play it on Low but Medium and up just makes it slow down to a crawl. I am using a laptop. I have tried making it use Nvidia instead of Intel (Integrated). I have tried r.GraphicsAdapter=0 (the same). But it's still slowing down. I have an okay laptop. 3.1GHz (8 CPUs) and 12GB RAM. Like I said, 4.7 runs just fine. Tested with the same scene, etc. What is the cause of the slowdown? It's only when I play it. (Simulate, Play In Editor, Launch)

Thank you very much for reading this!

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Oct 16 '15 at 02:58 PM in Using UE4

avatar image

Lucas-san
110 7 15 19

avatar image Lucas-san Oct 16 '15 at 03:00 PM

Okay, so I haven't posted it anywhere else. I posted it as a comment in one of my other questions.

"Ah, no, I actually made the scene in 4.7.6 and converted it to 4.8.0 but then I had this weird overly blown color and this horrible, horrible slowdown whenever I would "Play" the project. So, I, then, decided to remake the project in 4.8.0 from the scratch it worked. Well, actually, I was able to copy the objects in the scene directly from 4.7.6 to 4.8.1, as in "Copy/Paste" as long as the objects had the same name it would work. The game goes for the lights and such. You can't do it the other way around due to some of properties have been modified, I guess? Anyhow, I have now redone it, again and I am back to the more stable and faster 4.7.6.

However, if anyone has a solution, feel free to post it here.

And thank you very much or you comments and help."

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try debugging it using the built-in debugging tools. I had a similar problem once with creating UMG widgets every frame after about 5 minutes it would get down to about 1FPS until i stopped "playing" i had to use the debugging tool to find out what was causing the slowdown and traced it to my blueprints.

more ▼

answered Oct 16 '15 at 10:41 PM

avatar image

MrGrr
986 34 3 41

avatar image Lucas-san Oct 16 '15 at 10:56 PM

Thank you! I will see if I can find anything! Is it "Test Suite" or "Flush Font Cache"?

avatar image Lucas-san Oct 16 '15 at 11:25 PM

I found this in the output log: "LogActor:Warning: GameSession /Game/Maps/UEDPIE_0_HeadTest3.HeadTest3:PersistentLevel.GameSession_4 has natively added scene component(s), but none of them were set as the actor's RootComponent - picking one arbitrarily". I will keep looking. :)

avatar image Lucas-san Oct 17 '15 at 06:43 PM

Found another: "LogRenderTargetPool:Warning: r.RenderTargetPoolMin exceeded 1451/400 MB (ok in editor, bad on fixed memory platform)"

avatar image Lucas-san Oct 18 '15 at 03:44 AM

Okay, I did some tests. It seems that if the scene is empty and I click "Play", it will run fine. But if I place a cube something, it will slow down. I really have no idea what is causing this.

avatar image MrGrr Oct 21 '15 at 10:22 AM

using the standard cube and standard materials?

what about a blank project? (to eliminate anything in your blueprints/c++) if it happens with a blank project.... i'm not sure.

avatar image Lucas-san Oct 21 '15 at 11:52 AM

Yeah, it's a standard cube and standard materials. :/

If it's blank (completely black) then it runs fine..? I actually don't know, since everything is black. But it just feels like it's not slowing down. In fact, no, I can feel it. When it slows down, it's slowing down overall.

Thank you for doing your best to help me. :)

avatar image MrGrr Oct 22 '15 at 07:34 AM

and the standard templates like the FPS template? then try copy and pasting a few hundred cubes or similar, if its still snappy, it might be something you added at some point?

avatar image Lucas-san Oct 23 '15 at 02:43 PM

Hmm, it doesn't play well from the get-go. But..it's like it's, uh, "collecting"/"building" up something, uh..that eats away at the memory. Because if I let it "Play" for a while and "Stop" it, it doesn't go back to normal.

In other words:

100% = Before pressing "Start" 10% - 1% = (perfomence decreases after a short while) After pressing "Start" 90% - 15% = (depending on when I stop it) Stopping it.

I am not a techy guy, at all, so I don't know if it makes sense.

avatar image Lucas-san Oct 25 '15 at 02:24 PM

Okay, I tried pausing the simulation and however it doesn't change anything. Only when I press stop, it stops.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question