x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Is there a way to limit GPU usage?

I am new to UDK and am following the programming quick start guide from the documentation website. After creating a new blank project the Unreal Editor starts. Right away my GPU activity jumps to 98% as seen in the AMD Catalyst Control Center -> Performance -> AMD Overdrive page. As soon as I close the Unreal Editor the activity drops back to 0%.

I am running Windows 8 with an AMD 7950 video card. I am running catalyst version 13.12.

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Apr 19 '14 at 03:02 AM in Using UE4

avatar image

jpetra
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

In the top right corner of the Editor there is an input field for console commands. Try to enter t.MaxFPS 30 , that will limit the fps to 30. I do this a lot, so that the gpu doesn't run at 99% all the time.

more ▼

answered Apr 19 '14 at 10:22 AM

avatar image

Yibby
141 5 6 65

avatar image tas May 07 '14 at 04:42 AM

"t.MaxFPS 20" works like a charm to limit GPU usage ( along with Realtime checkbox), unfortunately it also affects BluePrint Editor. Panning becomes very choppy...

Is it possible to limit only viewport FPS, without BP editor ?

thanks!

avatar image tas May 07 '14 at 05:24 AM

and how can I execute this command each time I start editor/project ?

I tried to put it in config files, but not luck.

avatar image tas May 07 '14 at 06:58 AM

found file to edit to get low FPS at startup

C:\Program Files\Unreal Engine\4.1\Engine\Config\Windows\WindowsEngine.ini

add this line at the bottom

t.MaxFPS=10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Does it stay at 98% when you turn Realtime(from the drop down menu that opens with the little arrow in the corner of viewport) off as well?

more ▼

answered Apr 19 '14 at 03:06 AM

avatar image

Jacky
16.8k 671 167 676

avatar image jpetra Apr 19 '14 at 03:11 AM

When I turn realtime off the activity drops to 10-20 percent. At least my GPU fans stay off now.Thanks!

avatar image jpetra Apr 19 '14 at 03:14 AM

It still jumps up to 98% as I rotate/move around the viewport though.

avatar image Jacky Apr 19 '14 at 03:16 AM

That is normal, when you turn realtime off it renders only when you interact with the level.

avatar image jpetra Apr 19 '14 at 03:17 AM

Ok. Thanks for the help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question