x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linux: editing linux demos?

Hi all,

I'm new to UE4; I'd like to be able to edit some of the downloadable Linux demos.

I've downloaded, compiled and got the editor running under linux. I can run all of the demos under linux.

But I cannot figure out how to, for example, edit the "Sun Temple" demo in Linux.

I found the UnrealPak executable, which I can run on the SunTemple pak file; this results in a .uproject file that I can attempt to load in the editor.

However, whenever I try to open the project, I am presented with a dialog box that says the version of the editor I'm using, and the version the project was created with, don't match. There are several options from there (convert in-place, skip conversion, copy, etc.).

No matter what I select, the editor makes some progress, but always ends up with a segfault. Here's a typical output:

 [2015.10.16-21.19.20:683][  0]LogFileManager:Warning: ReadFile failed: Count=0 Length=1702194220 Error=No system errors available on this platform. for file ../../../../../pak/SunTemple 4.10/Content/Blueprints/FirstPersonCharacter.uasset
 Signal 11 caught.
 EngineCrashHandler: Signal=11

So, a couple of questions:

1) Am I doing this the right way? Or is there a better way to open a pak file directly in the editor?

2) Any hints on what might be causing this error?

I have also tried pulling 4.10, compiling and running; I get the same error.

System setup: Ubuntu 14.04; 64G RAM; Titan X GPU; all updates installed.

Any help would be appreciated. Thanks!

David

P.S. Update: I got a core dump, and traced it; it looks like the error is here:

 #16 0x00007f2656331074 in FPackageReader::OpenPackageFile (this=0x7f2600b7d570, InPackageFilename=...)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/AssetRegistry/Private/PackageReader.cpp:32
 **32              *this << PackageFileSummary;**

Here is the full dump:

 gdb ./UE4Editor core
 GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
 Copyright (C) 2014 Free Software Foundation, Inc.
 License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
 This is free software: you are free to change and redistribute it.
 There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
 and "show warranty" for details.
 This GDB was configured as "x86_64-linux-gnu".
 Type "show configuration" for configuration details.
 For bug reporting instructions, please see:
 <http://www.gnu.org/software/gdb/bugs/>.
 Find the GDB manual and other documentation resources online at:
 <http://www.gnu.org/software/gdb/documentation/>.
 For help, type "help".
 Type "apropos word" to search for commands related to "word"...
 Reading symbols from ./UE4Editor...done.
 [New LWP 8085]
 [New LWP 8042]
 [New LWP 8045]
 [New LWP 8043]
 [New LWP 8044]
 [New LWP 8049]
 [New LWP 8081]
 [New LWP 8076]
 [New LWP 8057]
 [New LWP 8077]
 [New LWP 8082]
 [New LWP 8059]
 [New LWP 8050]
 [New LWP 8047]
 [New LWP 8079]
 [New LWP 8048]
 [New LWP 8083]
 [New LWP 8046]
 [New LWP 8080]
 [New LWP 8078]
 [New LWP 8051]
 [New LWP 8058]
 [New LWP 8052]
 [New LWP 8056]
 [New LWP 8084]
 [New LWP 8055]
 [Thread debugging using libthread_db enabled]
 Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
 Core was generated by `./UE4Editor /home/wingated/pak/SunTemple 4.10/SunTemple.uproject'.
 Program terminated with signal SIGSEGV, Segmentation fault.
 #0  _int_malloc (av=0x7f25f4000020, bytes=139312) at malloc.c:3445
 3445    malloc.c: No such file or directory.
 Traceback (most recent call last):
   File "/usr/share/gdb/auto-load/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.19-gdb.py", line 63, in <module>
     from libstdcxx.v6.printers import register_libstdcxx_printers
 ImportError: No module named 'libstdcxx'
 (gdb) bt
 #0  _int_malloc (av=0x7f25f4000020, bytes=139312) at malloc.c:3445
 #1  0x00007f265a6812bb in _int_memalign (av=0x7f25f4000020, alignment=4096, bytes=139328, bytes@entry=135168) at malloc.c:4403
 #2  0x00007f265a682c94 in _mid_memalign (alignment=4096, bytes=135168, address=<optimized out>) at malloc.c:3106
 #3  0x00007f2665d1b987 in OSAlloc (this=0x7f2666c62010, NewSize=135168, OutActualSize=@0x21000: <error reading variable>)
     at Runtime/Core/Public/HAL/MallocBinned.h:815
 #4  FMallocBinned::Malloc (this=0x7f2666c62010, Size=<optimized out>, Alignment=16) at Runtime/Core/Public/HAL/MallocBinned.h:1050
 #5  0x00007f2665cdc102 in ResizeAllocation (NumElements=32769, NumBytesPerElement=4, this=<optimized out>, PreviousNumElements=<optimized out>)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Public/Containers/ContainerAllocationPolicies.h:344
 #6  Reserve (Number=32769, this=<optimized out>) at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Public/Containers/Array.h:1902
 #7  Reserve (this=<optimized out>, CharacterCount=32768) at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Public/Containers/UnrealString.h:1518
 #8  FGenericCrashContext::FGenericCrashContext (this=<optimized out>)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformContext.cpp:83
 #9  0x00007f2665daf6ce in FLinuxCrashContext (this=0x7f26665a08e0 <vtable for FGenericCrashContext+16>)
     at Runtime/Core/Public/Linux/LinuxPlatformCrashContext.h:35
 #10 PlatformCrashHandler (Signal=11, Info=0x7f2600b7cb30, Context=0x7f2600b7ca00)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Private/Linux/LinuxPlatformCrashContext.cpp:434
 #11 <signal handler called>
 #12 Convert<char, wchar_t> (BogusChar=63 L'?', Dest=<optimized out>, DestSize=<optimized out>, Src=<optimized out>, SrcSize=<optimized out>)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Public/GenericPlatform/GenericPlatformString.h:146
 #13 Apply (this=<optimized out>) at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Public/Containers/StringConv.h:701
 #14 operator<< (Ar=..., A=...) at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Private/Containers/String.cpp:1075
 #15 0x00007f26657df65f in operator<< (Ar=..., Sum=...)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/CoreUObject/Private/UObject/PackageFileSummary.cpp:199
 #16 0x00007f2656331074 in FPackageReader::OpenPackageFile (this=0x7f2600b7d570, InPackageFilename=...)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/AssetRegistry/Private/PackageReader.cpp:32
 #17 0x00007f265632ef23 in FAssetDataGatherer::ReadAssetFile (this=0xfbbde00, AssetFilename=..., AssetDataList=..., DependencyData=...)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/AssetRegistry/Private/AssetDataGatherer.cpp:494
 #18 0x00007f265632ccc1 in FAssetDataGatherer::Run (this=0xfbbde00)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/AssetRegistry/Private/AssetDataGatherer.cpp:186
 #19 0x00007f2665d0be64 in FRunnableThreadPThread::Run (this=0x10dbd7c0)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Private/HAL/PThreadRunnableThread.cpp:26
 #20 0x00007f2665d4ae08 in FRunnableThreadPThread::_ThreadProc (pThis=0x10dbd7c0)
     at /home/wingated/projects/ue-release/Engine/Source/Runtime/Core/Private/GenericPlatform/../HAL/PThreadRunnableThread.h:167
 #21 0x00007f26668df182 in start_thread (arg=0x7f2600b7f700) at pthread_create.c:312
 #22 0x00007f265a6fa47d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
 




Product Version: UE 4.9
Tags:
more ▼

asked Oct 16 '15 at 09:32 PM in Linux

avatar image

wingated
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question