x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Intellisense not working on my project files

Hello, I tried out the new visual studio 2015 and Unreal 4.10 Preview 1 and i noticed that intellisense only works on the base unreal 4 engine classes and functions. Whenever i add a new class, for example a child of ACharacter class, and create some variables and functions it wont recognize. It will only recognize the functions in ACharacter but tell me that all my own functions and variables isn't defined and the "red error underlining" is dominating my entire view. However it will compile just fine.

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Oct 17 '15 at 09:16 AM in C++ Programming

avatar image

Eqric
89 19 26 31

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Eqric-

There are a number of UE specific things happening behind the scenes when a code project is created/compiled that Intellisense may not recognize. These "false positives" can be misleading and in many cases can be ignored. You can use Visual Assist alongside Intellisense for code completion or you can use it in place of Intellisense to avoid seeing the false errors completely.

Cheers

Doug Wilson

more ▼

answered Oct 19 '15 at 08:04 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey, for people who is having problems with IntelliSense, my problem might help some others. My IntelliSense was working on x86 but not x64

I tried everything to solve it but what had really happened was that I had overwritten the file "C:\Users\username\AppData\Local\Microsoft\MSBuild\v4.0\ Microsoft.Cpp.x64.user.props" with the content from a colleague to build other project.

I added these lines which are the ones which screwed up my x64 Intellisense...

<ItemDefinitionGroup> <ClCompile> <AdditionalIncludeDirectories> <\AdditionalIncludeDirectories> <\ClCompile> <\ItemDefinitionGroup>

So all I had to do was to REMOVE THEM

more ▼

answered Mar 14 '19 at 08:32 AM

avatar image

clau_ccanada
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question