x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG OnAnimationFinished called few seconds later

Hello,

After compiling UMG widgets with 4.10, blueprint OnAnimationFinished event and c++ OnAnimationFinished_Implementation seems to be called few seconds later.

However widgets compiled with 4.9 but executed with 4.10 seems to behave correctly.

Karlitos.

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Oct 18 '15 at 12:16 AM in Bug Reports

avatar image

Karlitos_VII
3 2 3

avatar image Rudy Q ♦♦ STAFF Oct 19 '15 at 02:10 PM

Hello Karlitos_sf,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image Karlitos_VII Oct 19 '15 at 05:32 PM

You can easily reproduce the bug.

  1. Create a new 4.9 third person project

  2. Create a new widget which is a simple text block and add it a basic scale animation alt text alt text

  3. Add widget to vewport on begin play alt text

  4. Save and close project

  5. Switch project unreal version to 4.10

  6. Open project and recompile the widget

By now, OnAnimationFinished event should be called ~3s (on my computer) after animation finished.

Same behavior if I reparent the widget with a custom c++ widget and reimplements OnAnimationFinished_Implementation.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I was able to reproduce this issue on our end. I have written up a report (UE-22334) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered Oct 19 '15 at 06:46 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Karlitos_VII Oct 19 '15 at 06:55 PM

You're welcome :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question