x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Vehicle wheels fall off upon re-enabling physics

A Wheeled Vehicle's wheel meshes will fall off if the vehicle (or more specifically, the root, which would be the vehicle skeletal mesh) is not currently simulating physics, and you decide to Set Simulate Physics to true (while playing / at runtime).

alt text

I originally found this problem toying around with a vehicle I made within the 4.8 version of the "Vehicle Advanced" template, but I've found this also happens with the vehicle in the 4.9 version of the "Vehicle" template.

Steps to easily see this behavior are as follow:

  1. Start a new project using the "Vehicle" blueprint template.

  2. Open the Sedan blueprint.

  3. Within the main Event Graph, add these nodes: Using whichever key you'd like, toggles the physics simulation of the vehicle on / off

  4. Start playing the game. Drive around and toggle the physics. Observe wheel behavior.

I've messed around with plenty of settings within the vehicle blueprint itself, the animation blueprint for the vehicle, and the physics asset the skeletal mesh uses. However I wasn't able to pinpoint what exactly is going on here. Here are some of the things I've tried, and some of the things I've noticed:

  • The vehicle, when simulating physics, still works completely fine.

  • When re-enabling physics, adding on the Set Physics Asset node with the the Force Re Init bool set to true will crash the editor (probably because that doesn't re initialize the physics asset like I thought it would, but it was worth a try)

  • If you are accelerating and/or turning at the moment of re-enabling physics, the wheels will roll off in the direction they are pointing, on what appears to possibly be the spheres used for their collision in the physics asset.

  • This is interesting. Open the Sedan blueprint, select the vehicle mesh, and in the details panel search for "No Skeleton Update" which will be under the Skeletal Mesh category. Setting this option to true will prevent the vehicle skeletal mesh from animating, including the wheels (you can see this by turning and noticing the front wheels are not turning). If you drive around and toggle the physics, the wheels won't fall off. Of course they aren't animating either.

  • The last two observations pretty much leave me stumped. I'm not sure if this is a problem with the physics asset, or the animation blueprint. Maybe both, maybe neither?

Is there any way of fixing this so that when you re-enable physics for the car, the wheels will continue to animate correctly? It would be nice for situations like attaching the vehicle to something in order to transport it somewhere, and then detaching it and allowing it to drive again. Any help with this, especially identifying if this is a bug or not, is much appreciated.

Product Version: UE 4.9
Tags:
more ▼

asked Oct 18 '15 at 03:40 AM in Bug Reports

avatar image

RO10
11 1 2 4

avatar image MasterOfShapes Oct 18 '15 at 04:48 PM

Having the exact same issue 4.9.2. Wheels detach and remain rigid as if not getting physics but car drives perfect. I dont know if its a bug or a limitation?

avatar image 1999 Oct 24 '15 at 08:39 PM

I find you problem funny.

avatar image JohnADaniels May 16 '19 at 04:35 PM

This is still happening in 4.22, have a bunch of vehicles and wanted to keep physics off until possessing.

When you posses it works perfect except the wheels stay in play :0

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Did you try changing 'PhysicsType' on those bodies from PhysType_Default (which means it will be whatever the skeletal mesh component is set to) to PhysType_Kinematic (which means it will not simulate, even if the component is told to)?

more ▼

answered Oct 20 '15 at 08:34 AM

avatar image

JamesG STAFF
1.3k 8 8 32

avatar image RO10 Oct 20 '15 at 10:33 PM

That worked! Thanks, both of you! I think I never ended up trying that because I've had problems before with other physics assets having intersecting collision bodies set to kinematic, but it looks like vehicles don't have that problem I guess? Although now the vehicle floats there in place when you attempt to simulate the physics within PHAT, but other than that everything else works. Thanks again!

avatar image JohnADaniels May 16 '19 at 05:01 PM

After changing just the wheels to kinematic, it is working now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello RO10,

I believe this is a bug and have reported it as such. It is possible however that Simulating Physics off and on at runtime is something that is not supported at this time. It will be discussed and I'll update this post when any updates have been made. For your reference, the bug number is UE-22350.

Have a nice day!

more ▼

answered Oct 19 '15 at 08:55 PM

avatar image Frozenfire Jan 25 '17 at 04:27 AM

i'm currently getting this issue still in 4.14. Has this been solved?

note that I am not deliberately changing physics asset. It's just that on client side of multiplayer the wheels will always come on the moment the vehicle enter the scene.

avatar image Matthew J Jan 25 '17 at 03:46 PM

There is nothing to be fixed. This bug report was entered without know that this behavior was by design. Please see the answer posted by JamesG above which fixed the issue for the original user.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question