x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reproduced: Source Control causes crash in 4.10 Preview 2.

To reproduce in 4.10 preview 2: Click the source control button > Click Perforce > Experience crash.

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Oct 20 '15 at 04:55 PM in Bug Reports

avatar image

KITATUS
2.3k 97 84 398

avatar image Nextwave Nov 08 '15 at 08:02 PM

My error output:

MachineId:C24F2D9E4BAAC6956DFCB3B8784B44A5 EpicAccountId:e470b6efe5894cc6834c1933acc4c635

Stack overflow - code c00000fd (first/second chance not available)

""

LavasoftTcpService64 LavasoftTcpService64 ws2_32 ws2_32 UE4Editor_PerforceSourceControl!NetTcpSelector::Select() UE4Editor_PerforceSourceControl!NetTcpTransport::SendOrReceive() UE4Editor_PerforceSourceControl!NetBuffer::Receive() UE4Editor_PerforceSourceControl!RpcTransport::Receive() UE4Editor_PerforceSourceControl!Rpc::DispatchOne() UE4Editor_PerforceSourceControl!Rpc::Dispatch() UE4Editor_PerforceSourceControl!Client::WaitTag() UE4Editor_PerforceSourceControl!Client::RunTag() UE4Editor_PerforceSourceControl!Client::Run() UE4Editor_PerforceSourceControl!FPerforceConnection::RunCommand() UE4Editor_PerforceSourceControl!FPerforceConnection::EstablishConnection() UE4Editor_PerforceSourceControl!FPerforceConnection::FPerforceConnection() UE4Editor_PerforceSourceControl!FScopedPerforceConnection::Initialize() UE4Editor_PerforceSourceControl!FPerforceGetWorkspacesWorker::Execute() UE4Editor_PerforceSourceControl!FPerforceSourceControlCommand::DoThreadedWork() UE4Editor_Core!FQueuedThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\hal\threadingbase.cpp:400] UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

avatar image Nextwave Nov 09 '15 at 02:02 PM

Having this exact same issue with 4.9.2 right now.. :/

avatar image Doug E ♦♦ STAFF Nov 09 '15 at 03:54 PM

Hey Nextwave-

You are getting a crash when you click on Perforce in the Source Control window, is that correct? Is this occurring in a fresh 4.9.2 project? Are you using the launcher or a source built version of the engine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Kitatus-

This was reported for Preview 1 as well (UE-22260) and is under investigation.

Cheers

Doug Wilson

more ▼

answered Oct 20 '15 at 05:54 PM

avatar image Vergbergler Jan 21 '16 at 05:17 PM

Any resolution to this issue?

avatar image Doug E ♦♦ STAFF Jan 21 '16 at 05:52 PM

Hey OmicronVega-

This crash was reported as part of the 4.10 preview process and was fixed for the final 4.10 release. Are you still seeing this crash in 4.10.2?

avatar image Vergbergler Jan 21 '16 at 06:40 PM

Hey Doug,

I sure do. As soon as the Source Control button is pressed all of Unreal's UI freezes indefinitely without a crash report or breaking if Visual Studio 2015 is attached. I've left it running for about 30 minutes this way, but it remains frozen.

What I've tried thus far: 1) Uninstalled UE4 (all versions) from my machine including the launcher. 2) Uninstalled Visual Studio 2015. 3) Starting a new project that isn't connected to our repository.

I'm currently running Windows 7 x64.

Would you like to know more information?

avatar image Vergbergler Jan 21 '16 at 11:18 PM

Hey again Doug,

Is there anything I can do to help resolve this issue? Video recording of the bug, pictures, settings file configurations?

Thank you.

avatar image Doug E ♦♦ STAFF Jan 22 '16 at 03:37 PM

Are you using 4.10.2 build from source or are you using a launcher build? And to confirm, you tried creating a new project and attempted to connect to source control? Also, can you post the log files and callstack from the crash for additional information?

Thanks

avatar image Vergbergler Jan 23 '16 at 09:08 PM

Hey Doug,

To answer your questions: I can do both. Yes. No there isn't debug output of any kind. Unreal just locks up and remains that way. I have waited up to 30 minutes for something to happen on both a VS startup and a Launcher startup.


Solution: I did some digging while I was waiting for you to respond. I'm using a MSI laptop and it comes with preinstalled software called "Nahimic". Nahimic is apparently known to cause certain behavioral problems with Unreal Engine dialogs, to fix simply close all running Nahimic processes.


Thank you for your help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question