x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Blueprint Zoom Problem

When opening a blueprint graph, such as the event graph or a function that contains a lot of nodes, the view automatically zooms out to show the entire node graph. If you then try and zoom in straight away (as soon as you open the graph) you can't. The zoom keeps trying to go back out to show the whole node graph.

I think the problem is that when you first open a large event graph or function graph, the editor plays a bit of an animation to zoom out smoothly. This animation seems to take a second or so to complete. So if you try zooming within the second (which I do a lot as I work pretty fast), then you are not letting the animation complete so it keeps trying to finish the zoom out animation and keeps snapping your zoom back out. It will do this for as long as you keep spinning the mouse scroll wheel to zoom in. I've been able to keep it stuck in this zooming loop for some 10 seconds just by continually spinning the mouse wheel.

The only thing you can do is then wait for it to finish its silly zoom out animation before you can zoom in and get to work. The animation only takes a couple of seconds to complete, but it is so frustrating when you think it is finished, so you start zooming only to realise it isn't... the zoom animation resets... you wait another couple of seconds and try again... and oh no its not finished again... reset... wait a few seconds this time... ok now we can get to work. Very annoying when you are jumping around between multiple blueprint graphs trying to work quickly.

The solution: Remove the zoom animation. Just make it snap straight to whatever zoom level it wants to open at rather than smoothly animating to that zoom. Alternatively, cancel out of the animation if the user starts to zoom with their scroll wheel so the user can take over. Please fix this ASAP. It is driving me crazy!

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Oct 22 '15 at 07:29 AM in Bug Reports

avatar image

wilberolive
298 30 45 48

avatar image Enlo Oct 22 '15 at 07:54 AM

Is this something new in 4.10? I've never seen this animation, my blueprints seem to open in some default zoom level o_0

avatar image Sean L ♦♦ STAFF Oct 22 '15 at 02:36 PM

Hello wilberolive,

  • What type of blueprint are you experiencing this behavior in?

  • Do you have any unusual settings?

  • Have you enabled any settings in Editor Preferences that may be causing this to happen?

avatar image Allar Oct 22 '15 at 02:42 PM

Commenting to confirm this happens and would also like this zoom animation removed or... at least interruptible. You have to initiate a zoom really fast after a window is opened though, but its triggerable enough to be annoying. Happens in most BP classes for me, no unusual settings (clean engine build, new project), no editor preferences changed.

This is far easily reproduced in animation blueprint graphs however, as the zoom/recenter animation seems longer.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello everyone,

This issue actually exists in our system already as UE-19469. Thank you for your report, and I will follow up with any updates regarding the issue.

more ▼

answered Oct 22 '15 at 02:55 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question