x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Import custom physics from static mesh to physics asset has wrong scale

I have a skeletal mesh of a bus. To use custom physics assets I imported the mesh as static mesh too. The Static Mesh imported the convex physics objects successfully (The "UCX_*" meshes). Then I tried the "Copy Collision from Static Mesh" Button in PhAT. The convex objects copies successfully but with some issues:

  • The imported Convex Meshes are too large. The reason could be: We've modeled the bus in 3ds Max im meter and exported it with unit conversion to cm. In most cases all is fine but here it seems that the scaling is applied a second time when copying from Static Mesh to PhAT.

  • (Feature Request) The scaling of physics Meshes in PhAT is very painful and inaccurate with the scaling tool. Please give us a text field to type the Scaling (...and Location... and Rotation)

  • After scaling the physics mesh (painfully) all works fine but every time I open the Bus in the Editor (skeletal mesh or Blueprint) the camera is miles away fromt the Bus. It seams that the Bounds of the mesh doesn't uses the scaling of the physics mesh.

  • When showing the Collision Meshes in Editor with Alt+C then the shown Mesh is very tiny.

UE 4.9.2 Launcher Version

Product Version: UE 4.9
Tags:
more ▼

asked Oct 22 '15 at 04:41 PM in Bug Reports

avatar image

user37337
187 16 28 44

avatar image DyotoOrion Mar 31 '16 at 08:25 PM

I have having exactly the same issue. The issue of the oversized custom UCX asset when imported into the PHAT Editor was not there in UE4 Version 4.5.

The custom UCX collison object is of the correct scale when viewed in the static mesh editor, but when imported into PHAT it is 100x too big - and it is impossible to scale it down with the tools provided - as the original poster desribed. Hope this gets fixed in 4.12. Cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hello user37337,

I have entered a feature request for an option to scale your physics mesh more accurately than the scale tool.

The ticket number is UE-22598.

I will keep you up to date on this tickets progress.

Logan

more ▼

answered Oct 26 '15 at 01:57 PM

avatar image user37337 Oct 26 '15 at 02:34 PM

What about the other two issues?

avatar image Logan Bailey ♦♦ STAFF Oct 26 '15 at 02:37 PM

I included a link and notes regarding the scaling applied twice when copying from Static Mesh to PhAT and the bounds not using the scale of the physics mesh.

This is a multi part issue that may or may not be related. Our developers will look into this and determine how and why this could be happening.

avatar image user37337 Oct 29 '15 at 09:26 AM

Thank you. I've added another small issue to the list.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The feature to manually edit primitive data in PhAT was added recently in CL 2914743. It should be release in 4.12.

more ▼

answered Mar 18 '16 at 02:53 PM

avatar image

Tom Sarkanen STAFF
1.7k 39 12 53

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi again. :) I have found a work around for this issue that may be helpful. Only thing is I am using Blender 3D, not Max.

I was having exactly the problem that User37337 was having - that of a massively upscaled custom UCX when brought into the PHAT editor - experienced all the symptoms he described.

I was able to solve this issue by changing the Export Scale of the Target Skeletal Mesh from 1 to 0.01 and scaling the actual skeletal mesh up 100x inside Blender 3D. After then reimporting the Skeletal Mesh, creating a new Physics Asset for it and copying the custom UCX collision from a static mesh, the UCX collision was brought into PHAT at the correct scale, solving the issue.

I suspect the original problem was caused by PHAT reading the bones in my Skeletal Mesh as 100x too big. Scaling down the skeletal mesh in the FBX exporter (while scaling up in Blender) I was able to correct the bone size, while maintaining the correct skeletal mesh size.

Hope this is helpful. :-)

more ▼

answered Mar 31 '16 at 09:46 PM

avatar image

DyotoOrion
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question