x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Changing a variable name in parent, reset childs variable property in level

Hi,

i just found a bug (is it a bug? i hope yes because its annoying and its destroyed all my child blueprint property in my 20 maps !)

when you rename a variable in parent blueprint, all your childs you had in maps have their property reset to default !

tell me this is a bug, because i love to clean my blueprint, and renaming variables is part of my cleaning process :). i didnt pay attention and i lost all my custom property data in all childs blueprints i put in 20 differents maps (many hours of work lost)

Product Version: UE 4.9
Tags:
more ▼

asked Oct 23 '15 at 11:57 AM in Bug Reports

avatar image

skeleton60
620 42 59 88

avatar image skeleton60 Oct 23 '15 at 12:01 PM

i can reproduce this, i did it in a new blank project if you need

just please tell me this a bug <3

avatar image Sean L ♦♦ STAFF Oct 23 '15 at 02:31 PM

Hello skeleton60,

Could you provide the steps that you took to reproduce this issue so we can investigate it further? Also, feel free to zip up your project and send me a link to Dropbox and I can have a look at that as well. Thank you.

avatar image skeleton60 Oct 23 '15 at 03:18 PM

damn this is a bug then?

ok, steps to reproduce is easy, i dont do anything in particular, i will re-do it at same time i wrote steps:

-Launch unreal engine 4.9.2 -Create a new project -> Blueprint -> Blank - Target hardware: desktop/consoles - maximum quality - no starter content

-Create a new blueprint "BP_Parent" based on actor class -Add two variables: a boolean named boolean, and a float named float -Check "editable" for those two variables

-Create a child blueprint based on "BP_Parent" named "BP_Parent_child" -Place the child actor on scene -Edit the variable of the child actor in the scene. Check true the boolean, and write 10.0 for float -Save the map

-Now open the "BP_Parent" blueprint, and rename the boolean to boolean2 and the float to float2 and compile

-Check the child actor in scene, the boolean is reset to false, the float is reset to 0.0

so is it a bug or normal behavior?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello skeleton60,

This is currently a known issue, and is entered in our system as UE-21109. Thank you for your report.

Have a great day.

Sean Flint

more ▼

answered Oct 23 '15 at 04:45 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image skeleton60 Jan 11 '16 at 02:32 AM

hi,

it will be fixed soon? the bug still here (UE4.10)

avatar image Sean L ♦♦ STAFF Jan 11 '16 at 01:06 PM

Hello,

This issue is still being investigated by our developers, and there is currently no timeline for when the fix will be released. I will provide more updates as they become available.

Have a great day

avatar image Tbjbu1 Dec 29 '16 at 02:35 PM

I'm still getting this bug.. Still no fix? 4.14.1

avatar image Sean L ♦♦ STAFF Dec 29 '16 at 02:37 PM

Hello,

Here's the link to the issue on the public tracker:

https://issues.unrealengine.com/issue/UE-21109

The issue has been verified as fixed in 4.14. If you are experiencing the same issue, could you please provide a detailed list of repro steps that we can follow to reproduce the issue on our end?

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question