x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Subsurface material & light function

Hey,

i'll start with a scene description: i have a mesh that uses Subsurface shading model. I have a light(point light) with a light function that completely disables any lighting(emissive output set to 0). It works with other shading models, they receive no lighting in this case, but doesn't work on a Subsurface materials, they're still lit with it. However, just a subsurface shading is present. If i manually set light intensity to 0, subsurface shading is gone..

I hope the description is clear enough.. Thank you!

Product Version: UE 4.9
Tags:
more ▼

asked Oct 23 '15 at 06:45 PM in Bug Reports

avatar image

BiggestSmile
1.6k 54 38 105

avatar image BiggestSmile Oct 23 '15 at 07:49 PM

I believe that's not a bug report actually, but a feature request..

avatar image BiggestSmile Oct 24 '15 at 05:12 PM

Bumping..

avatar image BiggestSmile Oct 25 '15 at 12:14 PM

Noticed that this happens only with point lights, spot lights haven't got this problem

avatar image BiggestSmile Oct 26 '15 at 02:54 PM

Bumping again..

avatar image AndrewHurley Oct 27 '15 at 07:47 PM

Hey BiggestSmile,

We ask that our users remain patient when awaiting a response. We usually respond within 24 to 48 hours, but we ask users do not bump ever, and only ask for updates after the two day time period has expired.

Could you provide me with some reproducible steps as well as some screenshot so I can visualize what you are reporting?

Your description is somewhat clear, but gaining clarification so I can verify what you are reporting is necessary for testing.

Thank you,

Andrew Hurley

avatar image BiggestSmile Oct 28 '15 at 05:25 PM

Hey Andrew, sorry for the dumping.. Won't do anymore :) Sure :) Here i have point light. This is stationary. The bed and the sheet materials are using Subsurface shading model link text This is what i have when i set light function material. Direct lighting is gone, but subsurface lighting is still present. Light function is really simple: just a black Vector3 node attached to emissive color link text This is the same, expect for that the light intensity was set to 0 link text

And while taking the screenshot found out that spot lights are actually affected..

Curtains use Subsurface shading model Light is on, no light function is applied link text Applied light function. Notice some weird shadow on the curtains as well link text Set intensity to 0 link text

avatar image BiggestSmile Oct 28 '15 at 05:26 PM

Hope this helps. Let me know if you need anything else!

avatar image AndrewHurley Oct 28 '15 at 07:54 PM

Hey BiggestSmile,

I appreciate you deciding to refrain from bumping :)

So looking into this issue, I found some information about Light Function Materials within the tooltip. I believe this to be your issue in conjunction with some post processing and light actors you might need to disable.

Firstly, in regards to the light function material, the tooltip reads, "Note that only non-lightmapped lights (UseDirectLightMap=False) can have a light function." Since your light is set to Stationary, you are using lightmaps which means the light function will not work as you expect.

Your next issue seems to be with your Auto-Exposure setting within your Post Processing. In order to see your scene without this post processing effect, you will want to set the Min and Max brightness to a value of 1.0.

Let me know if you need help or have further questions.

Cheers,

Andrew Hurley

avatar image BiggestSmile Oct 29 '15 at 07:19 AM

Hey Andrew, thank you for the reply :)

Stationary light itself isn't lightmapped, the lighting is still dynamic. Only indirect lighting contributed by this light is in the lightmaps. In other words, for this light UseDirectLightmap=false :)

And this is what docs say about light functions: "Also, Static Lights cannot not use Light Functions, as this feature is only available for non-lightmapped lights, like Stationary and Movable lights.". Changing light mobility to movable doesn't do anything, since stationary light is still "almost" movable :)

I didn't modify exposure settings in a post-process volume, they're default. And turning it off darkens the room completely, since this is a night setting, it's an expected result :)

The problem is how light functions work, light intensity is masked in the world by the light function, while the actual intensity value is still present, and subsurface materials uses this. As i said earlier, that's not an actual bug, it's more of a feature request :)

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I do see what you are saying now, and I appreciate the clarification. I will take this information and try to generate a feature request that summarizes what you have pointed out.

Thanks,

Andrew Hurley

more ▼

answered Oct 29 '15 at 05:54 PM

avatar image BiggestSmile Oct 30 '15 at 09:28 AM

Thank you very much Andrew! :) Have a nice day :)

avatar image BiggestSmile Nov 09 '15 at 06:28 PM

Hey Andrew, any news on the subject? :)

avatar image AndrewHurley Nov 09 '15 at 10:11 PM

In order for the feature request to be completed. We need to make sure you have set up your material correctly. The reason I need this, is because I followed your instructions using a light function and a single stationary point light, and did not receive the same results.

alt text

Subsurface Material alt text

Thank you,

Andrew Hurley

avatar image BiggestSmile Nov 10 '15 at 05:55 PM

I've made sample project, you can get it here (4.9.2)

By default light function intensity is set to 0, the shadows and the lighting is still present on the curtains mesh, and only on the curtains

P.S. the curtains mesh uses masked blend mode, changing it to opaque does not resolve the problem

avatar image BiggestSmile Nov 14 '15 at 02:18 PM

I'm sorry for bumping, but it's 3rd day by now :)

avatar image AndrewHurley Nov 14 '15 at 04:36 PM

I have entered a feature request for this issue UE-23357. If this becomes a feature we will add it to our release notes.

Cheers,

Andrew H

avatar image AndrewHurley Nov 25 '15 at 02:12 PM

This is a known limitation of the Subsurface shading model. It's a bit more difficult to implement for point lights and spot lights, but certainly possible. We intend to improve the method and know about it. It's unclear when we will find the time to do that.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question