x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particles not colliding properly in-game...

I've seen a few other bug reports like this, but they were all for earlier versions of UE4. I'm in 4.9.2. The problem I'm having is that I've made a rain particle effect where CPU particles are supposed to collide with things and bounce to create a nice, almost splashing, effect on sloped surfaces. Anyway, I was building this effect the other day and everything was working flawlessly no matter how I tested it.

Today, I fired up my engine and wanted to check out my work again with fresh eyes to see if I could change anything. Everything works nicely in the editor window, but when I test it in a game window, collisions seem to not exist.

Exactly what I'm doing to encounter this issue:

  1. I dragged a particle system into the level directly (i.e. it's not a component of a blueprint or spawned in-game) It might be worth noting that it consists of a CPU particle emitter is paired with a GPU particle emitter;

  2. Collision works fine in the editor window;

  3. No collision occurs if I play the game in a new editor window;

Here is a screenshot with the particle effect selected to highlight raindrops: alt text

... and here is one from in-game (with wire frame mode on to highlight the drops): alt text

I'm running UE4, 4.9.2 on Windows 10.

Product Version: UE 4.9
Tags:
more ▼

asked Oct 23 '15 at 07:53 PM in Bug Reports

avatar image

PFG_Icarus
29 12 10 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Ryan -

For the CPU Particles, please check your Collision module under Performance and look at the Max Collision Distance. By Default this is set rather small for performance reasons (CPU Collision is really expensive). Try increasing the distance and if you are still not getting collision with these particles, also uncheck the Drop Detail. That will correct your issue for these particles. (These particles will be expensive, so limit the number to help with performance.)

For the GPU Particles, remember Collision is by default set to collide based on Scene Depth and if your camera is offset to the floor or ceiling such that the camera cannot distinguish any depth, your particles will not collide. If you are using Mesh Distance Fields, make sure that they are built and look at their view to see if you need to increase their overall resolution.

Thank You

Eric Ketchum

more ▼

answered Oct 23 '15 at 08:35 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question