x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why does VR preview with the Oculus Rift not work anymore?

I recently tried to preview my project using the Oculus Rift DK2, but the VR Preview button was grayed out using the 0.6 Oculus runtime running in extended mode. I upgraded to the 0.8 runtime and it fixed the button being grayed out but every time I VR Preview it crashes. I also tried the 0.7 runtime with the same results.

Here is the crash report:

Access violation - code c0000005 (first/second chance not available) "" UE4Editor_RHI!FRHITexture2D::GetSizeY() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\rhi\public\rhiresources.h:446] UE4Editor_Engine!`FCanvas::Flush_GameThread'::`21'::EURCMacro_CanvasFlushSetupCommand::DoTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\engine\private\userinterface\canvas.cpp:775] UE4Editor_Engine!TGraphTask<`FCanvas::Flush_GameThread'::`21'::EURCMacro_CanvasFlushSetupCommand>::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\public\async\taskgraphinterfaces.h:779] UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\async\taskgraph.cpp:539] UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\async\taskgraph.cpp:340] UE4Editor_RenderCore!RenderingThreadMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\rendercore\private\renderingthread.cpp:310] UE4Editor_RenderCore!FRenderingThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\rendercore\private\renderingthread.cpp:411] UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Product Version: UE 4.9
Tags:
more ▼

asked Oct 28 '15 at 08:59 PM in VR

avatar image

Q-bert505
13 3 4 5

avatar image Q-bert505 Oct 29 '15 at 08:28 PM

Some additional information:

I am using the 4.9.2 build of the engine. I get the same results in a new project. I am using Windows 7 64 bit.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

All works fine for me.

My system:

Windows 7 x64

GeForce 750 Ti

NVIDIA drivers 358.78 (this is latest GameWorks driver with VR support and recommended for work with Oculus)
https://developer.nvidia.com/gameworks-vr-driver-support

Oculus SDK 0.8.0.0

UE 4.9.2.

I played Showdown VR demo in "VR Preview" mode.

more ▼

answered Oct 30 '15 at 01:51 PM

avatar image

svv3dUDN
8.4k 254 41 399

avatar image Q-bert505 Oct 30 '15 at 05:04 PM

Downloading the drivers worked great! Thank you very much for your assistance.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question