x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Animation start/end bug

Hi

I just discovered a bug within the UMG animation editor.

I am currently doing animations for my main menu widgets, I want the animation to go from 0.0 to 1.5, however the animation editor seems to be remembering keys that have been deleted previously, such as -0.1 and 3.5, and thus plays from -0.1 to 3.5 for some reason.

I was able to replicate the issue, here are instructions on how to replicate the problem:

  1. Create new widget blueprint

  2. Add button to canvas

  3. Create new animation

  4. Add button to animation

  5. Create a "Render Transform" track on the button animation.

  6. Create a key at 0.0 and a key at 1.5 (with or without x/y movement value)

  7. Play the animation (It plays from 0.0 - 1.5 as you would expect)

  8. Add a new key at 3.0

  9. Delete the new key at 3.0

  10. Play animation again (It now plays from 0.0 - 3.0...)

I think it would be great to be able to set a start and end point of the animation like one would do so in any sort of animation editor.

Also, it would be great to be able to change an element of an animation. For example if I have a button, with keys already laid out, but I actually want to change that button element to a Text element or something else.

(Also, I tried to add the tag "Widget Animation" but there is only a tag for "Widget aniamtion"... which may make it more difficult to find topics related to widget animation ;) )

I hope this helps :)

Product Version: UE 4.9
Tags:
more ▼

asked Oct 29 '15 at 11:48 PM in Bug Reports

avatar image

Otreum
219 17 26 37

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Otreum,

I was able to reproduce this issue on our end. I have written up a report ( UE-22840) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered Nov 02 '15 at 02:54 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Otreum Nov 02 '15 at 09:06 PM

Thanks Rudy, glad I could help.

I hope you have a great day too! :)

avatar image antsonthetree Jan 05 '17 at 03:32 PM

Just want to say that this bug still exists as of 4.14.2

avatar image rokkie199 Feb 19 '19 at 07:53 PM

It still exists :/

avatar image error406 Apr 04 '19 at 09:11 AM

Please forgive my lack of real terms - long long day - if you are still running into this problem, you need to click on your tracks in the timeline where your keyframes are and you will notice a very hard-to-see bar with start and end points that will be stretching beyond your keyframes. It kind of looks like what you would expect to see in after effects - grab the ends and move them to the correct start and end points. if you need a better explanation leave a comment here and I'll reply when my brain is working better.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question