x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Why is my SkeletalMesh export missing bones?

Hi,

I am starting to play around with character modeling.

However, I noticed that you can't export a skeleton file. You only get a text file with the file name. You can export and re-import the default character as FBX, but bones are lost in the process (probably because they don't exist in the character file, only in the skeleton).

UDK used to offer a sample skeleton as a maya or 3ds file, so that users could base assets on this and reuse the current animations. Would this be possible ? Whatever the file format, though a simple FBX would be fine I guess.

Thanks !

Product Version: Not Selected
Tags:
more ▼

asked Apr 21 '14 at 07:46 AM in Using UE4

avatar image

StrangerGwenn
594 53 63 133

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Apr 28 '15 at 07:43 AM by StrangerGwenn for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Hi,

When you say "export and re-import the default character', are you exporting the skeletal mesh asset? You should be able to export that as an .fbx with no problems. I just tested it using the HeroTPP skeletal mesh from the Third Person Template and it worked fine. The only issue is when you import the fbx that it generates to Max or Maya (or any other program I suppose) the joint hierarchy and the mesh are both children of a new node named after the original asset (HeroTPP, in this case). You would want to unparent those and just delete that new node. The Root bone of your joint hierarchy shouldn't be a child of anything, and your mesh doesn't need to be included in your joint hierarchy either (since it is skin weighted to the joints).

more ▼

answered Apr 21 '14 at 01:04 PM

avatar image

Ray Arnett STAFF
1.4k 45 17 71

avatar image StrangerGwenn Apr 21 '14 at 01:24 PM

Hi,

Well this same asset exports well, yes, but I don't have any bones in the resulting file. Since I am using Blender this may be the problem, the FBX import is not perfect, but I wanted to check first if this is supposed to happen...

avatar image StrangerGwenn Apr 21 '14 at 01:30 PM

Hey, I just tried to convert the FBX to Collada using FBX Converter, then import that in Blender. It works. So this is just the Blender FBX import.

Thanks a lot !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question