x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

ShooterGameServer Target Configurations Missing

I tried making my own server target .cs file but after generating the VS project files the *Server configurations were missing in visual studio. I figured I'd done something wrong so loaded ShooterGame and generated the VS project files for it but the same problem occurs even though there is a ShooterGameServer.Target.cs file in the Source folder. Another thing to note: that file (ShooterGameServer.Target.cs) isn't actually added in the VS project and is not referenced in the vcxproj files at all. It only exists in the filesystem.

Product Version: UE 4.9
Tags:
more ▼

asked Nov 01 '15 at 12:17 PM in Bug Reports

avatar image

CrumblyCake
1 2 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello CrumblyCake,

Go into your project folder and right click on the .uproject file and select Generate Visual Studio Project Files. If you have the Target.cs file in the Source folder, doing this should associate the file with Visual Studio.

more ▼

answered Nov 02 '15 at 04:43 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image CrumblyCake Nov 02 '15 at 08:20 PM

I probably wasn't clear enough on this, but I already did this and it still wasn't there:

after generating the VS project files...that file (ShooterGameServer.Target.cs) isn't actually added in the VS project and is not referenced in the vcxproj files at all.

I also tried just manually deleting the generated files before generation and it still doesn't appear or give the relevant configurations. And ShooterGame is untouched so the ShooterGameServer.Target.cs file is in place with the other target files in the Source folder.

Update: I also ran the .bat file in my 4.9 Engine/Build/Batch folder directly against the ShooterGame project with the same result.

avatar image Sean L ♦♦ STAFF Nov 03 '15 at 06:02 PM

Have you tried manually adding the Server Target file that is located in the project's Source folder to the Visual Studio project by dragging it in?

avatar image CrumblyCake Nov 04 '15 at 01:28 AM

I've found why it's not working. I'm running Rocket and it looks like you don't support server targets under it: https://github.com/EpicGames/UnrealEngine/blob/4.9/Engine/Source/Programs/UnrealBuildTool/System/ProjectFileGenerator.cs#L1745 It also doesn't look like you will support it either due to a subsequent increase in size of the installed engine: https://github.com/EpicGames/UnrealEngine/pull/584#issuecomment-84930164 A few hundred MBs for built-in dedicated server packaging seems like a good tradeoff to me :P But I recognise I'm a bit biased.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question