x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Access violation - code c0000005 (first/second chance not available)

Hi there. I am getting a crash when I play the level. I am currently working on clouds in my project and it seems that the crash occurs only when the cloud is in level. But I would like to know what exactly causes this issue.

MachineId:904EC64541A12C6F684482A893696E3D EpicAccountId:b914896b9e1b4cc8843a5c4345f12b76

Access violation - code c0000005 (first/second chance not available)

""

UE4Editor_Engine!FDynamicSpriteEmitterData::GetDynamicMeshElementsEmitter() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\engine\private\particles\particlesystemrender.cpp:1005] UE4Editor_Engine!FParticleSystemSceneProxy::GetDynamicMeshElements() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\engine\private\particles\particlesystemrender.cpp:6341] UE4Editor_Renderer!FProjectedShadowInfo::GatherDynamicMeshElementsArray() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\shadowsetup.cpp:969] UE4Editor_Renderer!FProjectedShadowInfo::GatherDynamicMeshElements() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\shadowsetup.cpp:931] UE4Editor_Renderer!FSceneRenderer::GatherShadowDynamicMeshElements() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\shadowsetup.cpp:1903] UE4Editor_Renderer!FDeferredShadingSceneRenderer::InitDynamicShadows() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\shadowsetup.cpp:2435] UE4Editor_Renderer!FDeferredShadingSceneRenderer::InitViews() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\scenevisibility.cpp:2347] UE4Editor_Renderer!FDeferredShadingSceneRenderer::Render() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\deferredshadingrenderer.cpp:710] UE4Editor_Renderer!RenderViewFamily_RenderThread() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\scenerendering.cpp:1355] UE4Editor_Renderer!TGraphTask<`FRendererModule::BeginRenderingViewFamily'::`17'::EURCMacro_FDrawSceneCommand>::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\public\async\taskgraphinterfaces.h:753] UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:430] UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:273] UE4Editor_RenderCore!RenderingThreadMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\rendercore\private\renderingthread.cpp:284] UE4Editor_RenderCore!FRenderingThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\rendercore\private\renderingthread.cpp:385] UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73] UE4Editor_Core!FRunnableThreadWin::GuardedRun() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26] kernel32 ntdll

Here is my log link text

Product Version: UE 4.8
Tags:
more ▼

asked Nov 01 '15 at 04:08 PM in Bug Reports

avatar image

Kvazimodo
31 4 8 7

avatar image Lovecraft_K ♦♦ STAFF Nov 02 '15 at 03:03 PM

Hi Kvazimodo -

You are probably correct in your assumption that it is your clouds, assuming that they are a Mesh Particle System with a Lit Translucent Material applied to them.

I would need to see the actual project itself to be more precise, but have you tried a copy of the project in 4.9 to see if the crash is eliminated?

If you can share the project, you may do so here or if you want to keep it private, you may private message me a link via the Forums.

Thank You

Eric Ketchum

avatar image Kvazimodo Nov 02 '15 at 06:19 PM

Hi Eric, I didn't test it in 4.9 . I am not sure about how to share a project but anyway right now it weights about 10 gigs. I'm a bit new to this - it may be I am missing something.

avatar image Lovecraft_K ♦♦ STAFF Nov 02 '15 at 06:32 PM

You would need to zip the Config and Content Sub Folders and the *.uproject file in a single zip file and if it is small enough you can upload here, but if not you can upload it to a dropbox or google drive and post a link to that location here or via private message.

Eric Ketchum

avatar image Kvazimodo Nov 03 '15 at 09:30 AM

Ok, I sent you the link.

avatar image Lovecraft_K ♦♦ STAFF Nov 03 '15 at 07:37 PM

Hi Kvazimodo -

Can you let me know what you're reproduction rate is for this issue? Does it happen everytime or every 10th time (etc.)?

Also, try to delete your Intermediate, and if there is one, your DerivedDataCache Sub Folders in your Project and see if the crash subsides for you.

I am testing the project you linked me and am not getting any crashes which leads me to believe that this may be an error in a saved Shader compile found in your Intermediate Folder.

Thank You

Eric Ketchum

avatar image Kvazimodo Nov 04 '15 at 08:10 AM

Hi Eric, I deleted the Intermediate and the DerivedDataCache folders but the crash still occurs. It usually takes about 2 minutes to crash. By the way, what engine version are you testing it on?

avatar image Lovecraft_K ♦♦ STAFF Nov 04 '15 at 03:30 PM

4.8.3, I will test again.

avatar image Lovecraft_K ♦♦ STAFF Nov 04 '15 at 05:09 PM

I have retested again in 4.8.3 and in 4.8.1 and waited a total of 5 mins looking at the clouds and not looking at the clouds in each version. Can you attach a copy of your DXDIAG?

Eric Ketchum

avatar image Kvazimodo Nov 04 '15 at 06:32 PM

Ok, here it is link text

dxdiag.txt (28.6 kB)
avatar image Lovecraft_K ♦♦ STAFF Nov 04 '15 at 09:01 PM

Hi -

Can you do me a favor and update your Nvidia Drivers? Your DXDIAG shows that you are on driver version 9.18.13.3489 (334.89) where the most current version is 10.18.13.5850 (358.50). See if this corrects the issue for you.

Thank You

Eric Ketchum

avatar image Kvazimodo Nov 05 '15 at 08:53 AM

Hi, I upgraded the drivers through geforce experience with the clean install option, but the game crashes all the same. It creates the Intermediate folder automatically. Also I have the "Saved" folder that weights around 7 gigs. Can it influence this situation somehow?

Well I tried testing the project that I sent you [with just content and config folders] with the same crash result.

avatar image Kvazimodo Nov 06 '15 at 08:30 AM

Any ideas, Eric?

avatar image Lovecraft_K ♦♦ STAFF Nov 06 '15 at 04:34 PM

Is there anything that you are doing in your project when you PIE, beyond looking at the cloud emitter?

Eric Ketchum

avatar image Kvazimodo Nov 07 '15 at 08:06 AM

I change the speed of the sun with the shortcut keys ["F" and "G"], sometimes I grab one of the rocks [the "E" key lets you enter the grab mode], carry it around or just push it around testing the physics. Eric, could you tell me what graphics cards do you have? I am beginning to think that my card is just not powerful enough :|

Eric, could you please check if the detail parameters of the cloud blueprint are the same in editor and inside the blueprint itself? Especially the lighting parameters. alt text alt text

cloud1.jpg (163.6 kB)
cloud2.jpg (183.8 kB)
avatar image Kvazimodo Nov 08 '15 at 09:35 AM

Eric, maybe I should find these parameters somewhere in the editor and modify them?

0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'TranslucentSortAxis = (X=0.000000,Y=-1.000000,Z=0.000000)' [2015.11.07-08.11.47:479][ 0]LogConsoleResponse:Warning: Found in ini file 'M:/Job3/Projects/Unreal4/Cydonia/Cydonia 4.8/Saved/Config/Windows/Engine.ini', in section '[/Script/Engine.RendererSettings]' [2015.11.07-08.11.47:480][ 0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleRule = ShortestSide' [2015.11.07-08.11.47:480][ 0]LogConsoleResponse:Warning: Found in ini file 'M:/Job3/Projects/Unreal4/Cydonia/Cydonia 4.8/Saved/Config/Windows/Engine.ini', in section '[/Script/Engine.RendererSettings]' [2015.11.07-08.11.47:480][ 0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleCurve = (EditorCurveData=(Keys=),ExternalCurve=None)' [2015.11.07-08.11.47:480][ 0]LogConsoleResponse:Warning: Found in ini file 'M:/Job3/Projects/Unreal4/Cydonia/Cydonia 4.8/Saved/Config/Windows/Engine.ini', in section '[/Script/Engine.RendererSettings]'

avatar image Kvazimodo Nov 08 '15 at 11:10 AM

Also I often get these artifacts, so maybe it will help you in some way alt text

flick1.jpg (360.5 kB)
avatar image Kvazimodo Nov 09 '15 at 10:21 AM

Well, now I am getting the crash when I have none of those clouds in the scene. It seems to me that there might be some problem with TranslucentSortAxis parameter or something like that. I was working on the plane with translucent material on it. While this translucent plane is in the scene alone - everything goes well, but when I switched on the second plane that is higher than the first one and has the same translucent material with different parameters of its material instance, the crash happened. So there is definitely something wrong with translucency. Here is the latest log link text alt text

avatar image Lovecraft_K ♦♦ STAFF Nov 09 '15 at 08:09 PM

Hi -

So I am going to try to answer all your questions, but if I happen to miss one, feel free to ask again.

The Blueprints match what you have shown above in the details. I was able to push around the rock, but not to pick it up with the E button and F/G do not seem to do anything in my project. (This may have to do with Input ini settings). I am running on a Nvidia GTX 770 card with driver version 355.98. Those Log ini warnings would not cause the crashes you are reporting above, so at this time I would leave them alone. Don't add more variables when trying to debug an issue. Finally the last crash you reported (the APEX_Destructible one) is related to the Physics and not the Emitters at all, and that particular issue I believe was corrected in 4.9.

Could you attach your DXDIAG here and I can look at your CPU specifications to see if their might be a problem there?

Thank You

Eric Ketchum

avatar image Kvazimodo Nov 10 '15 at 08:14 AM

Hello

This is quite a pity that you can't use the F/G keys, and strange - I thought that they had to work as they are put in the level blueprint. Do you have a day/night cycle working? The E button should enable the grab mode - you grab the object with the left mouse button, not with the E button, but if the F/G keys don't work, then the E button probably isn't working too. My driver version is 358.87 I found it very odd that the last crash showed something related to the Destructible because, as I stated above I was working only on translucency and although there is a destructible object in the scene, it wasn't touched at all. Anyway, here is the DXDIAG link text

dxdiag.txt (28.6 kB)
avatar image Lovecraft_K ♦♦ STAFF Nov 10 '15 at 04:55 PM

Hi Kvazimodo -

I was finally able to reproduce the crash in 4.8.3. I was not able to reproduce the crash in 4.9.2, so it looks like this particular issue was cleared up in 4.9. Please let me know if moving to 4.9 does not fix this crash for you.

Thank You

Eric Ketchum

avatar image Kvazimodo Nov 11 '15 at 08:51 AM

Hi Eric

I think that I have found the cause of the problem. I moved to version 4.9 and everything seems to be working fine, but it always crashes when you try to make level blueprint and cloud3 blueprint communicate with each other. The thing is that there is a parameter in the material of the cloud that regulates the emissive intensity, which I called "Corona". I want the emissive to switch off at night and be visible only at daytime. So right now the level blueprint tells this Corona to be active at the stated event point "Corona Switch" in the Rotation Timeline and it works. The crash happens when you change something in the Corona Switch event graph. I changed the value of the point but I think any other changes will also cause the crash. I will provide you with the latest project variant as I changed some things there. Here is the log link text
And some screenshots alt text alt text alt text alt text

bcrash1.jpg (598.5 kB)
bcrash2.jpg (479.0 kB)
bcrash3.jpg (402.1 kB)
bcrash5.jpg (308.5 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi -

I was able to successfully get a reproduction that was 100% and have entered the issue as UE-23236. As we investigate a solution, I will keep you informed here.

Thank You -

Eric Ketchum

more ▼

answered Nov 11 '15 at 08:46 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image Kvazimodo Nov 12 '15 at 07:52 AM

Thanks again for your help, Eric.

avatar image Kvazimodo Nov 29 '15 at 11:39 AM

Hi Eric, Are there any news on this problem?

avatar image Lovecraft_K ♦♦ STAFF Nov 30 '15 at 09:52 PM

Hi -

The issue has been assigned to an Engineer and they are actively looking at the root causes, but unfortunately I do not have a timeline for this one just yet.

Eric

avatar image Lovecraft_K ♦♦ STAFF Feb 22 '16 at 07:01 PM

Hi Kvazimodo -

I am testing a few different bugs and it looks like this issue will be cleared up in 4.11 Preview 5, but since we did have some issues finally getting a repro I wanted to ask if you could test a copy of your project to see if you get the same crash. You should not, the copy that I have here does not crash in 4.11.

Let me know -

Eric Ketchum

avatar image Kvazimodo Feb 23 '16 at 11:55 AM

Hi Eric, I will try and test the project in a new version.

Ivan

avatar image Lovecraft_K ♦♦ STAFF Feb 23 '16 at 02:42 PM

Thanks Ivan

Let us know what your results are when you are able.

Eric Ketchum

avatar image Kvazimodo Feb 24 '16 at 11:10 AM

Ok, so it still crashes. Even more, the tessellation is not working. Here is what I got - I made some corrections to the level blueprint, but the game seems to be crashing randomly. [link text][1]

data.rar (68.5 kB)
avatar image Kvazimodo Feb 24 '16 at 11:12 AM

alt text alt text alt text alt text alt text

cr1.jpg (116.3 kB)
cr2.jpg (249.9 kB)
cr3.jpg (277.8 kB)
cr4.jpg (216.7 kB)
cr5.jpg (315.0 kB)
avatar image Lovecraft_K ♦♦ STAFF Feb 24 '16 at 03:40 PM

Hello -

The Tessellation is a known issue in 4.11 and is being worked on, but it looks like your issue is still reoccuring. I have updated the information on the bug report and added the new crash information, thank you. I will try to keep you informed as we continue to try to investigate a solution.

Thank You again -

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question