x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Error OSX iOS

I have ongoing packaging problems getting my Projects on iOS. (Problem occurs in UE 4.9.2 and 4.10 Preview 3)

I have this issue with a new blank C++ project, and with my demo C++ project that I worked a few hours on.

When doing Launch -> iPhone in the Unreal error, it will just stop at some point.

Full Crash Log <-- Link

Here's only the last lines:

mono: System.IO.IOException: AFCFileRefOpen (/PublicStaging/UnrealEngineTest-IOS-Shipping.ipa) failed with error 7 mono: at Manzana.iPhoneFile.Open (Manzana.MobileDeviceInstance phone, System.String path, FileAccess openmode) [0x00000] in :0 mono: at Manzana.iPhoneFile.OpenWrite (Manzana.MobileDeviceInstance phone, System.String path) [0x00000] in :0 mono: at Manzana.MobileDeviceInstance.CopyFileToPhone (System.String PathOnPC, System.String PathOnPhone, Int32 ChunkSize) [0x00000] in :0 mono: at Manzana.MobileDeviceInstance.CopyFileToPhone (System.String PathOnPC, System.String PathOnPhone) [0x00000] in :0 mono: at Manzana.MobileDeviceInstance.CopyFileToPublicStaging (System.String SourceFile) [0x00000] in :0 mono: at DeploymentServer.DeploymentImplementation+<>c_DisplayClass7.b6 (Manzana.MobileDeviceInstance Device) [0x00000] in :0 mono: at DeploymentServer.DeploymentImplementation.PerformActionOnAllDevices (UInt32 DelayEnumerationPeriodMS, DeploymentServer.PerformDeviceActionDelegate PerDeviceWork) [0x00000] in :0 mono: at DeploymentServer.DeploymentImplementation.InstallIPAOnDevice (System.String IPAPath) [0x00000] in :0 mono: at DeploymentServer.Program.RunCommand () [0x00000] in :0 mono: at DeploymentServer.Program+<>cDisplayClass1.b0 () [0x00000] in :0 mono: at System.Threading.Thread.StartInternal () [0x00000] in :0 mono: [ERROR] FATAL UNHANDLED EXCEPTION: System.IO.IOException: AFCFileRefOpen (/PublicStaging/UnrealEngineTest-IOS-Shipping.ipa) failed with error 7 mono: at Manzana.iPhoneFile.Open (Manzana.MobileDeviceInstance phone, System.String path, FileAccess openmode) [0x00000] in :0 mono: at Manzana.iPhoneFile.OpenWrite (Manzana.MobileDeviceInstance phone, System.String path) [0x00000] in :0 mono: at Manzana.MobileDeviceInstance.CopyFileToPhone (System.String PathOnPC, System.String PathOnPhone, Int32 ChunkSize) [0x00000] in :0 mono: at Manzana.MobileDeviceInstance.CopyFileToPhone (System.String PathOnPC, System.String PathOnPhone) [0x00000] in :0 mono: at Manzana.MobileDeviceInstance.CopyFileToPublicStaging (System.String SourceFile) [0x00000] in :0 mono: at DeploymentServer.DeploymentImplementation+<>cDisplayClass7.b6 (Manzana.MobileDeviceInstance Device) [0x00000] in :0 mono: at DeploymentServer.DeploymentImplementation.PerformActionOnAllDevices (UInt32 DelayEnumerationPeriodMS, DeploymentServer.PerformDeviceActionDelegate PerDeviceWork) [0x00000] in :0 mono: at DeploymentServer.DeploymentImplementation.InstallIPAOnDevice (System.String IPAPath) [0x00000] in :0 mono: at DeploymentServer.Program.RunCommand () [0x00000] in :0 mono: at DeploymentServer.Program+<>cDisplayClass1.b_0 () [0x00000] in :0 mono: at System.Threading.Thread.StartInternal () [0x00000] in :0 CommandUtils.Run: Run: Took 1,738101s to run mono, ExitCode=1 BuildCommand.Execute: ERROR: BUILD FAILED Program.Main: ERROR: AutomationTool terminated with exception: Program.Main: ERROR: Exception in AutomationUtils.Automation: Command failed (Result:1): /Users/Shared/UnrealEngine/4.9/Engine/Binaries/DotNET/IOS/DeploymentServer.exe Install -ipa "/Users/Max/Documents/MasterDocs/Eignugspruefungen/UnrealEngine4/UnrealEngineTest/Binaries/IOS/UnrealEngineTest-IOS-Shipping.ipa" -device 20913ea7cdacf8dd50357b4f55a2a7172a02408a -additionalcommandline "-SessionId=4D3F4DBF274A2802D8991897CF266C45 -SessionOwner=MaxMuthig -SessionName='iPhone 6S' ". See logfile for details: 'DeploymentServer-2015.11.01-22.30.56.txt' Stacktrace: at AutomationTool.CommandUtils.RunAndLog (System.String App, System.String CommandLine, System.String Logfile, Int32 MaxSuccessCode, System.String Input, ERunOptions Options, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in :0 at AutomationTool.CommandUtils.RunAndLog (AutomationTool.CommandEnvironment Env, System.String App, System.String CommandLine, System.String LogName, Int32 MaxSuccessCode, System.String Input, ERunOptions Options, System.Collections.Generic.Dictionary`2 EnvVars) [0x00000] in :0 at IOSPlatform.Deploy (AutomationTool.ProjectParams Params, DeploymentContext SC) [0x00000] in :0 at Project.Deploy (AutomationTool.ProjectParams Params) [0x00000] in :0 at BuildCookRun.DoBuildCookRun (AutomationTool.ProjectParams Params) [0x00000] in :0 at BuildCookRun.ExecuteBuild () [0x00000] in :0 at BuildCommand.Execute () [0x00000] in :0 Program.Main: AutomationTool exiting with ExitCode=Error_Unknown Domain_ProcessExit RunUAT ERROR: AutomationTool was unable to run successfully.

Product Version: UE 4.9
Tags:
projectlauncher.log (192.8 kB)
more ▼

asked Nov 02 '15 at 02:05 PM in Packaging & Deployment

avatar image

framusrock
1 1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi framusrock -

It looks like in your logs that the OS cannot create a File Service that it needs. So, to test the easiest solutions first, Make sure that the Computer you are packaging or launching from is trusted by the iOS device, Make sure that you have sufficient room on the iOS device itself and finally if you have previously launched an app on the deivce with the same Project name, delete the previous version.

Try those three things and let me know.

Eric Ketchum

more ▼

answered Nov 18 '15 at 07:11 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question