x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] C4D Smoothing Groups inconsistent

Two meshes from C4D exported with 2013 FBX (7.3)

Both FBX's give this warning when importing..

Warning Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

The Sphere though seems to come in correctly (edges split in a strip around the middle).

The Cylinder though has hard edges only around its caps, the tube of the cylinder should be smooth. No amount of recalculating tangents and/or normals seems to fix it.

I have attached the FBX's in ASCII format.

alt text

link text

Product Version: Not Selected
Tags:
more ▼

asked Apr 21 '14 at 12:41 PM in Using UE4

avatar image

Anadin
361 10 18 27

avatar image BEEF DOCTOR Sep 26 '14 at 11:35 PM

I'm having exactly the same problem and can't seem to find an answer, any joy yet?

avatar image Anadin Sep 27 '14 at 01:40 AM

'fraid not no.

avatar image BEEF DOCTOR Sep 27 '14 at 12:08 PM

Out of interest, what version of c4d are you using?

avatar image yannoch Sep 27 '14 at 01:01 PM

Cinema4D R16 , Same problem. In UDK i can import with smouthing edges if i tic "explicit normals", but in UE4 this option is not available. Some have a tricks for that?

avatar image BEEF DOCTOR Sep 27 '14 at 01:28 PM

yeah I'm using R16 too, might test to see if I get the same results from R15. I am aware of the "Explicit Normals" option in UDK and have searched for something similar in UE4, I've found nothing. I'm wondering if there is a 3rd party Plugin for exporting FBX's for C4D, but seen as R16 is so new, I doubt it :(

avatar image yannoch Sep 27 '14 at 01:37 PM

Right ! I just trying to export my mesh from C4D R15 to UE4 and i have smouthing edges. I mean it's a issue with R16. :/ Waiting for patch, and rollback to R15 ...

avatar image BEEF DOCTOR Sep 27 '14 at 01:39 PM

Yes! i'll report back to maxon and let them know :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Oct 23 '14 at 07:51 PM by Tim Hobson for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

@ BEEF DOCTOR : I know this isn't your original post or meshes in the FBX but this does look to be an issue with C4D's export or something may not be smoothed correctly before export. I've imported the attached FBX files into 3Ds Max and can see that the smoothing groups are not a UE4 issue.

Thank you!

Tim

more ▼

answered Oct 02 '14 at 03:13 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image Anadin Oct 03 '14 at 04:24 AM

Actually it is fixed now with R16's 2014 FBX exporter. I didn't realise how long ago I posted the original bug.

avatar image BEEF DOCTOR Oct 03 '14 at 09:01 AM

Really? because I haven't had any updates for R16

avatar image BEEF DOCTOR Oct 03 '14 at 09:05 AM

Cheers @Tim Hobson ♦♦ but if you read the above posts we already figured out that it's an export problem with C4D R16, because R15 seems to export fine :D

avatar image Anadin Oct 03 '14 at 09:59 AM

Those files I originally exported maybe from R15 as FBX 2013 - it was a while ago :). today I exported them from R16 as FBX 2014 and they imported fine.

avatar image Tim Hobson ♦♦ STAFF Oct 03 '14 at 02:25 PM

@Anadin: Thanks for getting back! Glad this works now.

@BEEF DOCTOR: I was assigned the bug to make sure it got cleared out. Just wanted to check in and make sure that the issue was still not happening, especially since I do not have access to C4D (Only Max and Blender on my machine) it's hard to test something like this without the communities willingness to help sometimes! :)

avatar image BEEF DOCTOR Oct 03 '14 at 03:00 PM

cheers buddy, keep up the good work :)

avatar image Freestyledork Oct 15 '14 at 05:51 PM

Can you tell me a bit more about your settings, I can't seem to get importing to work without the smoothing group error. I tried with R16 and FBX 2014. Is there some other things ive missed?

EDIT - After playing around with the settings for a few hours I was unable to import with no errors. No matter what I tried in R16 faceting was on all my models. I tried some simple models in R15 and the faceting went away. To confirm this is a issue with R16 I saved out a model and opened it in R15 to export and it worked in UE4 with no faceting. You can see the faceting on the capsule in the back the rest were test from C4D R15 alt text

fbx_c4d_issues.png (569.4 kB)
avatar image BEEF DOCTOR Oct 17 '14 at 10:31 AM

When you export from cinema 4d r16, don't use FBX 2014 "The UE4 FBX import pipeline uses FBX 2013", this may help but for the time being I'm sticking with C4D R15.

avatar image Anadin Oct 17 '14 at 10:38 AM

UE4 uses FBX 2014 now, which actual version number of R16 do you have?

avatar image Freestyledork Oct 17 '14 at 09:22 PM

I am using C4D R16.027 and UE4 - 4.5.0-0+UE4.

Could you post a sample c4d scene or the exact options you pick exporting/importing?

avatar image BEEF DOCTOR Oct 18 '14 at 02:00 PM

Since the update to UE4.5 I'm getting faceting on FBX's from R15 now, this is getting really annoying now, I should be focusing on my materials and functionality but i'm too busy pissing around trying to get models to import correctly :(

avatar image Freestyledork Oct 18 '14 at 09:12 PM

@BEEF DOCTOR So if C4D R15 FBX 2013 works with UE4.5 but C4D R16 FBX 2014 worked with UE4.4 not sure whos to fault Maxon or Epic. I also read that if the FBX is imported to 3DS and exported it imports into UE4 fine, regardless I wish I could just import my models with no errors.

avatar image BEEF DOCTOR Oct 18 '14 at 11:20 PM

I upgraded my project to UE4.5 and now it doesn't matter if I export with C4D R15 or R16, i'm getting faceting.

avatar image Anadin Oct 19 '14 at 12:30 AM

alt text

Here is my attempt to make it facet, works fine for me Same C4D/UE4.5

Also my FBX file, https://dl.dropboxusercontent.com/u/4780157/Cylinders.zip

Can I see yours?

avatar image BEEF DOCTOR Oct 19 '14 at 11:50 AM

Ok, first off you seem to be confusing the issue, you say "So if C4D R15 FBX 2013 works with UE4.5 but C4D R16 FBX 2014 worked with UE4.4 not sure whos to fault Maxon or Epic."

This was Never the case:

  1. C4D R15 FBX 2013 Exported correctly to UE4.4 but not to UE4.5

  2. C4D R16 FBX 2013 or 2014 doesn't export correctly to UE4.4 or UE4.5

Here's some screen shots:

  1. C4D R15 FBX 2013 to UE4.5

  2. C4D R15 FBX 2014 to UE4.5

  3. C4D R16 FBX 2013 to UE4.5

  4. C4D R16 FBX 2013 to UE4.5

alt text

avatar image Freestyledork Oct 19 '14 at 07:00 PM

I attached my FBX file and the C4D file, any guidance is appreciated. It seems like I am exporting to FBX the wrong way as I was able to import yours fine.link text

fbx_test.zip (88.5 kB)
avatar image Anadin Oct 19 '14 at 10:30 PM

You guys Win! - thanks for the file Freestyledork, its the existence of the 2nd UV set. On my files if I add a 2nd UV set and import they become faceted.. Interestingly even if I turn OFF 'Generate Lightmap UV's' in the Model Build settings, the faceting is still there with 2 UV sets from C4D. The files look ok in Modo 801. @BEEF DOCTOR, can you try with only one UV map per mesh?

avatar image Anadin Oct 19 '14 at 10:41 PM

The only fix I have so far is to only have 1 UV set and rely on UE 4.5's Lightmap UV generation... Its NOT a problem exporting the same file (with 2UV maps) from Modo. That means its a C4D bug with multiple 2UV's (I'm a beta tested with Maxon so I'll go report it if I can figure out what the difference is)

alt text

avatar image Anadin Oct 19 '14 at 11:06 PM

Actually I think Epic should look at this too, both Modo 801 and Blender 2.71 have no issues with smoothing with the 2 UV maps, I tried using ASCII FBX's and seeing if there was anything bad in there and can find nothing that stops UE from breaking the smoothing on import.. ASCII FBX's here

link text

smoothingfbxuv.zip (10.0 kB)
avatar image Anadin Oct 19 '14 at 11:26 PM

Add just for another comparison, same meshes in Unity 4.6

alt text

avatar image Tim Hobson ♦♦ STAFF Oct 20 '14 at 02:37 AM

Hi Anadin,

I still do not believe this to be a bug with UE4. I took the meshes you linked above and without using UE4 imported them into Max. The first with 1 UV did have smoothing groups. The second with two UVs did not. This may need to be reported to Maxon if that's the case.

With regards to using Unity, it may be something in the way that they calculate normals rather than using ones from the mesh. I'm not sure there since I have not used Unity before.

Looking at the mesh FBX in an 3Ds Max and seeing that there are no smoothing groups on the second mesh shows me that this is not a problem with how UE4 is handling the FBX file but rather something in C4Ds export process that is being lost.

avatar image Anadin Oct 20 '14 at 02:39 AM

I agree, something is up with what C4D is doing with the mesh with multiple UV's (been a lot of recent work there) Interesting that MAX is also not dealing with it where MODO, Maya and Blender are all OK with it :( I'll be reporting it

avatar image Freestyledork Oct 22 '14 at 04:21 PM

Looking forward to a fix as this is rather annoying

avatar image BEEF DOCTOR Oct 20 '14 at 02:20 PM

How do Epic know this issue is open again? I gather they monitor these questions? I'm seriously considering going back to unity because this is becoming a pain in my arse.

avatar image Tim Hobson ♦♦ STAFF Oct 20 '14 at 03:47 PM

Hi Beef Doctor,

A lot of issues are assigned to our support staff or other developers. When the issue is resolved it is hidden in our assigned list but when the issue is opened back up by a new comment/question the issue reappears in our assigned tasks list. This is how I am aware when the topic has been re-opened.

avatar image Anadin Oct 21 '14 at 03:00 AM

Hey @Beef Doctor, did you try your mesh with just UV set?

avatar image BEEF DOCTOR Oct 21 '14 at 08:37 AM

Not yet, I have been away since yesterday, will try when I get back. I know you guys believe this not to be a bug with UE4 but rather something wrong with the way c4d exports, I disagree, I have been exporting out of C4D FBX 2013 with two UV's into older versions of UE4 and the smoothing groups (Phong angle) are fine. But when importing the same FBX into UE4.5 the smoothing is not there. This suggests that UE4.5 is not interpreting the data correctly and has nothing to do with C4d's export method.

avatar image BEEF DOCTOR Oct 21 '14 at 07:52 PM

Why has this been marked as closed when it clearly isn't?

avatar image Tim Hobson ♦♦ STAFF Oct 21 '14 at 08:38 PM

This has been resolved because this appears to be an issue on C4D's end with static meshes that have more than one UV with smoothing groups. The method I have used to test the issue does not use UE4 and I can see the issue that is being exported in the FBX file created with C4D when I import into 3Ds Max. This indicates that UE4 is not the source of the problem with the smoothing groups.

The image above displaying Unity with the smoothing groups correct is not a representative test case because Unity, from my understanding, applies an auto-smooth effect to it's imported meshes as indicated from this post on their UnityAnswers site.

avatar image BEEF DOCTOR Oct 21 '14 at 09:02 PM

I get what you are saying but that doesn't explain how I can export out an FBX out of cinema 4d R15 with two UV's and it work fine in UE4.4 but not in UE4.5. it's obviously caused by a change in unreal engine, thoughts?

avatar image Tim Hobson ♦♦ STAFF Oct 21 '14 at 09:13 PM

Post two simple meshes here that you've made. I'll test tomorrow in UE4 with 4.4 and 4.5.

I'm still happy to test this and take a look, but from what was already provided this appears to be an issue with C4D. We can test it though. :)

Tim

avatar image BEEF DOCTOR Oct 22 '14 at 07:22 PM

Hi Tim, I've made a small mistake, the build of the engine that reads C4D FBX correctly with 2 UVs is actually UE4.4.0, so you need to test the same FBX with UE4.4.0 and 4.5.0

Here's two FBX's (one is FBX 2013, and the other is FBX 2014 just incase you need em) and they both have two uv channels, Happy Testing :Dlink text

avatar image Tim Hobson ♦♦ STAFF Oct 22 '14 at 10:07 PM

Thank you for posting the spheres.

I was still not able to have smoothing groups in any of the following versions of the engine. My import settings were using the default settings and importing the normals with the FBX. The only difference was in 4.5 I unchecked the option to generate the Lightmap UV.

Here are my results:

4.3.1 alt text

4.4.0 (The one you suggested it was working with) alt text

4.4.3 alt text

4.5.0 alt text

Let me know your thoughts on this before I consider this resolved.

Thank you!

Tim

4.3.1.png (335.1 kB)
4.4.0.png (838.2 kB)
4.4.3.png (298.3 kB)
4.5.0.png (412.3 kB)
avatar image Anadin Oct 23 '14 at 02:59 AM

I did more checking on this and I have the same results as @Tim Hobson. Modo actually says both 2013 and 2014 meshes have 'Malformed' normals so regenerates them (kind of what Unity does) Ideally Maxon do need to fix this, it is a problem between C4D and 3DS Max too luckily for us. I have reported it and uploaded meshes/screenshots etc. Of course UE could have a recalculate button..... ;)

avatar image BEEF DOCTOR Oct 23 '14 at 08:10 AM

Hi guys I've just seen this, I will post my engine screen shots when I get home from work :D

avatar image BEEF DOCTOR Oct 24 '14 at 07:07 PM

Sorry I've been a bit absent, been busy getting the project back over to unity3d. This problem looks like it's not going to get resolved anytime soon and the clock is ticking i'm afraid, cheers for the help Tim :D

avatar image michelle0309 Oct 28 '14 at 07:50 PM

the solution is no use edge breaks in the phong tag!

avatar image BEEF DOCTOR Nov 01 '14 at 09:20 AM

no can do, I need edge breaks :(

avatar image ChaNinja Dec 01 '16 at 01:57 AM

This plugin seems to do the trick .... http://www.cactus3d.com/CDFBX.html Its $30 but tested and working perfectly using C4D R16 + UE4.13.

It uses FBX 2014.

https://postimg.org/image/hoef6etzh/

avatar image Eskel Jan 17 '17 at 05:28 PM

Sadly Cactus Dan passed away, and the site is not running anymore. :(

avatar image Eskel Jan 17 '17 at 05:37 PM

Can we re-open this issue? I can't get smoothing groups to work even on very small meshes (cilinders, spheres), in latest UE and C4D. No FBX version works.

avatar image tukor Feb 22 '17 at 01:22 AM

When importing to Unreal = FBX import options -> "Normal Import Method" = "Import Normals"

Have fun ;)

avatar image Cassidismal Mar 24 '17 at 10:52 AM

Running into this same issue. As a total noob to UE4 this is very discouraging!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question