x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor Compile No Longer Works, Only Compiling from VS Does

As of 4.10 preview 3, I can not longer compile from editor. I get this error:

CompilerResultsLog: Info C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\typeinfo(21): fatal error C1083: Cannot open include file: 'string.h': No such file or directory

I can compile fine from VS 2015, so I can work. But clearly, there is some difference as to paths or something between the two modes.

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Nov 02 '15 at 07:57 PM in Bug Reports

avatar image

gbrill
131 5 8 14

avatar image Doug E ♦♦ STAFF Nov 03 '15 at 03:39 PM

Hey gbrill-

I was able to add a new class and add code to the class which compiled when using the in-editor compile button. Do you get the same error inside a newly created 4.10 project? Also, does your computer have VS 2013 as well or are you only using VS2015?

Cheers

Doug Wilson

avatar image gbrill Nov 03 '15 at 03:53 PM

I have both VS 2013 as well as VS2015 installed. And there is 4.9.2 on there as well as 4.10. I should add some other details:

1) this is a project ported from 4.9.2 to 4.10 (from prev1-3)

2) it is not uncommon for me to encounter this kind of header error the Unreal, particularly on new or newly ported projects...but normally one finds that the "VC++ Directories" of the project are empty for some reason, and you just need to "inherit from project defaults" to get these going. But that wasn't the case here.

3) Note that I have a customized .builld.cs file, where I do bring in a number of outside headers and libraries. Of, course I would expect that build file to be run regardless of whether I am compiling from VS or Unreal.

4) have not tried a newly created project, but will go back the the machine and try that and post results in a couple hours.

avatar image Doug E ♦♦ STAFF Nov 05 '15 at 03:37 PM

I've still not been able to reproduce the error message you mentioned. Can you let me know if you get the same error in a new 4.10 project or in a new 4.9 project that is converted to 4.10? Also, does the error continue in 4.10 Preview 4?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi gbrill,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Nov 09 '15 at 06:13 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question