x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issues with Steamworks

Hi, so I'm having some issues with the Steamworks API. It's working correctly, but it seems to be causing an issue with the editor. I'm able to launch standalone games, but if I try to launch it via PIE, it says PIE failed to launch and the entire editor crashes. I'm also unable to connect to my localhost dedicated server, although I'm able to connect to a listen server just fine. When disabling Steamworks, everything works normally again. I can't seem to figure out what the issue is here.

I'm using the editor built from the source off GitHub, I believe it's version 4.9.2 (edit: nevermind, it's 4.10). Also I'm not sure if it's related, but when launching the editor via the Visual Studio debugger and trying to launch PIE, it asks to break around this line here. TArray LevelBlueprints = Level->GetLevelBlueprints(); That is line 2280 of PlayLevel.cpp.

While this is mostly an inconvenience at most, it'd be great to be able to fix it. Any advice is greatly appreciated.

Edit: So if I launch PIE with the number of players set to one, it works, but if I raise the amount of players or enable running a dedicated server, it crashes.

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Nov 03 '15 at 12:15 AM in Bug Reports

avatar image

Jeezy
6 1 4

avatar image Ben Halliday STAFF Nov 03 '15 at 05:08 PM

Hi Jeezy,

Please zip and attach the logs from the project's \Saved\Logs folder. It would also be useful to have the information in the Crash Reporter window if you get that, including the Machine ID, so we can look it up here. Make sure you hit Send.

Are you using the Steam SDK 1.32? That's what we're currently supporting.

avatar image Jeezy Nov 03 '15 at 05:37 PM

Logs

There's the log, although I feel there might be some mixed information in there because I've also been having issues with the editor crashing on nearly every successful compile but that's the least of my concerns. (even without the Steamworks API)

It appears I'm using the Steam SDK 1.35, I'll attempt to switch to 1.32 ASAP and report back. Also is switching to 1.32 as simple a switching the paths that my includes use?

Anyways, I'm not sure exactly what I'm supposed to be pulling out from the crash reporter, but this is what I see.

MachineId:BD82A434463F3E4E119AF2A479B93E58

Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000148

UE4Editor-UnrealEd.dll!UEditorEngine::PlayInEditor() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\playlevel.cpp:2276] UE4Editor-UnrealEd.dll!UEditorEngine::StartQueuedPlayMapRequest() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\playlevel.cpp:1047] UE4Editor-UnrealEd.dll!UEditorEngine::Tick() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\editorengine.cpp:1244] UE4Editor-UnrealEd.dll!UUnrealEdEngine::Tick() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\unrealedengine.cpp:361] UE4Editor.exe!FEngineLoop::Tick() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:2427] UE4Editor.exe!GuardedMain() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\launch.cpp:142] UE4Editor.exe!GuardedMainWrapper() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor.exe!WinMain() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] KERNEL32.DLL ntdll.dll ntdll.dll

logs.zip (3.1 MB)
avatar image Ben Halliday STAFF Nov 03 '15 at 06:43 PM

Thanks. There's certainly a lot of logs here, some of which have a lot going on. I'll sort through them to see if I can find anything useful.

The info in the Crash Reporter window, especially the Machine ID, really helps us compare the call stack between this and known issues. Did you hit Send? It doesn't appear to have made it to us. Can you try once more, being sure to hit Send before closing anything?

Let me know what happens after switching back to 1.32. Yes, simply switching the paths should be sufficient. There's some documentation here that may be helpful:

https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/index.html

Aside from the Steam SDK version references, it should be up-to-date. 1.32 has been included with 4.9.2 binary, but I'm not certain about 4.10 Preview or GitHub builds. Make sure you replace any 1.35 .dlls with the 1.32 version, if you changed those.

avatar image Jeezy Nov 03 '15 at 10:13 PM

Yes I did hit Send before closing anything, anyways I did it again so hopefully it made it to you this time. Changing the include paths for the SDK seems to be giving the same result, and yes I'm pretty sure 1.32 was included with this build since I saw the .dlls in there when setting it up. Going to try a couple more things, recompile, and then report back if I have any luck.

Edit: Maybe this screenshot could help out a bit. http://i.imgur.com/UA3Q0Se.png

avatar image Jeezy Nov 07 '15 at 09:17 PM

So I ended up forking a slightly newer version of the engine and recompiling it. Although it's kind of weird, at first steam overlay wasn't appearing in the editor and only in packaged games, but after recompiling my project recently it has begun to come up in the editor again.

On the bright side, attempting to launch PIE no longer crashes the entire editor, but it does still give the failed to start error. This is the one and only error I get in the message log.

Warning TravelFailure: PendingNetGameCreateFailure, Reason for Failure: 'SteamSockets: binding to port 0 failed (0)'. Shutting down PIE.

avatar image Ben Halliday STAFF Nov 10 '15 at 07:24 PM

Can I see your project's DefaultEngine.ini network settings? Does this occur in a new project as well, or only your current project?

It might be helpful for me to look at the project, if you don't mind uploading it somewhere for me. You can send me a link via PM on the forums if you'd prefer to keep it private:

https://forums.unrealengine.com/member.php?32-Ben-Halliday

avatar image Jeezy Nov 11 '15 at 08:33 PM

Here's my DefaultEngine.ini http://pastebin.com/xmbZxyhF I haven't tried it with a new project, I'll try that and let you know what happens. Also I've been told I'm not the only one with the dedicated server issue while using the steam subsystem. Anyway is there any specific part of the project that would be helpful? It'd take me ages to upload the entire 22gb folder and I don't know where I would upload it either.

avatar image Ben Halliday STAFF Nov 11 '15 at 09:23 PM

That's fine. Let's see if you're able to reproduce it in a new project first. If you're able, you can upload that someplace like Google Drive or Dropbox and share it with me.

And just so I'm clear, you tested this in a fresh install of the engine? Was that also 4.10? If you'd like to try the 4.10 official release, that was just pushed out today and would be the most helpful for testing this. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Jeezy,

We haven't heard back from you in a while, so I'm resolving this post for tracking purposes. If you were able to reproduce this in a new project or have any other information you can share with me, please feel free to respond and we'll continue investigating. Thanks!

more ▼

answered Nov 17 '15 at 05:43 PM

avatar image agzx1234 Nov 25 '15 at 02:59 PM

I have a problem.I can not find steamwork v 1.32,steamclient64.dll and tier0_s64.dll

avatar image Ben Halliday STAFF Nov 25 '15 at 06:30 PM

C:\Program Files\Epic Games\4.8\Engine\Binaries\ThirdParty\Steamworks\Steamv132\Win64 by default.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question