x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Assertion failed: IsValid() File:D:\BuildFarm

Hi,

Today when I open any UMG widget in editor, I get instant crash with this report. Funny, yesterday it worked fine.

Why is it refering to D:\BuildFarm ? I dont have such path on my system.

Do you guys need any more info about this Thanks

 Unknown exception - code 00000001 (first/second chance not available)
 
 "Assertion failed: IsValid() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Core\Public\Templates\SharedPointer.h] [Line: 739] 
 "
 
 UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\misc\outputdevice.cpp:374]
 UE4Editor_UMGEditor!FWidgetBlueprintEditor::UpdatePreview() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\umgeditor\private\widgetblueprinteditor.cpp:680]
 UE4Editor_UMGEditor!FWidgetBlueprintEditor::InitWidgetBlueprintEditor() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\umgeditor\private\widgetblueprinteditor.cpp:86]
 UE4Editor_UMGEditor!FAssetTypeActions_WidgetBlueprint::OpenAssetEditor() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\umgeditor\private\assettypeactions_widgetblueprint.cpp:32]
 UE4Editor_UnrealEd!FAssetEditorManager::OpenEditorForAsset() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\toolkits\asseteditormanager.cpp:311]
 UE4Editor_UMGEditor!FAssetTypeActions_Base::AssetsActivated() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\developer\assettools\public\assettypeactions_base.h:41]
 UE4Editor_ContentBrowser!SContentBrowser::OnAssetsActivated() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\contentbrowser\private\scontentbrowser.cpp:1757]
 UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SContentBrowser,0,TTypeWrapper<void> __cdecl(TArray<FAssetData,FDefaultAllocator> const & __ptr64,enum EAssetTypeActivationMethod::Type)>::Execute() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:282]
 UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SContentBrowser,0,void __cdecl(TArray<FAssetData,FDefaultAllocator> const & __ptr64,enum EAssetTypeActivationMethod::Type)>::ExecuteIfSafe() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:388]
 UE4Editor_ContentBrowser!SAssetView::OnOpenAssetsOrFolders() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\contentbrowser\private\sassetview.cpp:2726]
 UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SContentBrowser,0,TTypeWrapper<void> __cdecl(void)>::Execute() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:282]
 UE4Editor_ContentBrowser!TBaseSPMethodDelegateInstance<0,SContentBrowser,0,void __cdecl(void)>::ExecuteIfSafe() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:387]
 UE4Editor_Slate!FUICommandList::ConditionalProcessCommandBindings() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\commands\uicommandlist.cpp:206]
 UE4Editor_Slate!FUICommandList::ProcessCommandBindings() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\commands\uicommandlist.cpp:150]
 UE4Editor_ContentBrowser!SContentBrowser::OnKeyDown() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\contentbrowser\private\scontentbrowser.cpp:926]
 UE4Editor_Slate!<lambda_aecc0dcd28a75afb5aabe6b3b7d4c719>::operator()() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:3920]
 UE4Editor_Slate!FEventRouter::Route<FReply,FEventRouter::FBubblePolicy,FKeyEvent,<lambda_aecc0dcd28a75afb5aabe6b3b7d4c719> >() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:214]
 UE4Editor_Slate!FEventRouter::RouteAlongFocusPath<FEventRouter::FBubblePolicy,<lambda_aecc0dcd28a75afb5aabe6b3b7d4c719>,FKeyEvent>() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:196]
 UE4Editor_Slate!FSlateApplication::ProcessKeyDownEvent() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:3918]
 UE4Editor_Slate!FSlateApplication::OnKeyDown() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:3845]
 UE4Editor_Core!FWindowsApplication::ProcessDeferredMessage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:1260]
 UE4Editor_Core!FWindowsApplication::DeferMessage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:1709]
 UE4Editor_Core!FWindowsApplication::ProcessMessage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:707]
 UE4Editor_Core!FWindowsApplication::AppWndProc() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsapplication.cpp:629]
 user32
 user32
 UE4Editor_Core!FWindowsPlatformMisc::PumpMessages() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsplatformmisc.cpp:884]
 UE4Editor!FEngineLoop::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2391]
 UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:142]
 UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]
 UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]
 kernel32
 ntdll

Product Version: UE 4.10 Preview
Tags:
more ▼

asked Nov 03 '15 at 05:48 AM in Bug Reports

avatar image

tas
73 9 13 15

avatar image tas Nov 03 '15 at 05:58 AM

Im sure you will ask, if it happens in new project created from Launcher. Yes, its totally reproducible on my end. Also I deleted all files from C:\Users\\AppData\Local\UnrealEngine\4.10.

avatar image mdonge Nov 03 '15 at 07:47 AM

I've got the same problem, this morning all was fine, I closed UE editor with Widget editor opened (and game running in viewport), and I can't open them after that ...

It happened yesterday too ...

The only wait I've found is to rebuild the engine, and start again, but it's long ...

avatar image mdonge Nov 03 '15 at 10:22 AM

In fact it happen each time we close the UMG editor ... I tried this morning with a fresh compiled version, just opened the UMG editor and closed it (didn't do anything in the blueprint) and it won't open anymore ...

avatar image mdonge Nov 03 '15 at 11:46 AM

New test with 4.9.2, it doesn't bug when opening UMG editor...

avatar image Rudy Q ♦♦ STAFF Nov 03 '15 at 03:36 PM

Hello tas,

Thank you for testing this in a clean project, however I still have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Could you provide a detailed set of steps to reproduce this issue on our end?

  2. Could you provide screen shots of any blueprints that may be involved with this issue?

  3. Was the projects that you are using upgraded from an older version of the engine?

  4. When you say that you receive the crash when "opening" a widget, do you mean that you are opening up the widget blueprint or is this while running the project?

  5. Are you using windows 10?

avatar image tas Nov 03 '15 at 03:51 PM
  1. Open new project(blank TPP), create UMG widget, open this widget(double click), crash.

  2. There is nothing special in project that is crashing. I do it in blank project.

  3. It also happens in project upgraded from 4.9.2, but primarily it happens in project created in 4.10 created from scratch.

  4. It only happens when I open UMG widget. I can run editor normally with no crash, until I open UMG.

  5. Yes

  6. It doesnt happen in 4.9.2

avatar image mdonge Nov 03 '15 at 05:03 PM
  1. I use win7, if it can help

avatar image tas Nov 03 '15 at 05:31 PM

good to know its not win10 related.

avatar image Rudy Q ♦♦ STAFF Nov 03 '15 at 08:12 PM

Could you run a quick test with the preview 4 version of 4.10 and let me know if this is still an issue?

avatar image tas Nov 03 '15 at 08:15 PM

sure, lets try our luck :)

avatar image tas Nov 04 '15 at 05:09 AM

same on 4.10 preview 4. Rudy, can you reproduce it ?

avatar image Rudy Q ♦♦ STAFF Nov 04 '15 at 03:36 PM

I tried a couple more ways to try and reproduce the issue that you are having. I was unable to do so. Could you (tas and mdonge) provide your dxdiag?

avatar image tas Nov 04 '15 at 04:38 PM
dxdiag.txt (83.3 kB)
avatar image tas Nov 04 '15 at 07:31 PM

Rudy, would it be helpful if I start Editor from VS in debugging mode, catch the crash and send you over some logs ? Does it provide exact cause of the exception ?

avatar image mdonge Nov 05 '15 at 05:41 AM

Hope it can help you (I don't have 4.10 to try something this morning, sorry) link text

dxdiag.txt (33.1 kB)
avatar image yeshjho Nov 06 '15 at 07:17 AM

I have the same problem, too. And here's my dxdiag link text Additionally, I skipped 'DirectInput' and System Information when I executed dxdiag.

dxdiag.txt (72.5 kB)
avatar image Rudy Q ♦♦ STAFF Nov 10 '15 at 09:30 PM

Hello tas,

Could you try updating your drivers and let me know if this issue is still occurring?

avatar image tas Nov 10 '15 at 09:43 PM

Rudy, which drivers do you mean exactly ?

avatar image yeshjho Nov 11 '15 at 07:58 AM

Do you mean the video card driver? Yes, I updated last night (AMD 15.201.1151.1007-151103a-296068E) and it's still occurring

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We were able to reproduce this crash in a clean project. We have written up a report (UE-23217) and it has been submitted to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. During testing we found that the issue was caused by closing the animation and timeline windows. Thank you for your time and information.

Workaround:

Window > Reset Layout will allow you to open the blueprint again.

alt text

Make it a great day

more ▼

answered Nov 11 '15 at 03:54 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image yeshjho Nov 11 '15 at 04:22 PM

Wow IT REALLY WORKS! Thank you!

avatar image tas Nov 11 '15 at 05:49 PM

nice trick! thank you

avatar image DerChris Nov 12 '15 at 12:48 PM

also helped me. Thanks!

avatar image SouldomainTM Nov 16 '15 at 03:45 PM

Thanks, it works with the release version of 4.10 as well.

avatar image JonathanADaley Nov 16 '15 at 03:52 PM

I had this same issue, and posted a Bug Report on AnswerHub here: https://answers.unrealengine.com/questions/334085/crash-when-opening-umg-widgets-in-410.html

I posted the answer provided here on my post.

I want to confirm that this workaround works on both the Windows and the OS X binary versions of 4.10.0.

avatar image jtsmith Nov 17 '15 at 03:27 AM

It's worth noting that while this workaround does work, keep in mind that once in UMG you can not change your layout i.e. close the animation boxes, or the crash will occur again. Hope a hotfix comes soon. Thanks for the workaround anyway, I was worried it may have been a source control issue (my project is github.)

avatar image blofang Dec 09 '15 at 04:44 PM

WOW it works ! thank you, i thought i was doomed !

avatar image hahasasa Jan 19 '16 at 10:03 AM

YES! That what I want!!! it's back to work fine! :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question