x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmass crashed

Bug

-Lightmass crashes when building lighting even with preview lighting quality.
-Sometimes, the editor crashes as well when doing it and I receive a message of Windos telling me that the editor was closed due to a lack of RAM

Cause

-Lightmap resolution: some of my assets are set to a resolution of 32, some of them to 128 and the ones that need more quality to 1024. Lowering the resolution avoids the crashes, but decreases shadow quality.

My specs:

-GTX 660ti
-i5 3570
-8Gb RAM

Log

-Swarm Agent's log when building the lightmass. Lightmasscrash
-Line of the error: "16:05:50: [UpdateTaskState]: Task Killed locally by DANIEL-PC, counted as failure"

Additional notes

I don't have any anti-virus software and any other memory-consuming app running in the background. Is there any way I can fix it without buying more RAM? My scene isn't really complex and 8gb RAM seem enough for it, I don't know what I'm doing wrong.

Advanced thanks.

PS: Sorry if there's any grammar mistake, english isn't my mother tongue.

Product Version: Not Selected
Tags:
more ▼

asked Apr 21 '14 at 02:52 PM in Rendering

avatar image

Wowthever
1 4 8 8

avatar image A Rehman Feb 13 '19 at 02:55 PM

Here is the following error i am receiving.

=== Lightmass crashed: === Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:d:\build\++ue4\sync\engine\source\runtime\core\public\Containers/Array.h] [Line: 611] Array index out of bounds: 3232332 from an array of size 3232332

0x00007ff988e4a388 KERNELBASE.dll!UnknownFunction [] 0x00007ff9275cceaa UnrealLightmass-Core.dll!UnknownFunction [] 0x00007ff9274329b7 UnrealLightmass-Core.dll!UnknownFunction [] 0x00007ff9273762b9 UnrealLightmass-Core.dll!UnknownFunction [] 0x00007ff72cd10d80 UnrealLightmass.exe!Lightmass::FEmbreeGeometry::FEmbreeGeometry() [] 0x00007ff72cd19822 UnrealLightmass.exe!Lightmass::FEmbreeAggregateMesh::AddMesh() [] 0x00007ff72cd772ed UnrealLightmass.exe!Lightmass::FStaticLightingSystem::FStaticLightingSystem() [] 0x00007ff72cd1f44c UnrealLightmass.exe!Lightmass::BuildStaticLighting() [] 0x00007ff72cd4a5dc UnrealLightmass.exe!Lightmass::LightmassMain() [] 0x00007ff72cd6d83a UnrealLightmass.exe!main() [] 0x00007ff72cdf0fcc UnrealLightmass.exe!__scrt_common_main_seh() [] 0x00007ff98a653034 KERNEL32.DLL!UnknownFunction [] 0x00007ff98bc93691 ntdll.dll!UnknownFunction []

What will be the issue? The crash started after adding spotlight, even removing all the spotlights and saving all, still problem doesn't resolved.

Please help.

My PC Config is i5 4460 16GB Ram 4GB R9 380 AMD Gpu 256GB SSD 1TB HDD

Regards

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

First, make sure you have a lightmass importance volume in your scene.(this will probably solve your issue if you dont have one already)

Second, you can increase the virtual memory to make up for lack of RAM.

more ▼

answered Apr 21 '14 at 02:58 PM

avatar image

Jacky
16.6k 671 166 674

avatar image Wowthever Apr 21 '14 at 03:49 PM

I already had the lightmass importance volume, but increasing the virtual memory solved the problem. Thanks! :D

avatar image tech1187 Nov 04 '15 at 04:49 AM

I know this is an older post, but I thought I may ask here. I am also having the same issue as above. I seem to be having the problem only when I add Foliage to the project such as grass and or trees. I have 16 gig of memory and I have also increased the virtual memory up to 6+ gig more and still seem to be running out of memory. I do have the light-mass importance volume in the project as well. Also have tried reducing the light-map down to 35 and still have this problem. Any ideas why I am having these issues?

Error message from log:

Error === Lightmass crashed: === Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.9\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 77] Ran out of memory allocating 1920390176 bytes with alignment 0

Note: Some reason it is looking for the DVD drive (D:\ above line) not hard drive where Unreal 4 or project is installed.

avatar image Tim Hobson ♦♦ STAFF Nov 04 '15 at 02:43 PM

Hi Tech1187,

Have a look at the Swarm Agent/Lightmass Troubleshooting guide. Try the suggestions to resolve the issue. Also, only use Power of 2 (2, 4, 8, 16, 32, etc) lightmap resolutions.

https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting#.22Ran_out_of_Memory.22

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question