x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal editor process never stops on close.

Unreal editor never closes in the background and in fact keeps increasing memory usage when i close the program by normal means... Only ctrl alt delete and killing the process actually ends it. Was wondering why my comp was running like crap... and that was the reason. 10 min after quitting it was still running in the background and it does this every time.

Just thought id report this.

Product Version: UE 4.9
Tags:
more ▼

asked Nov 04 '15 at 02:45 PM in Bug Reports

avatar image

kurylo3d
464 46 80 105

avatar image Matt.Williams Nov 04 '15 at 04:51 PM

Hey kurylo3d,

Is this every time you close the editor? Also I want to confirm that it's the UE4Editor.exe process and not the EpicGamesLauncher.exe

-Matt W.

avatar image kurylo3d Nov 04 '15 at 07:11 PM

Yes its teh UE4Editor.exe...

and sometimes ill be at like 7gb used memory, but after i close the editor it will very gradually keep goign up... i've seen it get to 10 gb after closing...

avatar image kurylo3d Nov 04 '15 at 08:41 PM

Also not sure if its every time but i can confirm it has happened to me at least 10 times if not more.

avatar image Stunt Thumper Nov 04 '15 at 05:41 PM

Are you creating any custom Threads?

avatar image kurylo3d Nov 04 '15 at 07:11 PM

No. No programming has been done in the scene.. im an artist jsut building a level.

avatar image Assist Nov 05 '18 at 09:19 AM

Yes same issue here. It's happened in the past from time to time, but since 4.20 (perhaps 4.19, not sure) it occurs all the time. The UE4Editor.exe process isn't killed by closing the editor.

Aside from the occasional RAM leaking, having 2 editor processes open prevents from being able to save any blueprint. Therefore, I have to systematically kill UE4 editor process with the task manager whenever I restart it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first

Can you download 4.10 Preview 4 and tell me if it's still occurring there?

more ▼

answered Nov 05 '15 at 10:56 PM

avatar image kurylo3d Nov 06 '15 at 03:25 AM

maybe next week.. would prefer to wait for final 10.. dont like working off preview versions.

avatar image Matt.Williams Nov 06 '15 at 07:04 PM

If you'd prefer to wait, I'll be marking this as fixed for tracking purposes.

avatar image kurylo3d Nov 16 '15 at 07:53 PM

Ok i tried it with 4.10 final and same issue. Its either not closing in the background process... or it is taking very very long and keeps adding to the memory number... im talkn gbs worth of memory extra climbing after close... Usually just ctrl alt delete it or my comp becomes unuseable.

Problem is reproduceable on multiple computers.. with different hardware.

avatar image Matt.Williams Nov 16 '15 at 09:06 PM

Can you send me the dxdiag info for all those computers? Like I said, this is not reproducable here and we'd like to see if we can set up a test machine. Can you try this on a blank sample project?

avatar image kurylo3d Nov 16 '15 at 09:27 PM

link text

Here is 1 dx diag.. other comp is at home...

I will say my project is pretty huge so maybe you need a project thats taking up a lot of resources to replicate it.

dxdiag.txt (53.9 kB)
avatar image Matt.Williams Nov 17 '15 at 07:50 PM

Can you update to the latest non-beta driver for your GPU?

avatar image kurylo3d Nov 17 '15 at 09:55 PM

link text

Here is the other dx diag from the other computer.

dxdiag.txt (59.0 kB)
avatar image Matt.Williams Nov 23 '15 at 01:34 PM

Can you update to the latest non-beta driver for both of your GPU's? Also, did you try this on a blank project to confirm whether or not it's something going on with your project?

avatar image kurylo3d Nov 23 '15 at 01:50 PM

The computer with the gtx 980 was updated to the latest non beta driver over the weekend. I still have to end up control alt deleting unreal usually.. It sticks around for a while. Don't know if its permanent, but if you are working on a very big project it tends to just stay in the background for a while taking up resources.

avatar image kurylo3d Nov 23 '15 at 03:54 PM

Also, Just noticed something else.. Hitting play with standalone mode also creates anotehr instance of UE4Editor.exe ... and it also does not disappear until i ctrl alt delete it.. Just noticed cause my computer was no longer respond as it was trying to close it properly but couldnt i guess.

avatar image Matt.Williams Nov 24 '15 at 08:44 PM

We've tried to reproduce this with KiteDemo, which is gigantic. The UE4Editor.exe process hangs around for about 5-10 seconds after closing and then goes away.

I need to know if this is occurring outside of your project. Can you download KiteDemo and attempt to load all the levels, then close the editor(should be taking up about 10GB of RAM after loading the levels)?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yes i get the same using 4.20.3, i guess they will never fix this problem

more ▼

answered Oct 12 '18 at 05:45 AM

avatar image

taw116
6

avatar image IntervideoFilm Nov 08 '18 at 10:24 AM

Have this problem for a while now (4.20.3 and before). Are you developing for Android? I read here about adb causing it: https://answers.unrealengine.com/questions/85232/ue4exe-and-adbexe-still-work-in-system-background.html But this is 4 years old...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm having the same issue on different systems as well, but usually the process remains for 5-10 minutes making my pc incredibly slow (which it does as well when the editor is running 99% ram usage) Maybe that's related somehow?

more ▼

answered Jan 22 '16 at 03:41 PM

avatar image

Rashura
96 5 6 12

avatar image kurylo3d Jan 22 '16 at 06:19 PM

I've given up on this. Just ctrl - alt - delete it after u hit close and the window is no longer in view. The ram usage usually goes way up after u hit close .

avatar image Rashura Jan 22 '16 at 08:05 PM

I guessed as much T_T

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This keeps happening on UE 4.15.1

I close the editor using 600mb and stays on background growing untill it reaches 3.5gb of memory usage.. computer starts to run slow.. and after a few minutes the process dies and everything goes back to normal.

Pretty annoying to be honest!

Specs: I7 4770k - 8gb 1866mhz - 3 HDD with 1TB each

more ▼

answered Apr 12 '17 at 09:01 AM

avatar image

D4rkul4
1 1 2

avatar image Matt.Williams Apr 17 '17 at 09:48 PM

Hi delfrasco,

This type of thing can happen for a number of reasons. If you'd like us to investigate your case, please post a new thread in Bug Reports.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This happened to me today with 4.20.3. 6GB pre-close, 8.5GB post-close. Waited 20 minutes then killed the process manually. Posting this here to underline that this problem was known before - same as the initial poster from this thread, i worked on some map design. In my case i updated a material on a rather big portion of my map, so this could be an issue with shader compiler cleanups or something in that general direction.

more ▼

answered Sep 25 '18 at 12:14 PM

avatar image

Tymax
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same Problem with 4.22 and all other Versions before. The only Way is kill the Prozess with Taskmanager! strange is also that the engine works about 15 minutes with low Ram load and then makes the RAM close. Even if I do nothing in the engine! It's terrible to restart the engine every 30 minutes just so the Ram can be used again! There seems to be a problem with the engine and the Ram allocation. The engine is stuck in the Ram even if nothing is done and uses more and more Ram until it is busy!

more ▼

answered Apr 21 '19 at 04:25 AM

avatar image

bulatburato
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question