x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Paint Foliage: don't see texture

Hi, I'm painting some grass on my landscape. I already searched in the forum for an answer but I did not find it.

  • when asked to add foliage type in the Paint Foliage, I added mesh that already has a texture on it.

However, when I paint it, I can see the texture in the viewport, but when i launch the preview of my landscape all my grass are planes without the texture on it (just grey and dark grey squares).

Do you have any idea for how can I solve this problem?

thank you in advance

Product Version: UE 4.8
Tags:
more ▼

asked Nov 04 '15 at 03:13 PM in Rendering

avatar image

Dizfoo
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'd start with opening up the foliage you are trying to use and make sure it has the proper mesh selected. If that's all ok I'd check the static mesh itself which the foliage file is based on and make sure it has a material applied to it.

more ▼

answered Nov 04 '15 at 03:30 PM

avatar image

Crowley Caine
693 8 10 16

avatar image Dizfoo Nov 04 '15 at 04:14 PM

alt text Hi, thank you for your answer. As you can see in the image attached the material is already applied on the mesh that I'm using to create grass. Also, you can see that in the viewport I can see my grass, but not in the preview. Can be that some settings in the details view cause this problem?

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello mate, if you havent found the answer yet i've faced a similar problem with applying Materials to landscape segment and Andrew was so kind to help me out. After i solved this i found out i was getting the same Tile Effect on one of my foliages. I went to the material applied in the static mesh i used in my foliage, i clicked my texture samples and changed the Sampler Source to Shared:Wrap. This fixed my problem and hopefully it will do the same for you! alt text

Also here's a link from the exact solution Andrew posted for me in case you face another problem like mine in the future. Take care! https://answers.unrealengine.com/questions/374153/materials-not-displaying-correctly.html

help.png (456.1 kB)
more ▼

answered Feb 11 '16 at 05:43 PM

avatar image

NovacainE
13 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question