x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Why is Visual Studio now required?

I am very new to UE4 and have just begun experimenting with it as an architectural visualization tool so my knowledge is very limited and I apologize in advance if this is a stupid question.

I have been working on a test project for a little while and have packaged it several times, however as of today I haven't been able to as it says installation of Visual Studio 2013 is required. What could I have done to prompt this, and is there a way for me to go back to packaging the project without installing it?

Product Version: UE 4.9
Tags:
more ▼

asked Nov 05 '15 at 11:10 AM in Packaging & Deployment

avatar image

Macbeth_
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jul 01 '16 at 08:41 PM by Samantha Sutton for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks!


1 answer: sort voted first

HI!

When you only work in Editor with blueprint projects, you not need VS 2013. But if you work with C++ project you need install VS 2013. Also you need VS 2013, if you want package your projects for publishing.

more ▼

answered Nov 05 '15 at 01:20 PM

avatar image

svv3dUDN
8.4k 254 41 399

avatar image Macbeth_ Nov 05 '15 at 01:33 PM

Hello!

Thanks for your help, in that case could it be an asset I added to the project from the market place might work with C++ and has introduced it to the project? Is there a way to restore the project to a point where VS 2013 isn't required?

Thanks Again.

avatar image Macbeth_ Nov 06 '15 at 09:45 AM

Removing one of the plugins installed from the marketplace solved the issue. However I now receive the error 'RunUAT.bat ERROR: AutomationTool was unable to run successfully' (I don't know if this is related...).

avatar image svv3dUDN Nov 06 '15 at 11:51 AM

What happening, if you create new project from template and package it?

avatar image Macbeth_ Nov 08 '15 at 06:41 PM

Sorry for the delayed response, I made a new blank project and that packaged fine. But i migrated the level from the original project and now I get the same error.

avatar image Macbeth_ Nov 09 '15 at 03:32 PM

The new error seemed to have been caused by some asset names being too long. I renamed them and all is well, thanks for your help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question