x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How do I make my foliage render properly when testing my game outside the editor?

For some reason my foliage - specifically the leaves part of my foliage - isn't rendering properly when I try running the game outside of the editor. On the other hand if I test it in-editor it runs fine with the leaves transparent texture rendering and swaying as it should be.

Any ideas why? Below is a screenshot of the leaves. If you need any more info let me know and I'll post it as soon as I can. Thank you!

Outside of Editor Playtesting

Product Version: UE 4.9
Tags:
more ▼

asked Nov 05 '15 at 06:44 PM in Rendering

avatar image

TheDiceParadox
1 1 3

avatar image TheDiceParadox Nov 05 '15 at 07:11 PM

This screenshot shows the tree foliage I have as well as some grass. As you can see the trunk of the trees renders properly, the grass does as well, the leaves on the other hand are just gray and sad :/

Another screencap with 3 different materials showing, 2 of them rendering properly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It was a weird bug, I replaced the material with an exact copy and it fixed it self.

GG gals and gents, GG.

more ▼

answered Nov 05 '15 at 08:35 PM

avatar image

TheDiceParadox
1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question