x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Package game for HTML5 not working, opening Unreal Engine docs webpage.

I have read and reread HTML5 packaging questions and the docs for unreal engine html5 packaging and followed the instructions. I now have the device manager under 'Launch' showing Chrome for HTML5 connected. However when I try to package the game with HTML5, it opens web browser to the getting started guide in unreal engine docs. What am I missing... I can provide more information if needed, but may need to hear the request in layman's terms.

This is a blueprint project using 4.8.3 that has already packaged well on desktop and android. Just want to package for HTML5 to add the game to my website.

Thanks

Product Version: UE 4.8
Tags:
more ▼

asked Nov 06 '15 at 11:13 PM in Packaging & Deployment

avatar image

Bamwd5
128 10 13 19

avatar image Bamwd5 Nov 06 '15 at 11:30 PM

Could this have to do with not having "ENV Variables" setup? (I've done nothing for this to my knowledge).

OR could this have to do with not "compiling HTML5" for UE4? (Not sure if this is an extra step not mentioned in the unreal engine docs for getting started developing with HTML5)

Thanks again

avatar image Bamwd5 Nov 07 '15 at 12:18 AM

link text

Here is error from project launcher. First error seems to be No BuildPlatform for HTML5.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Bamwd5,

I've not been able to reproduce this on my end. Everything seems to package fine for me that I can see with my test project. My test project is just the Blueprints template First Person.

  • So with that in mind. Does this only happen in your project or any project you create and package for HTML5?

  • Are you using the latest version of Emscripten and Python 2.7.10? (You can find the links to these on the HTML5 documentation page)

  • Are you launching on Chromium 64-bit or FireFox Nightly build 64-bit?

  • Make sure that your Project Settings > HTML5 SDK settings are correct as well by pointing to the correct directories and SDK.

Thank you!

Tim

more ▼

answered Nov 12 '15 at 03:28 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question