x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Help with unlit texture/material washed out.

I just created a brand new project in 4.9 and imported a mesh from 3dsmax. It brought in the texture and generated a material from it. I then went into the material and set it to unlit. No matter what I do it is washed out and I'm not sure what to do about it.

The right side of the screenshot below shows the texture as it is in photoshop prior to saving the PNG. The left side shows the image after it is imported into unreal. Behind the textures you will see the mesh in the viewport. I also tried unchecking the sRGB on the texture (which does in fact take away the washed out look) HOWEVER it continues to show the washed out texture in the material and viewport.

What could I be doing wrong?

Thank you for any help provided!

alt text

Product Version: UE 4.9
Tags:
material.jpg (460.2 kB)
more ▼

asked Nov 07 '15 at 05:19 PM in Rendering

avatar image

jeffvoigt
423 19 34 61

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi!

Your PSD texture in 16-bit mode. This is Linear texture and in the UE4 you need disable sRGB interpretation.

alt text

alt text

srgb01.png (941.0 kB)
srgb02.png (912.9 kB)
more ▼

answered Nov 09 '15 at 01:31 PM

avatar image

svv3dUDN
8.4k 254 39 399

(comments are locked)
10|2000 characters needed characters left

Please read all of my post and you will see I tried that, but viewing the material did not reflect the changes even though the texture did.

more ▼

answered Nov 09 '15 at 02:19 PM

avatar image

jeffvoigt
423 19 34 61

avatar image svv3dUDN Nov 09 '15 at 03:03 PM

UE4 incorrectly work with Linear images. You need manually delete gamma from your image, if you want import to UE4 PSD in 16-bit mode. As you can see, textures have a little difference. Value 0.45 this is inverse of Gamma 2.2. Use in UE4 linear images for color texture not good idea.

alt text

srgb03.png (742.2 kB)
avatar image jeffvoigt Nov 09 '15 at 03:07 PM

What is the recommended approach. Should I just output all psd files to 8-bit pngs?

avatar image svv3dUDN Nov 09 '15 at 03:24 PM

If you need, you can continue work in Photoshop in 16-bit mode. Before export, you just need switch to 8-bit mode and save to PNG or TGA.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question