x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

.uproject missing in packaged project

Alright, so today I wanted to release an alpha version of my game for public testing. First ever release of the game in fact. Packaging it went well. No errors were reported. BUT, I ran into an issue when testing to see if the new package would actually work. At first I had used a development configuration, and when I opened the .exe in the root of the package folder, it gave me a black screen, with a dialog box saying "Fatal error" and nothing else.

Then I tried a Shipping configuration.

Got another error: "Could not find descriptor file '../../../ProjectProtostar-Win32-Shipping/ProjectProtostar-Win32-Shipping.uproject'."

I tried looking it up, tried messing with build settings, etc, to no avail.

THEN I got risky. I copied the .uproject that was found in the root of the game's source code to the path the error said to. It got rid of the error, but I was greeted with another black screen, but this time with no error. I couldn't tell if it was inside the Main Menu level (it has no sky, and nothing but a single building with a camera inside, and a level blueprint to spawn the menu) as no menu was spawned, and I couldn't rotate or move the camera to see if the building was even there. I don't know if it was the level I was seeing and that I spawned in the wrong spot, or it just couldn't load it.

If anyone's experienced a similar issue (minus the final black screen part, I'm guessing that has to do with the game not knowing where the .pak file containing all the assets are due to the .uproject not telling it, or something like that) and they've somehow fixed it, PLEASE let me know.

I am in UE4.9.2, using the Epic Games Launcher release. My project is full blueprint, and works just fine in the editor.

Product Version: UE 4.9
Tags:
more ▼

asked Nov 09 '15 at 01:23 AM in Packaging & Deployment

avatar image

TheShiftOSGuy
10 4 5 10

avatar image Samantha Sutton ♦♦ STAFF Nov 10 '15 at 09:33 PM

Hey TheShiftOSGuy,

  • Could you please tell me which version of the engine you've packaged in?

  • What platform are you packaging for?

Please look over the links that are listed under "Failed to Open Descriptor File after Packaging". Please also attempt to package and run a UE4 template and let me know if the same happens to that project.

Looking forward to hearing back from you, thanks!

avatar image MagicTigger Nov 16 '15 at 07:48 PM

same with 4.10.0 https://answers.unrealengine.com/questions/334468/build-isnt-working-correctly.html

Engine Version 4.10.0 Packaging for Windows 64 and Windows 32. Same result

Trying a clean build of "Vehicle Advanced BP" works. :(

Cheers!

Tigger

avatar image Samantha Sutton ♦♦ STAFF Nov 18 '15 at 05:45 PM

MagicTigger,

I see that you've already resolved this by unchecking generate chunks. Let us know if you run into anymore complications.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey MagicTigger,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Nov 23 '15 at 05:09 PM

avatar image MagicTigger Nov 24 '15 at 08:04 AM

Dear Samantha, many thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question