x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

XML Packaged project

Hi, I'm having some problems with my project.

Few days ago I decided to use XMLParser that UE4 provides. Its works good, I can load file and have access to its attributes, contents, etc. The problem begins when I try to package my project. I can package the project for windows 64 bits, but when I want to open it a new window appears saying: Fatal Error.

I guess the problem is generated by the XML file, because my code wants to access it but it can't (I guess). I've been asking in the Unreal Developers facebook Page and they told me that maybe this XMLParser won't work on packaged builds.

So, is this true? I can't use this if I want to package my project? And if it is tru, why should Unreal let me use this tool with the developing but I can't use it for shipping?

I want to use this XML to store some level information and load it when the game begins. If it is not possible to use it, there is another way to use XML files to store and load this information for future packaged builds?

Thanks in advance.

Product Version: UE 4.9
Tags:
more ▼

asked Nov 09 '15 at 02:45 PM in C++ Programming

avatar image

ezrubiera
41 5 6 9

avatar image Bertram.Sch Nov 20 '15 at 01:11 PM

Same problem here. Dont have a solution either...

Bump :-)

avatar image ezrubiera Nov 20 '15 at 01:31 PM

Sorry I haven't posted my solution.

My problem was that I was not packaging the XML file. In the packaging settings I had to put my xml file path to package in the advance settings, where it says 'Aditional files to package' or something like that. Try that, worked for me.

avatar image Bertram.Sch Nov 20 '15 at 01:46 PM

Solved it myself too, i copied the xml by hand into the right path in the packaged version. Should do the same thing.

avatar image ezrubiera Nov 20 '15 at 02:19 PM

Yeah, that works, but if you want to have it packaged in the .pak file, you must do what I said before ;-)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

My approach was more for testing purpose, the recommended way is yours, adding the containing folder to:

Project Settings -> Packaging -> Additional Non-Asset Directories to Package

alt text

xml.png (103.9 kB)
more ▼

answered Nov 23 '15 at 09:37 AM

avatar image

Bertram.Sch
46 3 9 9

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question