x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media texture not working

Hi, when i run my .exe my media texture, with my movie in the content/movies, doesn't play. i tried putting in another location and it worked [i created a c:/videos then it played]

Any suggestion? ty

Product Version: UE 4.9
Tags:
more ▼

asked Nov 09 '15 at 07:02 PM in Packaging & Deployment

avatar image

Albeheon
31 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Media files currently have to be located inside /YourProject/Content/Movies, otherwise they will not package/deploy.

more ▼

answered Nov 09 '15 at 07:23 PM

avatar image reedandrader Nov 09 '15 at 08:08 PM

Having the same problem with 4.9. Movies are black on a Standalone Game. Everything worked fine with older versions but not with 4.9. I am triggering the media texture with play in blueprints. My media is in a Movies folder. No luck.

avatar image Albeheon Nov 10 '15 at 10:41 AM

As i said, my movie is already inside this folder and still not working during the package...

avatar image AndrewHurley Nov 10 '15 at 03:45 PM

How are you packaging your project?

Are you using the Shipping or Development build configuration?

avatar image dpham Jan 31 '16 at 07:07 AM

I have the same issue, doing both Shipping and Development. In the packaged folder, I already see the movie file located in the content/Movies/ folder, but it doesn't play.

avatar image AndrewHurley Jan 31 '16 at 09:50 PM

Hey Xerafel,

Could you provide me with the engine version you are working in, and the video format you are using? i.e. 4.10.2 and .h264 encoded media file.

Also, what platform are you packaging for?

Thanks,

Andrew Hurley

avatar image State128 Feb 17 '16 at 08:49 AM

I get a similar problem. My UMG Media texture plays fine uncooked and in editor. But after package (Development) it turns black. A message flashes by saying: "Texture Streaming Pool Over 20512.00 MB" The movie is 62.5 MB and it all looks good when checking the stats. Also tried to pump up the streaming pool size without any luck... Could there be a movie file-type issue? Right now we use AVI files (Get the same result with Shootinggame Loading.mp4 though)

avatar image AndrewHurley Feb 17 '16 at 02:45 PM

Take a look at our documentation. We state that there are known issues with certain encoded media files and file types such as .mp4

Media Framework

https://docs.unrealengine.com/latest/INT/Engine/MediaFramework/#whatismediaframework

The texture streaming issue means you are going over the allotted Texture Pool Memory size, and some of your textures are being streamed out of memory. This is a separate issue from the Media Framework issue, and we ask that you create a new AnswerHub post so we can track the problem on its own thread.

avatar image State128 Feb 19 '16 at 07:43 AM
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question