x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTML5 - how to make it work?

Ok, guys, I have created an empty project without any content and try to build in HTML. Build procces have been completed fine without any errors. I tried to do it from UnrealEditor and by Frontend tool. But my html file is not working in any browsers (32 or 64 bit). Finally, what I have to do to make it work? Please, give me some help.

alt text

Product Version: UE 4.8
Tags:
untitled-1.jpg (378.2 kB)
more ▼

asked Nov 11 '15 at 11:22 AM in Packaging & Deployment

avatar image

AlexFecit
11 2 4 4

avatar image Samantha Sutton ♦♦ STAFF Nov 11 '15 at 10:04 PM

Hey Alex,

Did you locate the HTML5LaunchHelper.exe file that's included within your packaged project folder? If not, please launch that first, then open a browser for testing and browse to the location of: http://(machinename):8000 and it should populate for you.

Let me know what steps you've taken, thanks!

avatar image AlexFecit Nov 12 '15 at 08:29 AM

Hi Samantha, thank you for your participation. My packaged project folder doesn`t contain HTML5LaunchHelper.exe. But I found it in UE4 DotNET folder and launch them. What shoud be happen? Then I opened browser and typed http://(machinename):8000 but it not working. I have tried put HTML5LaunchHelper.exe file in my packaged folder, no changes.

Please, tell me step by step what I have to do?

Here is my packaged folder after package is complete and browser:

alt text

untitled-1.jpg (427.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Nov 12 '15 at 07:00 PM

It seems you're not on a new version of the engine. Here are the instructions on launching your HTML5 project in an older version of the engine:

  • Package the project for HTML5

  • Navigate to the folder where the packaged project was placed

  • Locate the HTML5LaunchHelper.exe file

  • Double Click the helper file

  • A DOS prompt/command window will open

  • Open browser being used for testing

  • Browse to location listed next to Starting Server at: http://(machinename):8000

Please make sure you're using Google Chromium or FireFox Nightly.

avatar image AlexFecit Nov 14 '15 at 09:48 AM

I have tried in UE 4.10 and Nightly.I created empty project without any content. I did steps that you tell me and I have tried to launch direct from editor and in a both case what I got: alt text alt text

untitled-1.jpg (488.7 kB)
untitled-2.jpg (346.5 kB)
avatar image Samantha Sutton ♦♦ STAFF Nov 17 '15 at 07:51 PM

Which version of 4.10 are you on? Is it from Github or the Epic Games Launcher? If it's from GitHub, you may want to rebuild the engine and for HTML5. If it's from the Epic Games Launcher, you may want to try and 'verify' 4.10 and see if that helps any.

Once you've done this, repackage your project and try again. Let me know how it goes.

avatar image AlexFecit Nov 19 '15 at 09:00 AM

I use version 4.10 from Launcher. I have tried verify and packaged my project again - no changes, there is the same errors.It doesnt work anyway. I dont now what am I doing wrong...

avatar image Samantha Sutton ♦♦ STAFF Nov 23 '15 at 06:07 PM

It looks like your WebGL: framebufferTexture2D is at a higher level than 0. The error states that it must be level 0. Please make sure that your mipmap level of the texture images are always set to 0.

avatar image AlexFecit Nov 24 '15 at 06:45 AM

Where can I find this parameter? I couldnt find it.

avatar image Samantha Sutton ♦♦ STAFF Nov 30 '15 at 06:37 PM

Alex,

I spoke with our HTML5 developer and he shed some additional light on the issue that you've been experiencing.

The framebuffer issue looks like it's just missing the texture. Since it looks like you're trying to render an empty scene, there may be an object that got in the scene (that's likely missing a texture) and that is what the "error" output seems to be stating.

Please keep in mind that without seeing your project, it's hard to determine if this is the exact issue, but that's how it seems at this time.

Also, the actual error (the pink box) seems to be crashing on the slate handler - - OnControllerAnalog(). This likely means that there is a HUD object that's trying to access something that isn't currently set properly. We believe that your mouse handler got triggered and caused a crash.

Please reply back with any additional information you can provide, or perhaps a link to your project?

Thanks!

avatar image AlexFecit Dec 04 '15 at 09:18 AM

Samantha, My project is default and has no any special things, but I attached it anyway. https://drive.google.com/file/d/0B86oFjhLbhLMaW5hc0JMU1E0RW8/view?usp=sharing

About your words "mouse handler got triggered" I dont fully undarstand what you means. I have connected graphics tablet, maybe it causes that problem.

avatar image Samantha Sutton ♦♦ STAFF Dec 07 '15 at 05:05 PM

Alex,

I was able to successfully launch your project within Google Chrome and FireFix (including Nightly). I do not have any digital tablets attached to my computer so I'm wondering if that's the issue that you're running into. Have you tried unattaching your drawing tablet and seeing whether or not that was the main culprit to launching a HTML5 project on your computer?

avatar image AlexFecit Dec 10 '15 at 12:57 PM

I have tried unattaching my tablet and it still doesn't work (the same error). Please try to launch my build, maybe I do somthing wrong with packaging process? I make a build direct from UE editor.

My HTML5 build: https://drive.google.com/open?id=0B86oFjhLbhLMZXpYU3NQdmxoUzA

avatar image Samantha Sutton ♦♦ STAFF Dec 10 '15 at 07:23 PM

Your HTML5 project does not run for me. The temporary server is not working correctly either. Could you tell me how you set up your HTML5 project before packaging it?

I have taken the project that you gave me earlier and I have packaged it for HTML5 by going to File > Packaging Project > HTML5. I did not change any of the settings. Could you please tell me if you changed any of the settings within HTML5, did you change how it packages?

avatar image AlexFecit Dec 11 '15 at 09:31 AM

This is my packaging set up. alt text

untitled-2.jpg (392.7 kB)
avatar image Samantha Sutton ♦♦ STAFF Dec 11 '15 at 03:46 PM

Please go to the folder and run the HTML5LaunchHelper.exe. Inside of the server, it tells you a localhost to go to. Please open up FireFox and type in the server address in the address bar. If it doesn't load up then, please try Google Chromium.

avatar image AlexFecit Dec 12 '15 at 10:53 AM

I already have treid all of it many times. Please give me link to your HTML5 build of my project (which you successfully launched on your system), I will try it on my system.

avatar image Samantha Sutton ♦♦ STAFF Dec 14 '15 at 03:02 PM

Double-click on the HTML5LaunchHelper.exe. From there, open up Google Chrome or FireFox and type: http://localhost:8000/ and it will load up your project onto the browser. This will be a local server.

avatar image AlexFecit Dec 14 '15 at 04:06 PM

Samantha, you didn't understand me. I have done all as you told me and got error like I posted erlier. Send me your build (package) which you successfully launched on your system. I will try to launche it.

avatar image Samantha Sutton ♦♦ STAFF Dec 16 '15 at 08:34 PM

Here is a link to the project I have created and packaged: HTML5 Project and Package

avatar image AlexFecit Dec 17 '15 at 06:28 PM

I have tried to launch your html file with HTML5LaunchHelper and Nightly (pic) But I've got only black screen.. buuut it is big progress, there is no errors at least))

alt text

untitled-1.jpg (535.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

It seems that from the screenshot, the memory error noted is probably due to an array going out of bounds. For example, some_data[value] where "value" is bigger than: 2^29 => 512 MB (which is 536870912 seen in the screenshot). It's highly possible that a "negative number" or just a number that's "very big" (like an "addresses") was used here.

Regarding the "error: Assertion failed: Typed arrays 2 must be run on a little-endian system" the following was found:

  • Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.30.0\src\preamble.js

  • Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.30.0\third_party\lzma.js\lzma-decoder.js

  • Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.30.0\third_party\lzma.js\lzma-full.js

  • Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.30.0\tools\crunch-worker.js

Since these are all JS files, these will be running within the browsers. It looks as though you're running on Windows, so we're now assuming that the endianness isn't the actual issue.

Instead, we believe that all of the available RAM has been used. It may be due to the fact that the HEAP was increased to 4GB thus not giving enough RAM to HEAP check.

  • Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.30.0\src\preamble.js -- line 1431

Here are some additional links, if you'd like to learn more about typed array details used within emscripten. And, if you are interested, here are some additional in-depth details on using typed arrays in HTML5.

Thanks!

more ▼

answered Dec 31 '15 at 08:05 PM

avatar image AlexFecit Jan 11 '16 at 12:59 PM

Thank you for your answer, but i don't fully understand what I have to do with these .js files to fix the error?

avatar image Samantha Sutton ♦♦ STAFF Jan 14 '16 at 08:02 PM

We believe that all of the available RAM has been used. It may be due to the fact that the HEAP was increased to 4GB. Try lowering it some and let us know what happens.

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Please download Google Chrome and let me know if it works for you. I just tested a new project on Google Chrome using: http://localhost:8000//TestingHTML5.html and it loaded without any trouble.

This is the new project I tried, just so you'd have it too: https://www.dropbox.com/sh/kaflor871ucio1h/AABqynVCuDDiA7HOaU3r9Su2a?dl=0

Thanks!

more ▼

answered Dec 17 '15 at 07:25 PM

avatar image AlexFecit Dec 17 '15 at 08:25 PM

Yes, it works! It works on Chrome and on Nightly. Why previos projects does not work? What is different?

avatar image Samantha Sutton ♦♦ STAFF Dec 17 '15 at 08:50 PM

I'm thinking it was because it was a blank project and there wasn't a light in it. I'm glad it worked for you. Please let me know if you run into any further complications. :)

avatar image AlexFecit Dec 17 '15 at 09:26 PM

Blank project have a light too. Till now I don't find where is different.

avatar image AlexFecit Dec 18 '15 at 08:18 AM

I'm thinking I have solved the issue! It needs to set up default map in project settings) Ok, at now I have another problem with my original project. I have got this message, how can I implement any of picked up instructions? (I tried on Chrome and Nightly)

alt text

untitled-1.jpg (422.6 kB)
avatar image Samantha Sutton ♦♦ STAFF Dec 18 '15 at 07:45 PM

Alex,

Have you tried changing the memory settings withing Project Settings > HTML5? Also, how large if your project that you're trying to run on HTML5? HTML5 isn't like Windows, it can only handle what WebGL can handle, based on that browser. So if you have a 3 gigabyte project with a lot of memory usage, it either will throw errors, will not run, or it will take a really long time to load.

Let me know, thanks!

avatar image AlexFecit Dec 24 '15 at 09:08 AM

My project build is 50 Mb. Project folder is 90 Mb. I've tried to set mamory to 4096 Mb and it is not working. I got this error: Assertion failed: Typed arrays 2 must be run on a little-endian system

avatar image Samantha Sutton ♦♦ STAFF Dec 29 '15 at 05:47 PM

I am looking into this further, we will respond to you as soon as we can. Thank you! :)

avatar image AlexFecit Dec 30 '15 at 06:55 AM

Thank you, Samantha, for your participation) Maybe this error it is because my project has many components and mach more complex than blank projects.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question