x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Render decal as solid?

I've found a picture of a bullet hole, made an alphamap for it and set Material Domain to "Deferred Decal" and Decal Blend Mode to "DBuffer Translucent Color", as seen on the picture below. alt text

I haven't changed anthing else on the material.

I've dumped a Decal in my scene. But as shown below, the center of the bullethole is transparent. I want this to be solid.

alt text

I've been inside the Project settings and set the 3 settings as shown below and restarted and all.. Still with no luck. What am i missing?

alt text

Product Version: UE 4.9
Tags:
more ▼

asked Nov 11 '15 at 07:33 PM in Rendering

avatar image

Jonas_Molgaard
491 29 25 47

avatar image Jonas_Molgaard Nov 11 '15 at 07:37 PM

Oh and i've also tried to place a Point light without any difference and tried even to uncheck "Allow Static Lighting" in Project settings.

avatar image Jacky Nov 11 '15 at 11:05 PM

The center isn't transparent. It is black because the center is black in the texture you are using for diffuse. You need to fix it in your diffuse texture if you want it to have another color.

avatar image Jonas_Molgaard Nov 12 '15 at 05:51 AM

I just want the center to be black.. Thats the issue. As it is now, it is semi transparent even with a white color in the center for the alpha channel

avatar image Jacky Nov 12 '15 at 11:31 AM

Oh, i see. Plug only the red channel of your opacity texture to opacity an see if it helps.

avatar image Jonas_Molgaard Nov 12 '15 at 04:13 PM

Already tried that, and it makes no difference :( I just tried it again even in 4.10 and still same issue. Really has no one faced this issue and fixed it?!?

avatar image Jacky Nov 12 '15 at 04:40 PM

All i can think of is that your opacity texture isn't completely white. Try multiplying it by 2 and see if it fixes the center. If it does then you'll have to edit the texture and make sure the center is pure white.

avatar image Jonas_Molgaard Nov 14 '15 at 11:16 PM

Still no luck. Does no one know how to work around this?

avatar image Jacky Nov 14 '15 at 11:23 PM

Can you upload your textures for us to see what may be wrong?

avatar image Jonas_Molgaard Nov 14 '15 at 11:40 PM

Jup, here it is.link text

It should work if u dump it in the root of the ContentFolder. Otherwise just wire up the texture and the alpha.

bullethole_mat.zip (464.8 kB)
avatar image Jacky Nov 15 '15 at 12:22 AM

Everything worked just fine for me.

alt text

I noticed something though; are you sure what you are seeing is not roughness difference of those tiles? Set Decal Blend Mode to Translucent, Color, Roughness and then plug a Constant1 to the roughness, value 1. If that still isnt the problem could you try this in a new project and see if it's still transparent in the middle please?

decal1.jpg (58.5 kB)
avatar image Jonas_Molgaard Nov 15 '15 at 10:28 AM

Oh pooh, it helped a bit, but look now... alt text

alt text

avatar image Jonas_Molgaard Nov 15 '15 at 10:32 AM

And here's the material in unrealalt text

Btw, haven't told you how much i appreciate you taking the time to look into this for me Jacky. Thanks a bunch really!

avatar image Jacky Nov 15 '15 at 06:53 PM

No problem! This time it looks like the normals of the default material of the floor is showing up, though i'm not sure why. Set the decal blend mode to Translucent, Color, Roughness, Normal and plug a vector 3 blue color to Normal input and see how it goes.

Btw, you dont need to multiply the opacity map. Just plug the texture's red channel to opacity and it'll be fine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Alright, that actually seemed to fix it. Im posting the material as it is now along with screenshot of it.

Thanks a bunch for the assistance Jacky. If you see any obvious improvements let me know.

Next project is to look into how to animate this ;-P Also if you have good suggestions to how to approach this too, feel free to pitch in, otherwise i'll just start by looking into how to actually animate textures in general. I'll post more when i have something.

Oh and here's the mats + screenshots. alt text alt text

more ▼

answered Nov 15 '15 at 09:02 PM

avatar image

Jonas_Molgaard
491 29 25 47

avatar image Jacky Nov 15 '15 at 09:10 PM

Cool, glad that it is solved. You can actually make a normal map for that texture and use that instead of blue, but that is something you need to do in photoshop or some other normal map generator. As to animation, you dont need to animate this really. It is for bullet impact so you'll just spawn it wherever the bullet hits and that sudden spawn wont be noticable as you cant notice it in real life with naked eyes either. Some dust particles would with bullet impact would be nice though.

avatar image Jonas_Molgaard Nov 18 '15 at 10:11 PM

Hi Jacky and thanks again for helping out with this,

Here's my current results so far. It's wip, but it looks ok i think: https://youtu.be/kVhwSJ7txNs

avatar image Jacky Nov 18 '15 at 10:32 PM

Looks good! Something else you can add is to set a random rotation(on X axis i think) when you spawn the decal so that they dont line up identically every time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question