x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Anim state transitions to wrong state

Alright, so, I've been following this FPS tutorial on the UE4 wiki almost verbatim, skipping only the projectile/weapon parts so far. It works well, however when I do an initial jump my "Idle" anim state transitions directly to the "JumpLoop" state, without even having a link to each other, and completely skips the only link in between them which is "JumpStart". After that one initial jump, whether from "Idle" or "Run", it works fine, however this just looks unappealing as my "JumpLoop" state has a very vigorous animation. It is legitimately the same thing as what they have in the tutorial, you can check here, with only one exception that "JumpStart" is linked to "JumpEnd", however removing this link does not fix the problem.

I've checked the tutorial and my project and have made the states exactly like they have it in the tutorial, and it still doesn't fix it. I've also tried to figure out alternative ways and they don't work either. If anyone's got any idea how to fix this, please share.

Product Version: UE 4.9
Tags:
more ▼

asked Nov 12 '15 at 01:19 AM in Blueprint Scripting

avatar image

ViddyXD
8 2 3 6

avatar image alperenakyuz Nov 12 '15 at 08:24 AM

Would you mind posting a screenshot of the animation blueprint? It maybe that your animation transitions too fast between states that it appears it's skipping states.

avatar image ViddyXD Nov 13 '15 at 03:29 AM

Well, it only skips the state once on the initial jump, then it works properly.

avatar image Grimwolf Dec 01 '15 at 05:39 PM

I'm having exactly the same problem, with multiple animations. The very first time they run after starting the game, they skip both the starting and ending animations and transitions directly from loop to loop (IE; Standing > Jumping > Standing). Any subsequent time the animation runs, it works fine. It happens with literally any animation state I've split into multiple parts; a Loop that transitions from a Start, and/or into an End.

avatar image Grimwolf Dec 04 '15 at 02:03 PM

based on further testing, it seems that any non-looping animation played inside the state machine will just get skipped over the first time it activates. I think it's a problem with the "get animation time remaining" functions used as a transition out of it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I've found a solution. just like I thought, using "get relevant animation time remaining" is broken. If you get the time remaining on the previous animation directly, instead of using "get relevant", the transition works fine. I think the issue is that it will fail to find the "relevant" animation the 1st time it runs, and register as having 0 time remaining immediately. So the transition will just skip the animation.

more ▼

answered Dec 08 '15 at 10:37 PM

avatar image

Grimwolf
157 15 19 27

avatar image ViddyXD Dec 16 '15 at 02:35 AM

Yeah, I figured this out a while back...should've said something about it.

But, as if I thought I could possibly be free from this petty yet irritating kind of issue, now I'm having a problem with JumpLoop when it transitions to JumpEnd, with it doing the same thing where it doesn't transition on the first time. Bleh.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question