x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Perforce SSL not working as of 4.10

Hey all,

First of all want to say 4.10 is fantastic so far!

But...

As the title suggest I seem to be unable to connect to my perforce server through an SSL connection any more. I have tested it on 4.9 and it was working fine however upon upgrading to 4.10 it no longer works. All my details are the exact same between the two versions.

Here are the errors I receive: alt text

If you have any questions feel free to ask and I'll get back to you ASAP.

Cheers,

Kanibel

Product Version: UE 4.10
Tags:
more ▼

asked Nov 12 '15 at 03:16 AM in Bug Reports

avatar image

Kanibel
131 5 15 18

avatar image hyperdr1ve Nov 12 '15 at 05:28 AM

Just upgraded to 4.10 and having the exact same issue.

avatar image hyperdr1ve Nov 12 '15 at 05:58 AM

Mine is an existing 4.9 project. Perforce connects fine in 4.9, doesn't connect at all in 4.10. Tried disabling plugin, restarting, enabling plugin etc.

avatar image hyperdr1ve Nov 12 '15 at 06:08 AM

So I just traced the connection attempt and can confirm via wireshark that UE4 editor isn't even making an attempt to connect to my P4 server. The error seems completely internal with zero packets transmitted to the destination server.

avatar image hyperdr1ve Nov 12 '15 at 07:47 AM

This is easy to reproduce in a clean 4.10 project.

avatar image cancel Nov 12 '15 at 05:30 PM

Same problem here. P4 working fine in all of my 4.9 and earlier projects and other things I use P4 for (command-line client is fine, P4V is fine, etc.) Not sure what has changed in 4.10 that is causing this.

avatar image cancel Nov 12 '15 at 06:07 PM

I'm narrowing down the problem. It seems that something is spuriously reporting or detecting an error in the source control config dialog. However, UE4 editor can still work correctly.As a temporary workaround, you can type the correct info into the UE4 editor's source control config settings, and then without clicking any other buttons, close the UE4 editor. You can then run the UE4 editor again and it will correctly connect to source control the next time it starts. Note that I haven't tested this with an expired ticket (my previous login ticket is still valid). Ignore this, incorrect. Only cosmetically displays as correct, still actually not working.

avatar image hyperdr1ve Nov 12 '15 at 06:24 PM

This kind of works. At least the source-control icon turns green when I start up. But I don't see any source control status icons on assets and trying to refresh status fails and submitting from the engine also fails.

avatar image cancel Nov 12 '15 at 06:29 PM

Oops, you're right, it doesn't completely work. Seems most of the functionality still throws errors. Hmm.

avatar image cancel Nov 12 '15 at 06:32 PM

The P4 source control plugin module doesn't seem to come with debug symbols, so I'll have to build from source to see what's going wrong. It will take me a few hours (I haven't set up 4.10 for a source build yet).

Edit: it does come with the pdb, I'm just not getting some type info in the debugger. Will keep looking, but matthew_clark can probably find what's wrong before I do.

avatar image hyperdr1ve Nov 13 '15 at 11:35 PM

Did you get a chance to step through this in the debugger? I may pull down this weekend and see if I can get anywhere.

avatar image cancel Nov 16 '15 at 07:42 PM

I've attempted to step through it, however I can't get the VS debugger to utilize the symbols correctly for the perforce source control module. I think I need to build from source, and I haven't yet had a chance to set that up. Sorry :(

avatar image hyperdr1ve Nov 16 '15 at 07:47 PM

No worries. I have a deadline for this Friday, after that, if this hasn't been resolved I'll pull down master and hammer on it for a few days.

avatar image hyperdr1ve Nov 12 '15 at 05:46 PM

I just tried updating my P4V client to the latest, no change.

avatar image Matthew J Nov 12 '15 at 06:30 PM

Hello everyone,

Leaving a message here to let you know that I'm looking into this problem. I'll let you all know if I have any questions or have any additional information to provide.

avatar image hyperdr1ve Nov 16 '15 at 07:13 PM

Have you been able to repro this on your end Matthew?

avatar image tabana Nov 17 '15 at 01:22 AM

I think I found something. It seems that someone added a bunch of
#if USE_P4_API ...some code... #endif inside all the functions. The problem is USE_P4_API doesn't seems to be defined anywhere. Meaning, when you compile it, all you have are just empty functions.

avatar image hyperdr1ve Nov 17 '15 at 01:52 AM

I saw that too, but it is hard-coded to true here. This seems to be part of the changes for the VS 2015 support.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello everyone,

It appears that this has already been reported elsewhere and you can find information surrounding that report here: https://answers.unrealengine.com/questions/334975/perforce-ssl-failing-in-410.html

We hope to have this fixed soon, but please be aware that we do acknowledge that SSL is having issues in 4.10.

more ▼

answered Nov 17 '15 at 07:35 PM

avatar image hyperdr1ve Nov 17 '15 at 08:17 PM

Thanks Matthew. Are you guys not using SSL internally? For shame, may as well leave your passwords on a post-it note too ;)

avatar image Leszek Godlewski Feb 08 '16 at 11:26 AM

Hi Matt & hyperdr1ve,

When is this going to be fixed?

avatar image Martinch0 Feb 08 '16 at 12:05 PM

It was already fixed in 4.10.1.

avatar image Leszek Godlewski Feb 08 '16 at 08:46 PM

We are running 4.11 preview 2 with a VS2015 build and the problem persists.

For the record, I've fixed it locally by upgrading both P4API to 15.2 and OpenSSL to 1.0.1r. It seems that P4API 15.1 (the version used for VS2015 builds, see here and here) was broken (probably compiled by Perforce without SSL support, since no SSL symbols are present in the libs). Upgrading P4API took an OpenSSL upgrade in its wake, since the new version was built against 1.0.1r.

avatar image Matthew J Feb 09 '16 at 08:05 PM

Hello Leszek Godlewski,

Are you getting the same errors that Kanibel mentions in his original post? Have you been able to try any of the latest preview versions? I tried reproducing the error on our latest internal build of 4.11 without any issues. I can give Preview 2 a try as well but it's possible that it was fixed in the newest previews if it's not occurring with the latest internal build.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question