x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to move object after placement.

When I'm using unreal engine I can place object in the scene but can't move them. There in the screenshot the highlighted part is what is weird. Also when I select the brush the arrows don't appear?

Can anyone help me there?

alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 22 '14 at 01:41 PM in Using UE4

avatar image

Dayskii
31 1 4 5

avatar image gruschi Mar 05 '15 at 08:24 AM

I have the same problem now. Does anybody have a solution? Couldn't find anything :/

avatar image Steve Hardister ♦♦ STAFF Dec 18 '15 at 03:58 PM

Hi Dayskii,

Please let us know a little more about the issue:

  1. What version of the Engine are you using (Have you tried another version?)

  2. Are you on a Mac or PC?

  3. Please list your system specs

  4. In your World Outliner, is the Map the upper most item (Parent) with all items children of the map as shown:

alt text

  1. What are your Viewport Options? Please post image as shown:

alt text

world.png (40.1 kB)
avatar image Steve Hardister ♦♦ STAFF Dec 22 '15 at 07:01 PM

Hi dayskii,

Since we have not heard back from you in a few days, we are closing this thread for tracking purposes. However, if you are still experiencing an issue with moving objects after placing them, simply respond with the requested information and we will continue to investigate.

Thanks,

Steve H.

avatar image SebNatto Jul 14 '16 at 01:24 PM

I have the exact same problem! This is so annoying!

avatar image Steve Hardister ♦♦ STAFF Jul 14 '16 at 04:17 PM

@ SebNatto,

Please respond with the requested information (or as much as possible) *especially the version of the engine you are using and I'll try to help you resolve this or report it as a bug. -Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I found out what the problem was in my case. "Show Transform Widget" was disabled. I have no idea why, maybe there's a shortcut I accidentally pressed. alt text

You can find it under the Settings tab. The symbols in the toolbar are greyed out and the W E and R keys don't do anything.

Maybe someone can explain any use of that feature to me.

more ▼

answered Jul 18 '16 at 12:05 PM

avatar image

SebNatto
21 1 1

avatar image jazen Sep 06 '16 at 05:06 PM

Thanks so much for that! It was really helpful.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Who ever has this problem should check if they are in play mode. I spent ages trying to figure it out only to realise i was running the game and you cant move anything while playing.

more ▼

answered Apr 24 '18 at 07:55 AM

avatar image

ZEBEDEE STOWERS
16 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I set snipping scale to 5 and the problem is solved. alt text

more ▼

answered Oct 06 '18 at 09:55 AM

avatar image

SimplestWay
34 1 3 7

avatar image Songheee Nov 27 '18 at 06:08 PM

For me this was it! Thank you!

avatar image Colugo Feb 09 '19 at 01:09 AM

Oh thank you that was what solved it for me as well! I forgot I had set it to 1,000 because I was moving huge actors.

avatar image ZECUU May 31 '19 at 12:26 AM

So my transform widget is enabled. My snap is set to 1. I'm not in play mode. I can rotate objects and scale objects. But the only way I can move them is to manually enter their coordinates. I've been having this problem for days now.

avatar image ZECUU May 31 '19 at 12:39 AM

alt text

Here's my problem

help.gif (4.6 MB)
avatar image SimplestWay May 31 '19 at 01:13 AM

hi, ZECUU: try to create another actor or drag another new geometry, if new actor/geometry can move around, check your detail pannel settings: In your detail pannel->Constaints->Lock Position should be false in all three axis. If all of your new geometry/actors can't be moved around, well, I have no idea. sorry about that.

avatar image SimplestWay May 31 '19 at 01:14 AM

I mean check the detail pannel of your locked actor/geometry, no those movable objects.

avatar image ZECUU May 31 '19 at 09:15 PM

It just spawns the object directly inside the current position of the camera regardless of where I drag it to. I cant move it from that position afterwards.

avatar image ZECUU May 31 '19 at 09:24 PM

alt text

help.gif (4.3 MB)
avatar image SimplestWay Jun 01 '19 at 01:16 PM

Hi, ZECUU: In fact, I have no idea right now. But maybe you can check if it was your blueprint logic that caused this problem. As what I have suggested before, create a new actor or just drag a new cube and see if this new actor/cube can be moved around. If yes, show your blueprint logic here, if not, post a new question in answerhub, it's beyond my reach, sorry about that.

avatar image ZECUU Jun 02 '19 at 01:45 AM

Sadly, creating a new cube behaves exactly like the gif I showed. It doesn't move. Still, I appreciate your help.

avatar image Dev_VPiton Jul 08 '19 at 06:17 PM

Hi, ZECUU ! I currently have the exact same problem, and I just can't find any solution. Did you managed to fix it ?

avatar image ZECUU Jul 09 '19 at 09:41 PM

No. Unfortunately, I have not.

avatar image Dev_VPiton Jul 10 '19 at 01:49 PM

Hey man, I found how to resolve the problem in my project ! It was the near clipping plane setting that I set, that broke everything (0.0001 | Not my best move I recon) You should take a look there. If not, I'm sorry for you, this bug is such a drag. Hope this will resolve your problem as well !

avatar image ZECUU yesterday

My near clipping plane as also at 0.0001... sadly, setting in back to 1 didnt fix the problem however. This issue really only started happening when I accidentally hit the build button on the menu. Then I couldn't move anything. I think I'm just going to have to make a new project. Unless there's a way to "unbuild"? Not sure, I'm fairly new to UE.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question