x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm issues after moving 4.8.3 -> 4.9.2

Hello, I read about prior issues with SWARM failing to kickoff and I'm not sure they're applicable to this situation. I can build lighting on all levels except our most important one, which is obviously problematic.

Our project was in 4.8.3 and lighting builds on the level fine. We moved it to 4.9.2 and now swarm fails to kickoff only on the main level. Tried updating to 4.10 today thinking perhaps that would alleviate the issues - but the substance plugin is not compatible with 4.10 yet.

What we've tried: -Deleting and replacing (i.e., ctrl+z) all meshes - read this on a forum somewhere -Saving as new level (file>save as) - didn't make a difference -Export as .t3d and reimport - no dice -Went to backup file in 4.8.3, lighting builds. Converted to 4.9.2 again. Swarm fails to kickoff.

Any ideas on how to fix this or what the issue may be?

In theory we can leave the project in 4.8.3, the issue is that 4.8.3 cannot package a shipping build for Windows 64bit. I've tried the different workarounds for that and haven't had any luck, always receive errors.

Thanks!

Product Version: UE 4.9
Tags:
more ▼

asked Nov 12 '15 at 06:10 PM in Rendering

avatar image

Gone_Fishin
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Gone_Fishin -

Take a look at our Swarm TGroubleshooting guide on the wiki:

https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting#What_does_.22Light_build_failed._Swarm_Agent_failed_to_kick_off.22_mean.2C_and_How_can_I_fix_it.3F

I believe you will find the answer there, if you still are having issues, please post back here.

Thank You

Eric Ketchum

more ▼

answered Nov 12 '15 at 06:39 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 737

avatar image Gone_Fishin Nov 13 '15 at 12:01 AM

Hi Eric, Thanks for your quick response. I checked out the solutions on the link but unfortunately none of those solutions worked.

1) Try restarting Unreal Engine 4 and/or your computer. - have tried both many times, no luck

2) Check Task Bar and/or Task Manager for multiple instances of Swarm Agent running. Close all or more than a single instance. -only one instance present, and only when I try to initiate it

3) Disable Firewall and/or Anti-Virus software. If this works, make sure to add an exception for SwarmAgent.exe - shouldn't be an issue, I can build other maps in same project

4) Test building lighting in known levels with assets that work, like the Default Level from Starter Content or one of the Template maps.- works fine with a different map in the same level

5) Verify the engine by going to the Epic Games Launcher > Library > Select Engine Version > Verify (see image below) - did this, no difference

6) Re-install the engine - uninstalled and reinstalled, still same error, swarm failed to kick off.

Another thing mentioned was HD space, but I checked that as well and there's more than enough space.

Any other ideas?

Thanks again for your help, our team really appreciates it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

OK got it working through one of the most monotonous processes ever - but it gets weirder. Bear with me, I'm going to type this out so when some other poor soul with too many actors in their scene runs into the same problem maybe this will help them.

I read on a different thread that the issue can be due to a corrupt mesh or material. And of course there isn't a easy way (at least that I could find) that you can check that all at once.

First, I created a duplicate project and I did all of this in the duplicate. NO IDEA why this carried over to my actual project file....

  1. Checked all my materials to make sure there were no errors. There weren't, at least that I saw.

  2. Next I started deleting all of my similar meshes in the scene one type of mesh at a time, and then tried building lighting. That let me identify what the problematic mesh type was. For example, first deleted all pillars. Then tried building lighting. Then deleted all doors. Then tried building lighting. Did that for a crazy long time until I found the mesh type that was causing problems.

  3. I had a lot of those meshes, so then I closed the project (didn't save) and opened up all of the one mesh that was a problem. Then i deleted them one by one and tried building lighting again between each.

  4. Closed file without saving.

  5. Once I identified the issue I went back into my primary project file. Out of curiosity, I clicked build lighting and it worked.


Any ideas why messing with a mesh would correct the issue in a completely separate project? It was not cloned, but rather hard copied in Windows explorer.

Have a good evening, and thanks again for the ideas and your quick response.

more ▼

answered Nov 13 '15 at 01:25 AM

avatar image

Gone_Fishin
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question