x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

After importing my animations from Blender to UE4, there is a strange twitching in the feet of one of my animations

I recently imported a few animations from Blender to UE4 to make sure they would work fine in UE4, and for the most part they did. There is one strange issue, though, which makes me nervous to continue animating because I'm not sure how significant it could be in the future.

In my 1 second animation, there's a point in the middle where each of the feet sort of twitch to left a bit. This only happens in the idle animation, and nothing similar happens in any of the other 12 animations I ported over.

For reference, here is what it looks like in Blender: http://gfycat.com/DelectableAffectionateDrake

Here is what it looks like in UE4: http://gfycat.com/AdeptNewBass

The issue goes away (mostly) when I delete the hip bone (the hips sway left and right a bit as my model shifts his weight from front to back), but it's very confusing why the feet only have this problem for such a short period of time. The hips are swaying the entire animation, but this issue only appears briefly in the middle of the animation.

There aren't any keyframes on the feet, other than one foot roll bone which bounces the heel up and down. I've also tried adding keyframes around that point in time to lock in the position, but it does absolutely nothing.

Just...completely confused why the animation wouldn't match up 1 to 1 from Blender to UE4.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 13 '15 at 06:47 PM in Using UE4

avatar image

Winnar
6 1

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

The solution to this problem would be to check "Preserve local transforms" in your animation import options. You can also reimport your animations with those options.

more ▼

answered Apr 01 '18 at 12:53 PM

avatar image

ClearlyUnified
1

(comments are locked)
10|2000 characters needed characters left

I had a similar issue. The animation looked solid in Blender, but feet sometimes shifted slightly in UE4. It was caused by the FBX export. Setting "Simplify" to 0 in the Animation category of the FBX export options solved the problem for me. You could also try changing the "Sampling Rate".

more ▼

answered Feb 25 '19 at 01:35 AM

avatar image

ChronicDev
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question