x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Built lighting turned everything green?

Hello, I just built my lighting and everything either got green painted all over it, or has immense green emissive light that fills the screen. (This is a mid-day snow map, so it is normally all white+blue)

alt text

Any ideas why this happened or how to fix it? Thanks!

Product Version: UE 4.9
Tags:
more ▼

asked Nov 14 '15 at 12:10 AM in Rendering

avatar image

Juice-Tin
152 38 37 45

avatar image Juice-Tin Nov 14 '15 at 06:02 PM

Just turned all the Global illumination off via a post process and that got rid of the immense green light, but now the scene has no GI lol.

Any ideas how to fix the broken GI? Thanks!

avatar image Jacky Nov 14 '15 at 06:13 PM

Delete and recreate reflection capture actors in the level and see if it helps. If not, make sure your GPU driver is updated.

avatar image Juice-Tin Nov 16 '15 at 05:07 PM

Hi Jacky, I have deleted the 2 reflection capture actors in the scene, and I deleted the Skylight (saw that in another post) then I rebuilt the lighting. Nothing has changed. (Yes my gpu is fully up to date)

Here's another view of the scene. I'm setting Global illumination intensity to 0 and 1 through a post process so you can see the problem. Also notice that some objects are oddly painted bright green, even though it's a snow scene with no green textures. So I think there's problems with the GI color map? I just can't figure out how to fix the GI. alt text

Edit: Also, here's a screenshot with the 'Lighting only' viewport. This is the one angle I could get without the light blowing out the screen like above. (Those are a bunch of brown rocks, which for some reason have tons of super emissive green GI sploches on them. alt text

avatar image Logan Bailey ♦♦ STAFF Nov 16 '15 at 06:41 PM

Hello Juice-Tin,

In order to understand this issue better I would like a little more information from you.

  1. Can you link a copy of your DxDiag?

  2. Does this happen in 4.10 or 4.8?

  3. Is this the only project this happens in?

I have seen similar issues to this but the fix to this was making sure the users graphics card was up to date. As you said, you have already done this and this did not fix the issue. After I have this information I will continue to investigate this issue at that time.

Logan

avatar image Juice-Tin Nov 16 '15 at 07:31 PM

Thanks for the response Logan,

  1. http://pastebin.com/4B1ndcFw

  2. This is in 4.9.1

  3. This is the only decently sized project I have, however it happens only in this level. (Edit: It now happens on my other levels as well, though I've built them just fine in the past)

If this may help, here are the last actions that were taken which may have led to this problem.

  1. I designed the main level layout (in unreal 4.9.1, Radeon GPU), and gave the entire project folder to my colleague.

  2. He altered the level and added new assets (in unreal 4.9.2 NVidia GPU).

  3. He then gave me back the level + his modified assets as zipped .uasset files which I placed directly in my unreal content folder.

  4. After a few last modifications of my own, I added a reflection actor and built the lighting, where the result was the above images.

So in short, the level + a few assets were created on AMD Radeon using Unreal 4.9.1, the whole project was sent to an NVidia using Unreal 4.9.2, then sent back via uasset to my Radeon 4.9.1. The lighting built just fine on his machine, but his level now goes green when built on my machine. The original level I created builds just fine, only the version that was sent to his Nvidia then back to me is broken.

Not sure if any of that helps, but hopefully it can be of some use. :)

Also, I'm happy to give out any extra information/screenshots/etc that you may need.

Edit: I rebuilt my original test level and now it too is showing some green Global illumination. This area is just 2 white snow rectangles, the whole scene should be a snowey blue+white yet there is the green GI again. alt text

Edit2: I built my colleague's project as well as some others from the marketplace, all the lighting built just fine. The problem is only with my main project (probably from when I copied some content from the other project to mine) Could you recommend any workaround fixes?

avatar image Logan Bailey ♦♦ STAFF Nov 17 '15 at 06:41 PM

So, you can try deleting your "Intermediate" and "Saved" folders from your Projects directory. This will force the engine to recompile all of your textures/materials/ and ask you to rebuild your lighting.

Make a copy of your project before you do this

This way you have a test to work with.

Let me know if this fixes your issue.

Logan

avatar image Juice-Tin Nov 17 '15 at 07:45 PM

Hey Logan, I deleted Saved and Intermediate, however these did not affect anything. All lighting/materials/etc was still built when the project opened. (Also, I've upgraded the project to 4.10)

Is there perhaps another folder/file I need to delete to force the recompile?

avatar image Logan Bailey ♦♦ STAFF Nov 17 '15 at 08:13 PM

Derived Data Cache. That's the last one I feel comfortable suggesting to delete.

Logan

avatar image Juice-Tin Nov 18 '15 at 04:43 PM

Hey Logan, I deleted that as well as Intermediate and Saved again, both from my project folder and the Unreal Appdata. No changes.

I've found a very temporary solution. By setting all the GI settings to extremely low in the world settings, it fixes the crazy GI and I can see my project again, however the lighting is very poor now and still has oddly colored artifacts.

alt text

I can work with this for now, but will soon need proper lighting. Again, I'm not sure if you're actively trying to figure out this bug or not, but if you are I'm more than willing to help in any way I can!

Thanks.

avatar image Logan Bailey ♦♦ STAFF Nov 18 '15 at 08:35 PM

I see that you figured out something to temporarily allow you to work. Would you be willing to share a test project or this one and I can delve into what may be causing this on my computer? Those steps to force your project to rebuild lighting and textures from scratch was really my only thoughts on how to fix it without looking at how you have certain settings setup.

Logan

avatar image Juice-Tin Nov 18 '15 at 09:00 PM

Hi Logan, thanks so much for your help! The current project is over 30gb, so tomorrow I'll create a much smaller stripped down version that can be transferred more easily. I'll also be trying it on other PC's tomorrow as well.

Thanks again!

avatar image Logan Bailey ♦♦ STAFF Nov 18 '15 at 09:20 PM

Not a problem. You could also check MeepMeep's suggestion and try disabling the plugin before going through all of the hassle of creating a test project.

avatar image Juice-Tin Nov 19 '15 at 06:22 PM

I just sent the project with details to your forum private messaging as I can't post the project publicly.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok, so this deals with the lighting cache and exceeding the cache limits.

There are two ways to fix this.

1) Use completely dynamic lighting, force no precomputed lighting, and turn off static lighting in your project settings.

After restarting the editor, because these steps will require you to, and the editor recompiles then the green light disappears. No worries about the dynamic lighting either as it actually improves the fps of your project by 30-40 fps in some places.

2) Follow this thread down to where Daniel W answers this issue.

https://answers.unrealengine.com/questions/48362/strange-foliage-glow-issue.html

Logan

more ▼

answered Nov 19 '15 at 10:20 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Well There is really nice answers, but what I'm gonna tell you is same situation that I had. I had red colour issue like you after lightmap baking and it was from the substance designer plugin. And I fixed after I delted that plugin involved material's emmissive radius.

more ▼

answered Nov 18 '15 at 08:47 PM

avatar image

MeepMeep
74 2 4 12

avatar image Juice-Tin Nov 18 '15 at 10:45 PM

I'm not using that plugin or any others for that matter. Also happened on a completely fresh install of Unreal without any engine modifications. But good to know if I ever grab that plugin, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question