x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

fooliage looks bad/pixelated with temporal AA

hello everyone

so i have this problem where grass looks VERY BAD with temporal AA some parts of grassblades are with holes/missing (look picture)

anyone knows how to fix this problem?

-new project

-all setting set to epic

-grass is from kite demo (ive changed no setings)

-tried 4.10 /4.9 /4.8

-tried diferent graphic card

-tried diferent OS

here are pictures with AA and without it

alt text alt text

Product Version: UE 4.10
Tags:
more ▼

asked Nov 14 '15 at 03:32 PM in Rendering

avatar image

jakaa
6 2 5 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello jakaa,

This is expected behavior due to the dithering calculations that Temporal AA uses.

So, what happens is the AA method you choose takes a sample from the current scene. Then that sample is calculated and redrawn on the screen a frame behind real time. With dynamic objects this creates a ghosting effect.

TemporalAA requires accurate per-pixel motion vectors. Because you are using WorldPositionOffset (or displacement) to animate, the motion vectors will not be accurate.

What you see is a limitation with AA and such will not be " fixed. " However, the development team is currently looking into options that will reduce how noticeable this effect will be. Thank you for reporting this issue to us. At this time I do not have an ETA for when these improvements will be made.

Logan

more ▼

answered Dec 01 '15 at 08:39 PM

avatar image jakaa Dec 03 '15 at 07:02 PM

finally someone commented on my post! ^.^

i appreciate your comment, sory if i sound unprofessional , but i made some googling on per-pixel motion vectors,

ive enabled accurate velocities from Vertex Deformation under the project settings, so i restarted the project to see the results,

however when i reopen the project it stops loading at 45% even after waiting for over 30 mins

do you by chance have any ideas on how to solve this?

THANKS!

avatar image Logan Bailey ♦♦ STAFF Dec 03 '15 at 07:22 PM

I have a troubleshoot for this :

Please make a copy of your project before doing this troubleshoot.

If you delete your Intermediate, Saved, and Derived Data Cache directories from your project folder does this then load your project?

Logan

avatar image jakaa Dec 03 '15 at 07:53 PM

unfortunately it still stops at 45

also no worries about losing my project, because its new project made for testing

avatar image Logan Bailey ♦♦ STAFF Dec 03 '15 at 08:05 PM

Interesting. So, am I correct in saying that in a blank project without Accurate Velocities from Vertex Deformation enabled you are able to launch the editor? If that is so I will attempt to test this on my end and determine if this is a bug.

Thanks,

Logan

avatar image jakaa Dec 03 '15 at 08:15 PM

correct, new blank project opens normaly , until i check Accurate Velocities

UPDATE!
this one came unexpectedly!

i was just messing around with creating new project end ticking the setting (i did that several times before also, no luck) it was maybe 2-3 minutes into loading and BAM it opend! somehow it got "stuck?" but it loaded till the end somehow..i dunno

im sory if i stole too much of your time with that stupid loading thing..

avatar image Logan Bailey ♦♦ STAFF Dec 03 '15 at 08:46 PM

I was able to enable Accurate Velocities in my project settings. From there I saved and restarted the Project. It took a little longer than I would expect I.E around 2 mins to open but I was able to open my project again. It did hang at precisely 45% until further calculations were made and the project open.

Would you link me a copy of your DxDiag?

These are the spec's on my machine.

OS Windows 7 Professional

Intel(R) Xeon(R) CPU ES-2620 0 @ 2.00 GHz 2.00GHz

32GB Ram

GeForce GTX 770 Version 347.09

Logan

avatar image jakaa Dec 03 '15 at 09:53 PM

oh god...i think im going crazy, yes THANK YOU grass look little bit better although its still a mess , i really don't know whats going on..

if you wish to take a further look of what happening, heres my dxdiag..

link text

dxdiag.txt (87.1 kB)
avatar image Logan Bailey ♦♦ STAFF Dec 03 '15 at 10:27 PM

I think I might see the issue from your DxDiag. You are currently developing with an i3 processor. This processor is equipped with 2 cores. For operating and subsequently developing with our software with recommend using a minimum of a quad core processor.

https://docs.unrealengine.com/latest/INT/GettingStarted/RecommendedSpecifications/

The rest of your spec's seem to do fine but I believe the issue you are having here, after going through the other troubleshoots, lies with your processor.

Logan

avatar image jakaa Dec 04 '15 at 05:14 PM

yeah maybe, but its kinda weird that CPU would do that..

is it maybe because its in editor not standalone game?

because temporalAA works fine in game called the vanishing of Ethan carter

i dunno whats up with AA in engine tho..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question