x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

4.10 memory leak

Editor starts to eat more memory(1-5mb per second) when some BPs opens, mostly AIs one(Behaviour tree, AIController,AICharacter...), other BPs don't cause such a problem. Newly created AIController and AICharacter don't cause this problem either.

So yeah, is there a solution for this?

Windows 8.1 64-bit.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 16 '15 at 10:43 AM in Bug Reports

avatar image

normal_ST
66 5 12 18

avatar image Jamie Dale STAFF Nov 16 '15 at 12:16 PM
avatar image normal_ST Nov 16 '15 at 02:23 PM

Unfortunately no, it's very similar, but this happens even with 1 tabs, and when I close it, the memory still keep "leaking"(1-2mbs every second). And again, not every BP, and I might add, not only AI related BPs as I found out.

Can't imagine what can cause it, it was find a while ago.

avatar image Sean L ♦♦ STAFF Nov 16 '15 at 07:46 PM

Hello,

  • Is the issue occurring only when you leave the tabs open?

  • Are you doing anything to the tabs during this time?

  • How often does this issue occur?

  • Does this issue occur in a clean project with no additional content?

  • Could you provide a screenshot of the task manager while this is occurring?

Thank you.

avatar image normal_ST Nov 19 '15 at 10:05 AM

I made some testing, and it's still hard to answer on all these questions.

  1. No, it's also happens when the main map is open, where all the Bps are, and no BPs tabs are open.

  2. No.

  3. Always, if the main map is loaded, or BPs tabs are open, even on empty map.

  4. No, it not even occur in my main project, if empty map is open on project start.

  5. Don't see a reason for that, at some point it was 3GB+ eating memory on my really small project, which at normal rate eat 800mb-1.2GB at max. And also I watching memory usage at ue4 itself(It can be toggled at performance, if I recall correctly) but at task manager the memory usage for ue4 is almost the same.

Also I wanted to point out, that the memory leaks really slowly, as I said before, 1-3mb per second, and sometimes it stops for a few seconds, and then continues. So it takes about 10-25mins to get 2-3GB memory usage.

I tested my project on other computer, and result was the same.

avatar image normal_ST Nov 20 '15 at 11:37 AM

link text

[1]: /storage/temp/67460-firstpersonexamplemap-windows-20-12.51.47.txt

[2]: /storage/temp/67461-firstpersonexamplemap-windows-20-12.52.55.txt

3 full memreports, all made on first person example map, in my project, 1. memreport just open the map, no memory leak. ~500mb 2. memreport opened a few BP tabs. Loaded to memory. ~900mb 3. memreport waited for a few minutes, have some memory leak, from ~900mb memory usage to ~1.3GB and it's still going. On my map this ticks much faster.

Still can't find a solution to this bug.

avatar image normal_ST Nov 20 '15 at 07:40 PM

So any advice? I have no clue what to do next, I'm stuck, and can't continue to work properly on the project, I would really appreciate some help.

avatar image szyszek Nov 19 '15 at 01:47 PM

I'm experiencing same issue and would like to point out another thing:

when I create a new project (any type) and add camera actor to the scene, editor memory usage jumps up. It's obviously caused by preview viewport of the camera but when I deselect the camera, memory doesnt drop, it stays on the same level for w while and then begins to grow, just like normal_ST described. Although, my editor is eating memory even without any blueprints/ai editor tabs open.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello,

I have entered two separate bug reports, UE-23794 and UE-23795. One relates to constantly increasing memory usage with few or no tabs open, and the other relates to a memory spike that occurs in PIE and never decreases. Thank you for your reports.

Have a great day,

Sean Flint

more ▼

answered Nov 24 '15 at 02:12 PM

avatar image

Sean L ♦♦ STAFF
43.8k 485 152 440

avatar image Sean L ♦♦ STAFF Dec 09 '15 at 02:39 PM

This issue has been fixed internally, and the fix will be available in a later version.

avatar image dx0ne Dec 12 '15 at 03:10 PM

Does it mean later than 4.10.1?

avatar image Sean L ♦♦ STAFF Dec 14 '15 at 02:01 PM

This issue was fixed after 4.10.1 was released, so it was not one of the fixes that was addressed by the 4.10.1 hotfix.

avatar image Heroico May 05 '16 at 02:14 AM

Hi Sean, I am still getting this with 4.10.4, 4.11.2, and 4.12 preview 2

avatar image Sean L ♦♦ STAFF May 05 '16 at 01:16 PM

Could you describe in a bit more detail which issue you are still experiencing?

(comments are locked)
10|2000 characters needed characters left

I found what cause it.

Repro steps:

  1. Any project will do but you can create a new one.

  2. Create a new UMG.

  3. Place a Text(Not TextBox, I did not test it with TextBox)

  4. And change the Text to " "(Not empty, a single space character)

  5. Then Create Blueprint.

  6. Add Widget component to it.

  7. Set widget class to our previously created widget(with " " text).

  8. Place it anywhere in the level, memory leak should start any moment(Usually 10-60 secs).

I hope you will get the same result, it was really annoying bug.

more ▼

answered Dec 09 '15 at 02:33 PM

avatar image

normal_ST
66 5 12 18

avatar image Sean L ♦♦ STAFF Dec 09 '15 at 02:40 PM

Could you please open a new Answerhub topic regarding this issue? The repro steps seem to be different enough from what we were able to reproduce to warrant investigation. Thank you.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question