x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting build failed. Swarm failed to kick off.

Hi, I constantly have problem with swarm agent and building lights on old projects after I backup them. When I want to change something and build lights it fails constantly. Building lights works fine on new projects that haven't been moved. I tried everything that you suggested on forums but no success. What can I do? Don't think that solution is not to backup old project because it is crazy! Please help!

Product Version: UE 4.9
Tags:
more ▼

asked Nov 16 '15 at 04:28 PM in Rendering

avatar image

manja
14 8 8 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello manja -

Can you take a moment to look at the following Wiki Troubleshooting Guide and let us know if these solutions do not work for you.

https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting#What_does_.22Light_build_failed._Swarm_Agent_failed_to_kick_off.22_mean.2C_and_How_can_I_fix_it.3F

Thank You

Eric Ketchum

more ▼

answered Nov 17 '15 at 07:00 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.6k 703 260 737

avatar image manja Nov 18 '15 at 02:16 PM

Hi Eric, Thanks for the answer but nothing works except to copy everything in new level object by object.. I was hoping for a solution for the future because I cannot go through this every time I move project to another machine or server.. Is there any way I can store my projects or archive them in order not to experience this again? Thanks, Manja

avatar image Tim Hobson ♦♦ STAFF Nov 18 '15 at 03:17 PM

Hi Manja,

Is this something that is reproducible for you in a new project? I've personally moved projects between multiple machines without this issue.

When moving to other machines what steps have you taken to make sure that Swarm can kick off and build lighting?

  • Did you disable the Firewall and Anti Virus/Malware software?

  • Do these other machines have UE4 installed, and can you create projects on them and build lighting without issue?

  • If you're using 4.9, does this still happen with 4.10, or have you tested in 4.10?

Thank you!

Tim

avatar image manja Nov 19 '15 at 01:58 PM

Hi Tim, I am using 4.9. I moved whole project to the backup server where I am only storing projects and resources. I don't have UE4 installed there, because it is just storage. So when I move project back to my computer where I work and build my projects I get message that swarm agent failed to kick off. I seams that it corrupts my projects after I move them..

avatar image Tim Hobson ♦♦ STAFF Nov 19 '15 at 07:04 PM

At the moment I'm not able to see the same thing on my end. I've copied a project to a computer that doesn't have UE4 installed and back without any issue.

Is this only with your project or any project that you create? If it's happening with any project, can you make a simple blank project with no starter content and upload here. I'll try to build lighting and see if I'm seeing the same issue, although I doubt I will see anything it's worth a check to see.

Some additional things to try that may or may not help:

  • Delete/backup in another folder location your Intermediate and saved folder from your project folders location.

  • Re-install UE4 and/or use the Verify option in the dropdown for the engine already installed from your library tab in the launcher.

Let me know.

avatar image manja Nov 24 '15 at 10:43 AM

Sorry I'm late with the answer.. I tried to move blank project and I didn't had the problem with building, but with every other I do.. It corrupts them for some reason.. I tried to reinstall UE4, tried to move on the other location and it is the same. Only thing that works after that is to make new level and to copy everything in it..

avatar image Tim Hobson ♦♦ STAFF Nov 24 '15 at 02:33 PM

If you open Swarm Agent is there anything that is printed in the Log tab that would indicate here that Swarm Failed to kick off? If so can you screenshot the log or copy the text that is there and attach here.

At the moment I'm out of ideas as to why this would happen when you copy a project to another computer and back. I've not had that happen in my experience yet with any version of the engine.

Would you also be willing to post a link to a simple blank project with a couple of assets placed (cubes, spheres, etc) that is after you have copied it and it gives the swarm failed issue. I can see if I get the same with that project and maybe try and diagnose from there. Beyond that I'm not sure I can reproduce locally the issue you're seeing.

Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In my case, simply rebuild UnrealLightmass project, and this problem resolved. Hope helpful

more ▼

answered Apr 18 '16 at 07:31 AM

avatar image

RayStones
11 1 2

avatar image Dinosaurum Games Apr 27 '16 at 05:04 PM

This solved my problem too. Thanks.

avatar image dmcclccam Jul 16 '16 at 05:43 PM

solved my problem also, tks!

avatar image eleika Jan 30 '18 at 03:20 PM

Em.. And how do I do that ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question