x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.10 Foliage Disappearance Bug

UE 4.10 Landscape learning tutorial map unmodified. Download, start in standalone or new window, and fly toward trees. Trees will vanish based on camera angle regardless of distance. You can crash into invisible trees as seen in video. Even removing the other LODs and auto LOD generation doesn't seem to resolve it. Works perfect in 4.9. Convert the 4.9 version of this project to a 4.10 and problem reappears there too.

GeForce GTX 980 Ti I7-4790k 32gb Ram Driver 358.91 Win 8.1

BugVideo

Product Version: UE 4.10
Tags:
more ▼

asked Nov 16 '15 at 09:06 PM in Bug Reports

avatar image

ELorenzen
3 1 2 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi ELorenzen,

I'm not sure exactly what is causing the issue in 4.10 after looking at it for a bit, but looking at the project in the build that will become 4.11 when it's released does not have this issue.

As it stands this looks to be resolved in that build and I don't see any JIRAs that were entered that reported the issue.

Thank you for taking the time to submit the question and look for this to be fixed in that future release.

Tim

more ▼

answered Nov 17 '15 at 09:47 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 98 874

avatar image DylanBrady Nov 18 '15 at 10:04 AM

I'm facing this bug also but I've found you can fix it for the most part pretty easy if you need to in your project. At least the following worked for me, don't know if it will for you.

Add the following under the BeginPlay for your character (or really, for just about any actor) alt text

It seems as though once one is removed (possibly under other conditions?) it updates the rest of them and then the foliage is back to normal.

avatar image ELorenzen Nov 18 '15 at 02:06 PM

Thanks, I'll give this a try and see if that fixes it.

avatar image MattCan36 Nov 30 '15 at 04:05 AM

I tried plugging a different mesh into the slot of whatever foliage was missing, save the map, re-open the map and re-apply the static mesh to that foliage layer that used to be there and it started displaying again.

So

replace disappeared foliage layer w/ any mesh -> save map -> reopen map -> apply intended mesh back in that foliage slot.

avatar image Omnisis Feb 20 '16 at 11:31 PM

DylanBrady's solution worked for me... but WHY does it work.... and why is it needed?

avatar image AndrewHurley Feb 23 '16 at 04:23 PM

As Tim Hobson stated in his initial post, this has been resolved in the preview release, so expect this fix to be integrated when the full release hits the public.

Thanks,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question