x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Import Mesh with LODs gives "Import Failed" error

I'm having trouble with importing a mesh with lods from Maya 2016. I'm tried using both FBX 2015 and FBX 2016 when exporting. I only have 3 lods in my mesh (Base, and 3 lod under it). When I import the mesh into Unreal Engine 4.9 or 4.10, it just says 'import failed', nothing else, it doesn't give me a clue of what's wrong with my mesh. Also I tried deleting the last lod of the mesh to see if it was a issue with having too many lods. It still gave me a error. I also tried importing by check off 'generate lightmap', that didn't solve the issue either. Same goes for checking off 'combine meshes' as well.

I'm willing to share my asset for a day or two, then I will remove it from dropbox:

Asset w/ LOD Download Link

Product Version: UE 4.10
Tags:
more ▼

asked Nov 17 '15 at 12:04 AM in Bug Reports

avatar image

Oblivion2500
143 16 26 129

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Oblivion,

FBX 2015 and 2016 are not yet supported. You will need to select FBX 2014 or lower in order to import objects into UE4 without issue.

Give that a shot and let me know.

Tim

more ▼

answered Nov 17 '15 at 06:45 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Oblivion2500 Nov 17 '15 at 08:34 PM

This didn't solve my issue. I have Maya 2016, it only exports as 2014/2015 or 2016. FBX 2014/2015 works fine for me on any other meshes. It's just this mesh that's not working for me.

avatar image Tim Hobson ♦♦ STAFF Nov 17 '15 at 09:41 PM

Can you upload the asset exported as FBX 2014 and the Maya file?

If I try to import the file into UE4 it crashes the editor straight out. No messages about "Failed to Import". And if I try to import the FBX into 3Ds Max I get the import window, but no geometry. Something is not exactly right with this asset for some reason, but I'm happy to have a look, pending I can get anything that I can open to see.

Thanks!

avatar image Oblivion2500 Nov 18 '15 at 01:08 AM

I have updated the link above. I exported it as 2014/2015 from Maya 2016 FBX Exporter. I have tested in 3ds Max, it seems to work but missing the LODs and textures. Still gives me "import failed' dialog in UE 4.9 and 4.10.

avatar image Tim Hobson ♦♦ STAFF Nov 18 '15 at 07:13 PM

Testing the updated asset you've linked above with 4.9.2 and 4.10 import for me on my end without LODs,

I'm not sure what exactly, but something has not been setup correctly with this mesh and LODs. In Max I can see the LODs and edit them along with export, but I cannot re-export from Max without getting the failed to import issue. And creating a new asset in Max doesn't give me the error.

Likely, something with the way the asset is being created is the issue, we just need to narrow down what that is.

Can you detail your steps here for creating the LOD and as a test can you setup a simple LOD with the base a cube, LOD1 as a sphere, and LOD2 as a cylinder. When you export make sure that it's as FBX 2014 and that Animation checkbox is checked as well.

avatar image Oblivion2500 Nov 18 '15 at 09:23 PM

I created a sphere, a cylinder, plane, and a cube in Maya. Then I select them in that order one by one, and went to edit > Level of Detail > Group. Then I exported it as a FBX 2014/2015 (there's no 2014 or 2015, only "2014/2015" inside of Maya 2016). When I imported it to UE4, it was a success but the mesh was missing.... I also tested it by importing it to 3ds Max 2016 and it only gave me the meshes but without the lods.

avatar image Tim Hobson ♦♦ STAFF Nov 18 '15 at 11:03 PM

Using these steps I'll have the two other people in our room that has Maya and Max 2016 give this a shot and see if something is not quite right.

I'll let you know what I find.

avatar image Oblivion2500 Nov 21 '15 at 06:26 PM

Any luck figuring out the issue at your end? I just imported it without the LODs for the meantime since it's only about 500 triangles avg. and doesn't really affect performance, but it would be ideal to have LODs included to squeeze out optimal performance.

avatar image Tim Hobson ♦♦ STAFF Dec 04 '15 at 03:54 PM

Apologies for the delay.

We just tested this with 4.10 and Maya 2016 using your repro steps without any issue at all.

I'm attaching the Maya 2016 file along with the FBX for your testing purposes

Let me know if this works for you. Beyond that I'm not sure off-hand what may be causing it to fail on import or have a missing mesh.

lodgrouptest.zip (27.5 kB)
avatar image Oblivion2500 Dec 05 '15 at 06:47 PM

Thanks. It does work for me. I don't know if it's just the mesh themselves causing the problem. It just worked now.

avatar image kidsmurf2000 Apr 11 '16 at 10:19 PM

Hi,

I'm getting the same issue with 4.11.1. Understood this is probably an issue with the meshes, but come better debug output would help a lot. "ImportFailed" doesn't give us a lot to go on.

Would it be possible to add more output?

avatar image Tim Hobson ♦♦ STAFF Apr 12 '16 at 01:24 PM

@kidsmurf2000

Try looking at the Output Log. Typically there should be an indication there for the reason. This may not cover every error out there and some may be vague than others, but regardless the output log should have a better indication than just the error window.

avatar image kidsmurf2000 Apr 12 '16 at 08:38 PM

0 Hi Tim,

Yeah I looked there but there's not much info. Just

Failed To import . Failed to create asset .

It looks like the problem with this specific asset was that it had 4 LODs, switching to 3 LODs makes it work ok. Feedback about that kind of error would be awesome.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question