x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Compiling Shaders crash on loading project

Background: The project was created in 4.9.2 then updated through all of the 4.10 preview versions and still worked normally.

Issue: I've now updated to 4.10 release, and when trying to opening the project, it crashes just about when it finishes compiling shaders.

The crash information is as follows:

Access violation - code c0000005 (first/second chance not available)

""

UE4Editor_Renderer!FDeferredShadingSceneRenderer::RenderLights() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\renderer\private\lightrendering.cpp:526]
UE4Editor_Renderer!FDeferredShadingSceneRenderer::Render() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\renderer\private\deferredshadingrenderer.cpp:1145]
UE4Editor_Renderer!RenderViewFamily_RenderThread() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\renderer\private\scenerendering.cpp:1582]
UE4Editor_Renderer!TGraphTask<`FRendererModule::BeginRenderingViewFamily'::`20'::EURCMacro_FDrawSceneCommand>::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\async\taskgraphinterfaces.h:779]
UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\async\taskgraph.cpp:539]
UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\async\taskgraph.cpp:340]
UE4Editor_RenderCore!RenderingThreadMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\rendercore\private\renderingthread.cpp:310]
UE4Editor_RenderCore!FRenderingThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\rendercore\private\renderingthread.cpp:411]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

I've tested creating a blank new project in 4.10 and that opens up just fine. Checking the .dmp file gives the following information:

Process Name: UE4Editor.exe C:\Program Files\Epic Games\4.10\Engine\Binaries\Win64\UE4Editor.exe
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

Any help would be greatly appreciated.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 17 '15 at 02:48 PM in Bug Reports

avatar image

Roteleks
26 2 2

avatar image Lovecraft_K ♦♦ STAFF Nov 17 '15 at 03:51 PM

Hi Roteleks -

Can you please ensure that when the Crash Reporter comes up on a crash you are submitting the report? When submitted, please post your Machine ID here. Also if you could post a copy of your project logs from the crash and a copy of your DXDIAG?

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Eric,

Thank for your quick reply. I actually found that this was more of a GIT issue with the GIT server I was using than anything related to the Engine. Apparently my last sync left out some of the game files. It just so happened that I updated to UE 4.10 while grabbing some files from the GIT repository and apparently caused some file corruption.

I deleted the project and re-synced it and everything is working great now.

As a reference, the MacineID is: 3DE040554AFC10A910CE849AB454E562 so you can close out the bug reports if you need to.

Thank you again!

more ▼

answered Nov 18 '15 at 03:32 AM

avatar image

Roteleks
26 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question