x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Fbx import results different (broken) in 4.10 vs 4.9.2

So im currently working on this little project game to learn all this and started with 4.9.2 very recently. I have my own rigs that I wanted to get into the engine, they have plenty of extra joints to improve deformation quality. That bit was pretty easy and the engine took my heavy rigs quite well. So on friday I bought this big movement animation package from the marketplace and retargeted it to my maya rig for re-export back onto my own skeleton (It needs to go through maya for all the auxiliary joints) All of that worked perfectly fine, I only did a quick automated batch retarget so most of the animations need some proper polishing by a real animator, but it worked for my purposes, everything went fine into UE4 and I was happy working on some character motion controller and all that fun... BUT NOW! ..

A few days ago I switched to 4.10 and kept working on that... today I decided to edit my current jump loop animation as I was using the one from the UE4 3rd person project which didnt match my other animations. So I go to maya to grab one of the jump starts from the pack as a starting point .. do my thing and set some keys .. retarget and export the rig like I always do (wrote some python utilities to automate that) and try bringing that fbx back into UE 4.10. BUT! Once inside the animation was barely there, some twisted joints and a skewed bind pose and some wiggle.. thats all I got. Also the import took quite a bit longer than I was used to from 4.9.2. It displayed some secondary progress bar saying "importing animation track for [bone N etc.etc.]" And took about 25 seconds to import. Heres where it gets crazy:

I thought it was some setting I forgot in my fbx export parameters in maya so I tried some different things. Apparently the first time I exported with the 2016 signature of fbx, surprisingly that did import into UE without crashing it, but the animation was nevertheless, broken. So I tried it in 4.9.2 with the same file and surprise surprise, it imported perfectly fine and displayed correctly and the import was almost instantaneously. Then I went a little further and exported it back from UE 4.9.2 to fbx and imported that new export to UE 4.10. and now that one displayed correctly too. Means that I have a workaround for now but its quite a strange thing so I wanted to report that here.

In case you want it to help you debug: Thats a folder with both the original maya exported fbx and the fbx that I got from importing the maya one into 4.9.2 and then back out and then to 4.10.

[removed file]

Heres some images showing the difference between the correct and the broken results:

[removed images]

Product Version: UE 4.10
Tags:
more ▼

asked Nov 17 '15 at 08:29 PM in Bug Reports

avatar image

Adeptus
31 1 7 9

avatar image Steve Hardister ♦♦ STAFF Nov 19 '15 at 09:11 PM

Hi Adeptus,

I am getting a 404 error when I click any of your links. Please check to make sure these are still active. If they are, let me know, it may be an issue on our end.

Thanks,

Steve H.

avatar image Adeptus Nov 19 '15 at 09:16 PM

uhhh sorry about that, copied this message from my forum post and forgot to update links. here you go:

[removed file]

avatar image Steve Hardister ♦♦ STAFF Nov 20 '15 at 08:36 PM

In order to import animations with joints only, there must be a skinned skeletal mesh already present in the Engine. Please send an FBX of the skinned skeletal mesh in order to examine this further. (Note: Maya 2016 is not officially supported and, if that is what you are generating your fbx files from, that may be the reason I only saw the skeletal data since we are currently only up to Maya 2015 here.)

avatar image Adeptus Nov 24 '15 at 02:49 AM

Any luck here? This is acutally spiralling a bit out of control for me. I just discovered that UE4 doesnt export the skeleton animation fbx files with scale, even if they had scale originally. This is a major bug guys, it needs to be solved please. Its forcing me to downgrade my projects back to 4.9

Heres what happens: When I make a skeleton animation in maya and have scale channels animated, uniformly or non uniformly doesnt matter, UE4 supports non uniform too. Then import that to UE 4.9.2 it all works fine. If I import to UE 4.10 obviously Im getting the above mentioned so I cant directly import. But If I want to use my workaround and import to 4.9.2 and then export back out. 4.9.2 doesnt export any scale channels. This is plain wrong as according to your docs the engine should fully support that. That also means to export scale channels back out to fbx!

[removed file]

Im really wondering why this hasnt been brought up by any serious developers yet..

avatar image teak421 Nov 20 '15 at 08:40 PM

Steve... Even though Maya 2016 has the Export to Unreal option, its still not officially support by Epic? Is that coming soon?

avatar image Steve Hardister ♦♦ STAFF Nov 20 '15 at 08:45 PM

Not "officially," but I'm not sure that being exported from 2016 is the issue here. If [Adeptus] can send me a skinned version of [his] character that I can open in 2015, I'll be happy to continue to look into this issue. (An FBX should be fine, but I didn't know if the two samples you sent were skinned since all I saw were animated joints and no geometry.) [Edited]

-Thanks

avatar image Adeptus Nov 20 '15 at 09:19 PM

I highly doubt m 2016 is the issue too because i have been using it ever since and all has been fine. No the two samples form the .zip were just animated skeleton.s here is a .fbx with the skinned model [removed file] so you can test it out.

-S

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Adeptus,

Thank you for providing all requested files. I was able to reproduce the FBX import issue as you described for UE 4.10 and entered the corresponding bug report: JIRA [UE-23819]. When this issue has been addressed we will update this post in order to notify you and the Answerhub community.

Again, thanks for your contribution towards improving UE4.

Steve H.

more ▼

answered Nov 24 '15 at 09:29 PM

avatar image Adeptus Nov 24 '15 at 09:49 PM

thats excellent news Steve! thanks a lot, Ill take the files offline now as they arent meant to be public. Let me know if you need anything else.

-S

avatar image sparrish Jan 12 '16 at 07:28 PM

Any update on this from Epic? I ran into this issue on a project as we moved from 4.9.2 to 4.10.1. We saw that code changes in the importer are minimal so re-compiled the editor moving back from the FBX 2016.1.1 library to FBX 2014.2.1 and that solved the problem. We have not yet tried the newer version of FBX 2016.1.2.

We were able to repro missing or incorrect rotations on simple animated assets exported to animation FBX files using FBX file format version 2014 and 2016 from both Maya 2015 and 2016.

avatar image Steve Hardister ♦♦ STAFF Jan 12 '16 at 07:44 PM

This has not been reported fixed as of yet but has not been forgotten.

avatar image sparrish Jan 13 '16 at 01:17 AM

Great thanks!

avatar image sparrish Mar 22 '16 at 08:14 PM

Any update on this? It appears fixed in 4.11 preview 8 at a glance, but I haven't seen mention of UE-23819 in release notes for 4.11 previews.

avatar image Steve Hardister ♦♦ STAFF Mar 22 '16 at 09:13 PM

I've re-tested this per the repro steps and assets provided to submit the bug report JIRA [UE-23819] in UE4.11p8 and the issue persists. However, this has not officially been marked resolved. Once it has, we will update this post.

avatar image Steve Hardister ♦♦ STAFF Mar 25 '16 at 02:54 PM

This has been has been resolved and tested using repro steps and assets used when submitting bug report JIRA [UE-23819]. Look for this fix listed in the release notes for the official UE4.11 Release.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question