x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug?] Blueprint continues to run when Paused in editor and using server/client networking

Came across an odd bug, or at least I think it's a bug. I'm not sure because I'm pretty new to networking as a whole. Anyway, the gist of it is that my game seems to continue to run even though the PIE editor is paused, and I'm not sure why.

So what I have is essentially a minigame that is played by multiple players. The server spawns the room, the room detects if players have entered the room, and once they have, it runs a timeline where tiles in the room are randomly chosen to shake, then fall. Once one player is left, the room finishes, rewards the players, and opens the door. This usually works perfectly in my previous tests, but as you can see in the gif I linked in the imgur link here (http://imgur.com/SlSQ3ld), the tiles aren't falling, and most importantly, the blueprint is running when the editor is paused. Let me know if you'd like to see the blueprint. It's a bit messy and large, but the explanation above is more or less the shortened version of what happens.

I noticed that this bug has happened one other time for a different minigame room with the same MO. The room works perfectly in other situations when placed directly into the level, but when spawned from a blueprint, and when there are two players, the blueprint will refuse to pause when the editor is paused, as well as refusing to work correctly. I have since made a work-around and changed the first room that this bug has happened to, so I'm unable to replicate the bug. I've also attempted to reinstall UE4, hoping that it was just a one-time problem, but it seems that this was just wishful thinking.

Any clues as to how to fix this problem?

Product Version: UE 4.9
Tags:
more ▼

asked Nov 18 '15 at 02:22 AM in Bug Reports

avatar image

thecomediclife
21 4 8 12

avatar image Ben Halliday STAFF Nov 18 '15 at 10:38 PM

Hey,

I'm not sure I understand, so let me ask for a bit of clarification. It looks like you're pausing the simulation, not pausing in game. And when you do, part of the tile blueprint runs (the shaking part), but not the falling part. This only happens when playing with 2 players in PIE, and only when the blueprint is spawned during PIE rather than placed in the level prior to PIE. The expectation is that pausing PIE will result in none of the blueprint running.

Is all that correct? Please let me know if I got any of it wrong.

My guess is that the timeline has already started when the simulation is paused, and the falling part is outside of the timeline. Is that correct? So the problem might be that the timeline isn't stopping.

It would be very helpful to see the blueprint, if you don't mind. Does it have any dependencies, or can i just drop it in a project to test it? If it's easier to show me in the project with which the problem occurs, you can upload that somewhere and send me a link via forums PM.

I'm also not clear: you managed to create a workaround for the one room, and so you can't reproduce the issue in that room. But you can in others? Is it consistent, and happens every time? If not, how frequently does this occur?

If you can provide any more specific details as to your workaround or the functionality of the blueprint in question, and the circumstance in which this occurs, please let me know. Thanks!

avatar image thecomediclife Nov 18 '15 at 11:22 PM

Yes, I'm pausing the simulation, and I'm expecting the timeline to pause with the simulation, which it usually does if I recall correctly. The shaking part is in fact part of the timeline, but the dropping part is a function in the tile's child actor's blueprint, which is called in the timeline. And yes, this only happens when playing with 2 players in PIE. In another level, I placed the room directly into the scene and it worked fine, but when spawned into the scene using my procedural generation blueprint, this behavior happens. The expectation is that pausing PIE will result in the timeline pausing, so that I can check what is working correctly and what isn't. I believe it might not just be the timeline that continues to play, because even nodes that are placed after the timeline's "Completed" line/node/connection/thing are playing while the simulation is paused as well.

Are timeline's supposed to run when I pause the simulation?

I can send you a .rar of my project via PM over google drive, could you show me where I can send you that privately?

And yes, I created a workaround for one room, but haven't thoroughly tested if it still works, or if the bug is even fixed thoroughly. I thought I had fixed it, but I just realized that I've been testing it without using my procedural generation to spawn the room, so I'm not sure if It's actually working. This has only happened twice to me, the two times I've mentioned this. Both use timelines that run the events that happen in the room. In this room, what happens is a timeline changes the material of a monster from black to red, like a ticking bomb. After the timeline ends, the monster explodes. When the simulation is paused, the timeline continues to run, changing the material of the monster, and eventually finishing and exploding him.

avatar image Ben Halliday STAFF Nov 18 '15 at 11:35 PM

No, timelines are not meant to run while simulation is paused, just wanted to be sure I'm understanding you correctly.

You can send me the download link here:

https://forums.unrealengine.com/member.php?32-Ben-Halliday

In your message, please include steps to reproduce in the project, including which map to open and any other incidental requirements that you can think of. If you can provide the name of the BP to focus on, that would also be helpful. Since this is only an occasional bug, I may not be able to reproduce it, but I'll at least see if I can spot anything that would cause this. Thanks!

avatar image thecomediclife Nov 19 '15 at 01:30 AM

Okay, I sent you the message in the UE4 forums. Let me know if you recieved it. I don't check the UE4 forums often, but I'll check when I can.

avatar image Ben Halliday STAFF Nov 23 '15 at 07:19 PM

Hey, sorry, forgot to mention that I did get the project, and I can see what you're describing. I'll be investigating further to see if I can find the cause and entering a bug report once I do. I'll keep you updated here.

avatar image thecomediclife Nov 18 '15 at 11:22 PM

Um... one other bug that has happened to me recently that I have been unable to reproduce that might be of help. When working on the blueprint class of one of my game rooms, for some odd reason, the blueprint was running, despite never having pressed play on the PIE editor. Namely, nothing was moving, but my Print String nodes were all playing in the correct order, then after some time, I would see my Spawn Actors spawn coins (a reward system I have for finishing a game room). The coins would simply be in the blueprint class viewport, but wouldn't show up in the list of objects in the blueprint class, nor could they be clicked. After I had this bug, I closed UE4 and restarted it, and haven't seen this bug again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey thecomediclife,

Thanks for the project! I was able to reproduce this in a much smaller project, and it appears it's as simple as timelines not pausing properly during PIE if there is more than 1 player. I've created a bug report for the issue (UE-23781), and I'll post here if I see an update.

I believe the problem you're having with the blocks not dropping is unrelated, and I would recommend creating a new post for that in the Blueprint Scripting section as I do not believe it's a bug but a workflow issue. If you PM me with a link to the new post you create, I'll see if I can spare some time to look into it further.

Thanks again!

more ▼

answered Nov 23 '15 at 09:03 PM

avatar image thecomediclife Nov 23 '15 at 09:07 PM

Thanks for the help Ben, much appreciated. No worries on the blocks not falling, it just so happened that I was trying to fix up the blocks when I noticed the bug, so I was unsure if it had any relation whatsoever. In the meantime, I found out why my blocks weren't following, which was indeed due to something I did wrong in my blueprint rather than a bug with Unreal, so that's fixed.

Thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question