x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.10 freezing when I click play or compile

Running 4.10 on OS X El Capitan.

I have a C++ project I made in 4.9.2 that is linked up with git. It was working fine the couple times I messed with it before 4.10 came out. Me, enjoying being on the bleeding edge of things, installed it right away side by side with 4.9.2, upgraded the project, and pushed the changes to the repo. I've been adding a few classes (one inheriting from actor, one from character, and one is an interface class) and working on a few levels until recently its started freezing for no explicable reason when hitting any form of play or when I try to compile, either from Xcode or from the editor.

The program becomes completely unresponsive, and I have to go to Activity Monitor to force quit the instance. I have tried 1) creating new projects, C++ and blueprint based. All new projects have this same problem. 2) Removing 4.9.2 and 4.10.0 and reinstalling 4.10.0 and it still does not work. There seems to be no rhyme or reason to this issue.

I had this same problem yesterday, and then around 2 hours later it was fine again. Compiled several times without issue. Now today it is back. I'm unsure what to do or what is causing this.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 19 '15 at 03:04 AM in Bug Reports

avatar image

Nyl0cke
1 1 3 3

avatar image Nyl0cke Nov 19 '15 at 03:25 AM

Update. I suspended my computer (closed the lid) on may way home and now it works. I was thinking somehow it might be tied to it going to sleep for an extended period of time somehow. I'm unsure though. If anyone has insight into this beyond "close the program before you put your computer to sleep" (Because from now on I will be trying this) It would be appreciated.

avatar image Nyl0cke Dec 14 '15 at 06:58 PM

Same problem is back. Right before updating as I mention below, I tried on an older version of the code with 4.10 and it was acting up then too.

I have the whole thing working on 2 separate windows installations, one in 8.1 and one in 7. No compiler errors or warnings at all. I updated to the latest version and (4.10.1) and pulled the changes on Git on OSX. I tried to open the editor and compile (since there were a lot of C++ code changes) and it kept on freezing.

I then just opened the workspace in Xcode and tried to compile there, but got some error about PCH files being from a different branch, so I cleaned the project and tried again. From there it said that it was missing some dylibs that should be in the UE4Editor app package. I went to the directory (or at least tired to) to find the UE4Editor.app package was missing.

I then went to the epic launcher, went to the library, verified my installation, and tried to play in editor, only to get another freeze. I then verified again to be safe, opened up Xcode, compiled there, it succeeded, and then I opened the project again.

I know for sure the changes from the compile were made because I could click on some pickups I made and they now had static mesh variables, etc. I then tried to play in editor once more and it froze. Every time it has froze the close, minimize, and maximize buttons still show the x - and square when I hover over them, and the minimize button works (maximize causes it to completely freeze with the beach ball and everything and the x does nothing). I then have to go to activity monitor, find the editor and force quit it.

I took a look at the logs when I press play and found this:

[2015.12.14-18.33.37:711][846]LogAIModule: Creating AISystem for world TestMapMike [2015.12.14-18.33.37:711][846]LogPlayLevel: PIE: W

The log cuts off. This is a pattern with all of the freeze logs, they all cut off somewhere on the last line.

avatar image Nyl0cke Dec 14 '15 at 07:00 PM

Also, putting my computer to sleep for 15 minutes or more doesn't fix it anymore. It was freezing on a fresh startup from windows.

avatar image Steve Hardister ♦♦ STAFF Dec 15 '15 at 06:51 PM

Hi Nyl0cke,

To clarify, is the engine freezing when you are opening the editor from the Launcher or when you are Playing in Editor which refers to having your project successfully open in the Editor already, then testing by "playing" in the editor like this:

alt text

Do you have a back up of the original 4.9 project that you can open in UE 4.9 on the Mac?

Also, please attach a copy of the corresponding crash log.

Please provide this information and we will continue to investigate.

Thanks,

Steve H.

pie.png (85.6 kB)
avatar image Nyl0cke Dec 16 '15 at 01:00 AM

I have 2 PIE logs and 1 Compile log (each labeled as such) that all resulted in an editor freeze.

I do have the ability to go back to a 4.9 version since I've had the project on Git since then. Is there something you would like me to do with the old version of the project?

The editor does not freeze when I open it from the Epic launcher. It does freeze when I either click the play button or the compile button (since it is a C++ project). It also freezes when I do simulate, so I'm assuming the other PIE options would cause a freeze as well. Things like rebuilding lighting, saving, and using the source control menu from the top bar do not cause an editor freeze.

avatar image Steve Hardister ♦♦ STAFF Dec 16 '15 at 04:32 PM

Thank you for the clarification regarding when freezes occur. Regarding the original 4.9 version, please verify that freezing currently does not occur with that version of the project when opened in 4.9.2 and that it does occur when opening in 4.10.1 before any changes have been made in order to definitively rule the changes out as a factor.

We are still examining other possible causes based on the other factors you have listed and the recent logs you've posted. In the meantime, it would be helpful if you could post your results from opening the older version in both 4.9.2 and 4.10.1. -Thanks

avatar image Nyl0cke Dec 17 '15 at 04:16 AM

I'll try it out. I cloned a second copy and went back to right when I created the repo. I have to backup my computer since its been a while, but I'll try to get my results back by tomorrow. I just opened it and it compiled and plays without freezing. I have a few things to try (restarting, putting computer to sleep, etc) that will take a little while.

avatar image Steve Hardister ♦♦ STAFF Dec 17 '15 at 02:52 PM

Having had a chance to take a closer look at the logs you've provided, a couple of things stand out:

  1. The first is that it is failing to find the game mode:

2015.12.15-05.04.49:836][787]LogUObjectGlobals:Warning: Failed to find object 'Object /Script/OperationSnowball.OperationSnowballGameMode'

  1. The second is that the engine is running from where the Launcher would install it:

[2015.12.15-04.49.02:235][ 0]LogInit: Base directory: /Users/Shared/UnrealEngine/4.10/Engine/Binaries/Mac/

So, to clarify, how are you launching the Editor?

avatar image Nyl0cke Dec 17 '15 at 03:51 PM

I'm opening the Epic Launcher and launching the engine for the most part.

I'm not sure why it is looking for that game mode, I renamed it quite a while ago to OSGameMode.

avatar image Nyl0cke Dec 17 '15 at 03:58 PM

I just opened my 4.10.1 project and for some reason the default game mode was undefined in the project settings, even though I remember changing it to OSGameMode around 2-3 months ago when I changed the game mode name.

I'm unsure why this would cause compilation problems, why this wouldn't cause problems on Windows, or why it would make it impossible to play or compile other code or blueprint projects though.

avatar image MugenCity Dec 16 '15 at 04:38 AM

I'm experiencing the same symptoms on my project.

Does you stand-alone also crash? We're getting the freezing on Play-In-Editor and crashes in Standalone. We have run the project on another system it works correctly. So this is a bit strange.

Running the editor as a debug build from VS2015, it looks like the editor is getting hooked up on a Mutex (WaitForSingleObject).

See attached screenshot, for where, and callstack.

alt text

ue4 pie lockup.png (167.5 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I figured out my issue. A while ago I broke my sound card by plugging in an audio interface via the 3.5mm output jack on my computer and then powering the interface with a super sketchy USB wall wart PSU. My computer, unless plugged into my HDMI monitor or into my audio interface via USB does not have any sound devices. Any action I perform in Unreal that causes it to output sound without an audio device causes it to freeze.

I just tested this with my USB headphones. I tried to play in 4.9.2 and 4.10.1 without any audio devices plugged in and it froze. Once I connected the USB headphones it resumed and ran fine. I then tried compile in both without it plugged in and it froze. I plugged it back in and it resumed. Not sure why this is an issue on OS X but not on Windows (Bootcamp), as I have ran and compiled many times without any audio devices.

more ▼

answered Dec 19 '15 at 06:35 AM

avatar image

Nyl0cke
1 1 3 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question