x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 can't open project after updating to 4.10

I'm trying to update the project from 4.9.2 to 4.10, but loading of the updated project freezes each time at 73%. The process doesn't use CPU time and doesn't affect the disk. In my last attempt it continues for a more then 4 hours so, I guess, waiting is useless here. I also tried to recompile the project manually in VS2015 and launch as a debug instance, but with the same result. By the way, another test projects open without any problems after update to 4.10 on my system.

log: http://pastebin.com/keuLisNz

UPD. It stucks on initializing phase even if i choose 'skip conversation' option when i try to launch the project in 4.10. Any ideas? I really need to upgrade to 4.10.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 19 '15 at 09:50 AM in Bug Reports

avatar image

YuriNK
81 8 12 13

avatar image Doug E ♦♦ STAFF Nov 20 '15 at 08:43 PM

Hey YuriNK-

Are you using the Launcher version of the engine or are you using a source build? When upgrading the project did you do so from the project browser and select "Make a copy"? If you open the project directory and right click on the .uproject file and select Switch Engine Version are you able to open the project?

avatar image YuriNK Nov 21 '15 at 11:43 AM

It's a launcher engine version. I used both 'make a copy' and 'skip conversation'. And that's definitly a some problem with a blueprint classes derived from c++ classes.

Today I finally loaded updated project after replacing my own GameMode class to basic class. Then I faced a permanent crashes when tried to move another blueprints derived from c++ classes from one folder to another. But it looks like now I can move it after project folder renaming (i made it to avoid external reference warnings).

By the way, attemt to use my old c-derived GameMode class still can block project loading. So, to explain:

1) I have, for example, MyCppGameMode class and derived blueprint bp_MyCppGameMode created in 4.9. If I use bp_MyCppGameMode, project loading stucks at 73%.

2) If I set standart GameMode as a base class in class settings of the bp_MyCppGameMode blueprint, the project loads fine (but I have compile error, obviously).

3) If I create new bp_MyCppGameMode410 derived from MyCppGameMode in UE 4.10 and use it, game works. But, obviously, I have another compile errors here.

So I createed a new blueprint class and copied functions, variables and nodes from the old class. It works.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I tried to follow your example by setting up a GameMode created in code with a blueprint based off of it set in the editor and then upgrading the project from 4.9.2 to 4.10. The project was able to open without issue after the conversion. It's possible that the game mode (class or blueprint) became corrupted in the conversion process. I'm glad to hear that recreating the game mode solved the issue for you.

Cheers

Doug Wilson

more ▼

answered Nov 23 '15 at 02:17 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question